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ActivePresenter is the ultimate eLearning software with advanced video recording and editing 
features. It allows you to create various eLearning content types such as video demos, 
software simulations, quizzes, and games. Using responsive design and HTML5, your content 
is truly device-independent – it looks good and runs perfectly on any modern web browser and 
device. The SCORM- and xAPI-compliant outputs also integrate seamlessly with most well-
known Learning Management Systems. 

ActivePresenter User Interface 

Start Page  

The Start Page is the first thing you see when you launch ActivePresenter. It allows you to 
quickly start new projects as well as access useful resources such as templates and samples. 
During the edit phase, you can open the Start Page by clicking the ActivePresenter button at 

the top-left corner and select Start Page . 

  

The Start Page has many components which are grouped into two main areas: left pane and 
central part.  

On the left are two sections: 

• The Quick Start provides buttons to create new projects and open existing ones. 

o Click Blank Project to create a new project using the blank theme. 

o Click Record Video to record screen as video. 
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o Click Record Software Simulation to record a software simulation.  

o Click Responsive Project to create a new responsive project. 

o Click Import PowerPoint to convert a PowerPoint presentation into an 
ActivePresenter project.  

o Click Open to open an existing project, a slide template, a theme, an object 
template or a video file.  

• The Recent shows a list of recently opened projects. 

o Click a project or right-click it > Open to open a project in the list. 

o Right-click a project > Remove to remove a project from the list. 

o Right-click a project > Open Folder to open the containing folder of a project. 

In the center are three tabs: 

• The Templates tab shows all the built-in and custom themes/templates that you can 
click to create a new project using this theme/template. 

• The Samples tab contains useful ActivePresenter samples. 

• The Help tab provides access to user manual, product homepage, user community, 
activation/deactivation, update checking, and information about the current version. 

Workspace 

ActivePresenter workspace contains three main sections: tabbed toolbar (1), document 
window (2), and status bar (3). 

 

Tabbed Toolbar 

Located at the top of the application window, the tabbed toolbar contains almost all the tools 
for creating and editing content. There are ten core tabs always present and some contextual 
tabs that appear only when a particular object is selected. In each tab, related commands are 
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grouped into groups. When you point to a command, a tooltip appears explaining the 
command and giving the hotkey (if any). 

At the top-left of the tabbed toolbar is the ActivePresenter button. This button opens the 
ActivePresenter main menu that provides access to all common file operations, 
configuration settings, and list of recently opened projects. 

 

You can show or hide the tabbed toolbar by clicking the double arrow at its right corner. You 
can also personalize the toolbar the way you want.  

Document Window  

You can open more than one project at the same time. Then, the document window will display 
projects in tabs for easy navigation. The document window has components as follows: 

1. The Quick Access Toolbar contains commands for creating new projects, opening 
and saving projects, and undoing and redoing recent actions. 

2. The document tab enables you to navigate between open documents. You can also 
hover over this tab to view the project location, or right-click the tab to open the project 
folder. 

3. The Canvas is the central area of the document window. It displays slide contents and 
allows all spatial editing. 

4. The Slides pane displays thumbnail views of all slides in your project. 

5. The Timeline pane shows all the objects in a slide against time axis, letting you adjust 
and fine-tune the timing and duration of objects and animation effects. 

6. The Properties pane lets you edit almost all physical and behavioral properties of the 
selected objects. 

7. The Selection pane displays all the objects included in a slide. It allows you to view, 
reorder, change the selection, lock, and toggle the visibility state of objects. 

8. The Resources pane displays all resources in your project. 

9. The Slide Pools pane contains slide pools that are used to randomize slides and 
create dynamic quizzes.  
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10. The Object States pane contains states of objects. Object states allow you to change 
the appearance of an object in response to user interaction.   

11. The Object Templates pane contains object templates that are useful to save and 
reuse objects across slides in the same project or across projects.  

You can customize the workspace by showing, hiding, repositioning, and resizing panes. 
After customizing, if you want to go back to the original window layout, just click the View tab 

> Reset Pane Layout . Your change will be applied the next time you open the application. 

Status Bar 

Located at the bottom of the application window, the status bar displays information about the 
current project. It may vary from what slide you are on to the current status of a project. 
Besides, you can use tools at the right corner of the status bar to adjust the zoom level of 
the Canvas. 

 

ActivePresenter Editions 

ActivePresenter offers three editions: Free, Standard, and Pro. 

1. Free edition is designed for those who want to create video demonstrations. This 
edition allows a number of screen recording and video editing features. Projects can 
be exported to several video formats, namely MP4, AVI, WMV, WebM, and MKV. 
However, the outputs cannot be used for commercial purposes. 

2. Standard edition provides all the features available in the Free edition plus some 
advanced audio and video editing features and the capability to export a project to 
many document formats, namely HTML SlideShow, PDF Document, Microsoft Word, 
Microsoft Excel, Microsoft PowerPoint, and HTML5. The outputs can be used for 
commercial purposes.  

3. Pro edition is the most powerful one that allows creating impressive video 
demonstrations, interactive software simulations, and eLearning content. This edition 
is highly suitable for online learning designers, trainers, educators, technical 
supporters, and anyone who wants to create professional content.  

You have full access to all the features of ActivePresenter Pro in the Free edition for trial 
purpose. Watermark is added in non-free outputs. 

The following table compares the features between three editions. The features which are 
available in all the three editions aren’t listed. 
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Feature Free  
Edition 

Standard 
Edition 

Pro Edition 

Commercial Use    

Report & Tracking in LMS (SCORM, xAPI)    

Export To HTML5    

Export To Microsoft PowerPoint    

Export To Microsoft Excel    

Export To Microsoft Word    

Export To PDF Document    

Export To Video    

Export To Images    

Audio Fade In/Fade Out    

Audio Noise Reduction    

Audio Normalization    

Video Blur Effect    

Video Green Screen Effect    

System Requirements 

Here are system requirements for running ActivePresenter 7.5 on Windows and macOS. 

Operating 
System 

Windows 7 SP1 with Platform Update, Windows 8, and Windows 10. Only 
Windows 64-bit (x64) is supported. 

macOS 10.11 or later. 

The following features are only available on Windows: Microsoft Word 
Export, Microsoft Excel Export, Microsoft PowerPoint Import/Export. 

Hardware CPU: 1.0 GHz or faster processor with SSE2 (which is available from Intel 
Pentium 4) (1.5 GHz recent multi-cores or higher recommended). 

At least 2 GB of RAM. 

2 GB of available hard-disk space for installation and storing project files. 
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Sound card and microphone for audio recording. 

Software For HTML SlideShow or HTML5 playback, the following web browsers are 
supported: 

Windows: Mozilla Firefox 38 or later, Google Chrome 43 or later, Internet 
Explorer 11, and Microsoft Edge. 

macOS: Google Chrome 43 or later and Safari 9 or later. 

iOS 10 (or later): Safari (latest). 

Android 5.0 (or later): Chrome (latest). 

For Microsoft Word Export: Microsoft Word 2013 or later. 

For Microsoft Excel Export: Microsoft Excel 2013 or later. 

For Microsoft PowerPoint Import/Export: Microsoft PowerPoint 2013 or 
later. 

For recording system audio on OS X or macOS: Background Music is 
required. 

Installing ActivePresenter  

Installing Windows: After downloading the installer, double-click it and follow the 
instructions. To install ActivePresenter silently from the command line, you 
can use the /VERYSILENT flag. For example, call 
ActivePresenter_v7.5.0_setup.exe /VERYSILENT from scripts. 

macOS: After downloading the installer, double-click it and follow the 
instructions. 

Activating  The Free edition doesn’t need activation. To activate Standard and Pro 
editions, on the Start Page or in the open project window, click the Help 
tab > Activate Product. 

Updating To update an existing version, just download the latest version of the 
executable and double-click to run. There is no need to uninstall the older 
version first.  

You can also click the Help tab > Check Updates to have 
ActivePresenter check if there are new updates and do the update 
automatically.  

Upgrading To upgrade your license, please contact the support group. 

Uninstalling Windows: The standard way to uninstall ActivePresenter from your 
computer is to use the Control Panel > Programs and Features > 
ActivePresenter, and follow the instructions. 

Alternatively, open the folder in which you’ve installed the application, 
double-click the unins000.exe file, and follow the instructions.  

https://talk.atomisystems.com/
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macOS: In the Finder sidebar, click Applications, drag the app from the 
Applications folder to the Trash (located at the end of the Dock), then 
choose Finder > Empty Trash. 

Activating and Deactivating ActivePresenter 

Activating ActivePresenter 

While the Free edition needs no activation, you must activate the Standard and Pro editions 
using product keys. There are two ways to activate ActivePresenter: direct (automatic) and 
web (manual) activation. 

You can purchase a product key here.  

Direct Activation 

Direct activation requires an active internet connection. Do the following: 

1. Click Activate Product at the top-right corner of the application window. Alternatively, 

click the Help tab > Activate Product .  

2. In the dialog that appears, enter a product key in the Product Key text box. 

3. The default activation method is direct. Click Activate to activate the application.  

 

Note: Click Connection Settings to configure the network connection if your computer is 
behind a proxy. 

https://atomisystems.com/pricing/
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Web Activation 

To manually activate ActivePresenter, perform the two steps above, then do the following: 

1. In the Method section, open the Web tab. 

2. Click Get Confirmation Code to open a web page that gives you the code. 

3. Click Enter Confirmation Code to paste the code into the text box that appears. 

4. Click Activate. Note that this button is dimmed until you enter the confirmation code. 

  

Deactivating ActivePresenter  

There is a chance you want to launch ActivePresenter on another computer. In that case, you 
need to deactivate the application on the current computer before using the same product key 
on a new computer.  

To deactivate the application, on the Start Page or in the open project window, click the Help 

tab > Deactivate Product . In the dialog that appears, select Direct or Web in the Method 
section > Deactivate. This deactivates the application instantly. 

The Multi-tier System of Support 

ActivePresenter has a multi-tier system of support, as described below: 

Tooltips A tooltip system explains the purpose of all the toolbar buttons. Hover the 
mouse over any button to show a short description. 
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User manual A user manual (PDF file) contains extensive reference to all topics. Press 
F1 to open it. 

Demos The best way to learn a product is to watch someone actually using it. 
The website provides many excellent demos.  

Tutorials A large number of written and video tutorials are available to help. 

FAQ The user community answers all your queries. But it is always better to 
first check whether your query is already listed in the FAQ section. If you 
have any feature in mind, you can also post a new feature request.  

Email support If you need any help or further information about ActivePresenter, you 
can send an email to the support team.  

Phone support For urgent support needs, contact +8424-3755-8373. 

https://atomisystems.com/activepresenter/demo/
https://atomisystems.com/activepresenter/tutorials/
https://www.youtube.com/user/ActivePresenter
https://talk.atomisystems.com/c/activepresenter
https://atomisystems.com/faq/
https://talk.atomisystems.com/c/activepresenter/feature-requests
https://atomisystems.com/contact/
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Creating Blank Projects 

A blank project is a project that contains blank slides where you can add contents such as 
images, video/audio clips, and slides from ActivePresenter projects or PowerPoint 
presentations. You can also add new recorded slides to a project by recording screen as video 
or as software simulations.  

To create a blank project, on the Start Page > Blank Project. Alternatively, in the open project 
window, click the ActivePresenter button > Blank Project. ActivePresenter will launch a new 
project with the default theme. 

By default, the new project will have one blank slide with the layout corresponding to the 

theme. You can add more slides by clicking the Home tab > New Slide , or in the Slide tab 

> New Slide . The new slide will be inserted after the slide that you are selecting.  

If you want to create a new slide with a different layout, click the arrow on the New Slide button 
and select a slide layout from the drop-down list. 

Changing Slide Size 

The new project that you’ve created has the default slide size (1280x720), and you can change 
it if needed. Note that you cannot change the slide size for a responsive project.  

Note: If you want to change the default slide size when creating a new blank project, click the 

ActivePresenter button > Project > Project Properties > Project Size.  

To change the slide size, click the Design tab > Slide Size . The following dialog will 
appear: 
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1. Preset Size: You can choose to quickly apply one of the preset sizes from the Preset Size 
drop-down list. The list contains different sizes ranging from small to large. You can also 
specify the new size by entering values in the Width and Height spin boxes, or clicking the 
up/down arrow button to increase/decrease the size respectively. 

2. Lock Aspect Ratio: By selecting this check box, ActivePresenter will automatically change 
the height according to the width, and vice versa so that the aspect ratio can be maintained. 

The new slide size that you select can be either smaller or larger than the previous size, so 
you have further options to adjust the contents of the slides. Two cases are described in details 
in the next parts.  

3. If the new size is smaller than the current slide size, do one of the following:  

o Select Scale to Fit to scale the contents to fit the new slide size. If you select Scale 
All Objects, all the objects in slides will be scaled to fit the new slide size, including 
placeholders in slides and slide masters. Otherwise, objects will keep their original 
sizes which are sometimes too large in comparison with the new slide size. However, 
you can adjust their sizes after that.  

o Select Crop > Next to crop the contents. The following dialog will appear: 
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To crop a slide, drag the orange frame to the desired position. You can crop each slide 
individually or all of them at once: 

Crop each slide individually: Select the slide from the Slide list box or click the  

and  buttons, then drag the orange frame to the desired position.  

Crop all slides at once: Select any slide of the project, drag the orange frame to the 
desired position, then click Apply to All Slides. All slides will be cropped at the same 
position.  

Note: When you choose to crop the slide in any position, objects and placeholders of 
the slide or slide master will not be cut. They keep their original sizes and you can 
manually drag their handles to fit the new slide size. 

4. If the new size is larger than the current slide size, do one of the following:  
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o Select Scale to Fit to scale the contents in order to fit the new slide size. This is similar 
to the Scale to Fit command mentioned above when the new slide size is smaller than 
the previous slide size.  

If you select Scale All Objects, all the objects in slides will be scaled to fit the new 
slide size, including placeholders in slides and slide master. Otherwise, objects will 
keep their original sizes which are sometimes too small in comparison with the new 
slide size. However, you can adjust their sizes after that.  

o Select Fill Background, then select the slide position where the contents will fill in 
from the Slide Position drop-down list, then click OK.  

Creating Responsive Projects 

Responsive design in ActivePresenter allows you to create a single project which displays 
perfectly in any devices which have different screen sizes. ActivePresenter defines five default 
responsive layouts which correspond to most popular device screen sizes:  

• Desktop with the viewport of 1280x620 

• Tablet Landscape with the viewport of 1024x674 

• Tablet Portrait with the viewport of 768x930 

• Mobile Landscape with the viewport of 667x345 

• Mobile Portrait with the viewport of 375x522 

Note that the above layout sizes are not the device viewport sizes. They are chosen to make 
sure that the content displays best on popular devices. You can add a responsive layout to 
support a particular device if you want. Besides, in the responsive mode, ActivePresenter also 
supports a flexible coordinate system with percentage, pixel, and auto units so the content still 
looks good with other screen sizes which are not in the list of responsive layouts of the project. 
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To create a responsive project, launch ActivePresenter and click Responsive Project on the 
Start Page. 

Alternatively, in the open project window, click the ActivePresenter button > Responsive 
Project. ActivePresenter will create a project with five different layouts which are Desktop, 
Tablet Landscape, Table Portrait, Mobile Landscape, and Mobile Portrait. 

 

Viewport of Responsive Layout 

Screen size 

The screen size is the physical measurement diagonally of the screen in inches.  

Resolution 

The resolution is the number of pixels on screen often displayed as a width by height (i.e. 
1024×768).  

Viewport 

Because devices with the same screen size can have very different resolutions, we use 
viewports when creating mobile friendly content. Viewports are scaled down versions of 
resolutions that allows sites to be viewed more consistently across different devices. You can 
find the viewport sizes of popular devices at https://material.io/devices (in the column with 
dp unit). 

How is the size of a responsive layout calculated in ActivePresenter? 

Viewport of the responsive layout is the actual visible area of the content when displaying in 
browser excluding the HTML5 player toolbar if any. 

For example, the Mobile Portrait is based on the viewport of iPhone 6, 7, or 8 (375x667). After 
excluding the Safari browser title and navigation bars and the HTML5 player toolbar (width: 
100%, height: 30), the layout size is 375x522. But with Mobile Landscape, Safari browser 
automatically hides the title and navigation bars so the layout size is 667x345. 

Managing Responsive Layouts 

Adding Layouts 

To add a new layout, click the drop-down button on the Responsive bar (on the top of 
document window) and select Add New.  

You can select one of the layouts provided or have a custom size by clicking Custom... and 
adjusting the size for the new layout. 

https://material.io/devices/
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Removing Layouts 

To remove a layout, select it and click the drop-down button on the Responsive bar > 
Remove... > OK. 

Changing Layout Name 

To rename a layout, select it and click the drop-down button on the Responsive bar > 
Rename... > type the new name in the Name text box > OK. 

Changing the Current Layout 

To switch between layouts, click the drop-down button on the Responsive bar > select a 
layout from the drop-down list. Alternatively, you can click directly one of those layouts on the 
Responsive bar.  

Changing Layout Height 

The Canvas shows the Layout Height control which indicates the current height of the 
responsive layout. 

To change the layout height, do the following: 

1. Click the Properties pane > Slide Properties > Layout Height > Layout Height. This 
displays the Layout Height control on the Canvas. 

2. Drag the Layout Height control up or down to decrease or increase the height 
respectively.  
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Alternatively, you can enter a value in the Layout Height spin box to get the same result. 

 

Changing Layout Width 

You can resize the layout width by moving the handles on Responsive bar to the left or right. 
However, the new width must be in the width range of the currently selected layout. This 
means if you are selecting the Table Portrait device layout, you can drag the handles within 
the width range of this layout only.  
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Changing Slide Height 

In common cases, you place the content inside the area which is limited layout width and 
layout height. However, for device with small viewport, you may want to have more space to 
place content. In that case, you can increase the slide height.  

To change the slide height, do the following:  

1. Click the Properties pane > Slide Properties > Layout Height > Custom Slide 
Height. This enables the Custom Slide Height function.  

2. Enter a value in the Custom Slide Height spin box. Or drag the Layout Height control 
up or down to decrease or increase the height respectively.  

If the slide height is bigger than the layout height, end users can view the contents beyond the 
layout by scrolling the bar on their devices.  

The slide width is always the same as the layout width.  

Changing Object Position Mode 

Position Mode is the exact specification of the object position in a slide of a project. To change 
this value of an object, select that object > Properties pane > Size & Properties tab > 
Transform > select one from four modes (Top-Left, Top-Right, Bottom-Right, or Bottom-Left). 

Changing Object Position and Size  

These values define the object position in a slide. To change those values, in the Properties 
pane > Size & Properties tab > Transform > adjust values of Top, Left, Right, Bottom, Width, 
and Height (in percentages or pixels) by entering values in those spin boxes. You can also 
click up/down arrow buttons next to the spin boxes to increase/decrease values.  

The values (Top, Left, Right, and Bottom) displayed in this section depend on the Position 
Mode type you select. For example, if you select the Bottom-Right mode, this section will show 
Bottom and Right value instead of showing Top and Left value when you select the Top-Left 
mode.   

If you want to keep the height-to-width ratio when changing the object width, select Auto from 
the Unit combo box next to the Height spin box. This option automatically changes the height 
according to the width.  

To rotate the object, along with dragging the rotation handle of the object, you can enter a 
value in the Rotation spin box.    

Changing Object Position Value Unit 

You can change the unit of object position value between percentages (%) and pixels (px). To 
do that, in the Properties pane > Size & Properties tab > Transform > Unit combo box next 
to the Size spin boxes > select %, px, or Auto (for Height unit). 

• Choose the % unit if you want the object position to be a percentage of 
left/top/width/height. 

• Choose the px unit if you want the object position to be a number of pixels of 
left/top/width/height. 

• Choose Auto for the height unit to retain the aspect ratio.  

Either the unit you choose, the size and position of the object should remain unchanged.  
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Aligning Horizontal/Vertical Center 

You can align objects in the center of the slide in all layouts of responsive projects. To do that, 
in the Properties pane > Size & Properties tab > Transform > Align Horizontal Center or 
Align Vertical Center. 

If you select both check boxes, objects will be aligned both horizontal and vertical center of 
the slide and you cannot move the object either in the horizontal or vertical direction.  

• Align Horizontal Center: The object will be aligned horizontal center and you can 
move the object only in the vertical direction of the slide. You cannot move it 
horizontally.  

• Align Vertical Center: The object will be aligned vertically center and you can move 
the object only in the horizontal direction of the slide. You cannot move it vertically. 

Scaling Text  

With the Text Scale feature, ActivePresenter allows you to reduce the text size on smaller 
devices. You can scale the text to a specified percentage of its original size. For that to happen, 
select the text > Properties pane > Size & Properties tab > Transform > Text Scale.  

Showing/Hiding Objects in Individual Responsive Layout 

ActivePresenter allows showing or hiding the object in each layout individually. To do that, in 
the layout that you want to hide the object, select that object > Properties pane > Size & 
Properties tab > Transform > Hidden in Current Layout.  

Creating Projects from PowerPoint Presentation 

This is a content-generation method where slides from a PowerPoint presentation are used 
instead of recording a target application or creating a blank project.  

To create a new project from PowerPoint slides, on the Start Page > Import PowerPoint > 
select the PowerPoint file from your computer. Alternatively, in the open project window, click 
the ActivePresenter button > Import PowerPoint > select the PowerPoint file from your 
computer.  

Note: ActivePresenter cannot handle the *.odp files created by OpenOffice and LibreOffice. 
You have to convert these files to pptx files first, then import them into ActivePresenter.  

After that, ActivePresenter will display the following window: 
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You now have the following two options: 

• Import Slides as Backgrounds: Each slide turns into a background image for a 
corresponding slide in ActivePresenter project. All the separate objects in the pptx/ppt 
slides will be flattened into one image, and you cannot manipulate/animate them.  

• Process Objects in Slides: All the objects in each PowerPoint slide are imported into 
the corresponding ActivePresenter slide. You can manipulate those objects and 
annotate the slides in ActivePresenter.  

Note: By default, all PowerPoint slides are selected. You can click the slides that you don’t 
want to import to clear the selection. Click Deselect All to select no slides. If you want to select 
multiple slides, hold down SHIFT or CTRL while clicking the slides. After that, click OK to 
import them into ActivePresenter. 

Creating Projects from Themes or Templates 

Creating projects from themes or templates can save you a lot of time in designing contents 
because you can reuse the project preferences (e.g. slide layouts, object properties) across 
multiple projects. It also ensures the workflow consistency especially when multiple authors 
are working on similar projects. 

An ActivePresenter theme or template contains the following: 

• Slide master which includes predefined slide layouts. Each layout may have additional 
decoration content. 

• Predefined colors and fonts. 
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• Object settings if any (otherwise, default program settings will be used). 

• For template, there are some pre-created slides with content. 

To create a template-based project, on the Start Page > Templates tab > select a them or 
template.  

In the Template tab, you can right-click any theme to open the context menu: 

• Preview: Preview the theme. 

• Blank Project: Create a blank project with the theme you are currently selecting.  

• Record Video: Record a video demonstration.  

• Record Software Simulation: Record a software simulation.  

• Responsive Project: Create a responsive project with the theme that you are currently 
selecting.  

• Set as Default Theme: Set the theme as the default them. 

Creating Projects from Video Files 

ActivePresenter allows you to create projects from video files, in which your desired video will 
be opened in a completely new ActivePresenter project. That new project will have the same 
size as the video size.  

To create a project from a video, do the following:  

1. On the Start Page, click Open. Or, in the open project window, click the 
ActivePresenter button > Open Project…. 

2. In the Files of type combo box, select All Support Types or Video Files. 

3. Browse the video files in your computer and select one. 

4. Click Open. 

After that, you can still resize and reposition the video as a normal object. 

Converting Projects 

Converting from Responsive to Non-Responsive Projects 

ActivePresenter allows you to convert from responsive to non-responsive projects. To get it 
done, click the ActivePresenter button > Project > Convert to Non-Responsive Project... 
> select one of the layouts. The project will be converted to a non-responsive project having 
the layout that you have chosen, without affecting object positions.  

Converting from Non-Responsive to Responsive Projects 

This feature allows you to convert from a non-responsive project to a responsive project having 
up to five default responsive layouts. To get it done, click the ActivePresenter button > 
Project > Convert to Responsive Project… The following dialog will appear:  
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• Current Project Size: Show the slide size of the currently working project.  

• Insert Preset Layouts: Choose which device layouts to insert into the new responsive 
project.   

• Convert Size & Position to Percent Unit: Convert unit from pixels to percentages.  

• Scale Content: Choose to scale the content in width, height or both dimensions.  

• Maintain Aspect Ratio: ActivePresenter will maintain the height-to-width ratio of the 
slide size and scale the contents.   

Saving Projects  

Saving Projects 

After creating and editing a project, you can save it easily by clicking Save  in the Quick 
Access Toolbar, or by using the CTRL+S hotkey. You can also click the ActivePresenter 
button > Save to get the same result. 

Alternatively, you can right-click the name of the project that you want to save on the document 
tab, then click Save.  

Note that when you save a project created with an older version, ActivePresenter will 
automatically save it in the new format, and those files cannot be opened with the older 
versions anymore. In such case, ActivePresenter will warn you with a dialog. 
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Saving Projects as Different Types 

ActivePresenter allows you to save existing projects to four types: Project, slide template, 
object template, and theme so that you can reuse them as the basis for other projects.  

To do that, in the open project window, click the ActivePresenter button > Save As… > select 
a type from the Save as type drop-down list. You can also right-click the name of the project 
that you want to save on the document tab, and click Save As… > select a type from the Save 
as type drop-down list.  

 

• ActivePresenter Projects (*.approj): Save existing projects as normal projects with 
all editing you’ve made. To know how to open an ActivePresenter project, see 
Opening Existing Projects.  

• ActivePresenter Slide Template (*.apslide): Save existing projects as slide 
templates. If you save templates in the C:\Users\\Documents\ActivePresenter 
Templates folder (for Windows) or /Users//Documents/ActivePresenter Templates 
folder (for macOS), they will be shown as custom themes on the Start Page. 

• ActivePresenter Object Template (*.apobject): Save existing projects as object 
templates. If you save templates in the C:\Users\\Documents\ActivePresenter 
Templates folder (for Windows) or /Users//Documents/ActivePresenter Templates 
folder (for macOS), they will be shown in the Object Templates pane.  

• ActivePresenter Theme (*.aptheme): Save existing projects as themes. If you save 
themes in the C:\Users\\Documents\ActivePresenter Templates folder (for Windows) 
or /Users//Documents/ActivePresenter Templates folder (for macOS), they will be 
shown as custom themes in the Design tab and Start Page.  

To open any type of project, do one of the following: 

• On the Start Page > Open > select one project type from the Files of type drop-down 
list > select a project. 

• In the open project window > ActivePresenter button > Open Projects… > select one 
project type from the Files of type drop-down list > select one project. 

• In the open project window > click the   button in the Quick Access Toolbar > select 
one project type from the Files of type drop-down list > select one project. 

• Use the CTRL+O hotkey. ActivePresenter will open the folder containing 
ActivePresenter projects for you to select. Now you can select one project type from 
the Files of type drop-down list. 

Shrinking Projects 

A project containing unused resources can be increased in size. Its size can also be increased 
after some editing operations. You can choose to reduce the size by shrinking your project. 
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To get it done, click the ActivePresenter button > Project > Shrink.... ActivePresenter will 
display the following dialog: 

 

To remove all unused resources, click the Delete All Unused Resources > Shrink. 

You can also manually choose which resources to remove by clicking the Delete Manually 
button. The Project Resources dialog will appear having two tabs. While the Images tab 
contains all images of the project, the Audio & Video tab contains all audio and video files of 
the project. 

Click the items that you want to remove, then click the Delete icon  at the top of the dialog. 

You can click the Select unused items button  to let ActivePresenter select all unused 

resources for you, then click the Delete icon . 

Opening Existing Projects 

When you have existing ActivePresenter projects, you can open them again easily. 

Do one of the following: 

• In the open project window, click the ActivePresenter button > Recent Projects > 

select a project, or click the  button in the Quick Access Toolbar > select a project.  

• Use the CTRL+O hotkey. ActivePresenter opens the folder containing ActivePresenter 
projects for you to select. 

• On the Start Page, select one project from the Recent list to open it.  
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Recording Videos  

You can use ActivePresenter to record the computer screen to create a video demo to show 
how your products or services look like. A recorded project captures truthfully all live actions 
on screen along with mouse and keyboard actions while you are interacting with the target 
application.  

To record a new project, do one of the following: 

• On the Start Page, click Record Video. 

• In the open project window, click the ActivePresenter button > Record Video. 

After that the following dialog will appear: 

 

Recording Area Section  

This section allows you to specify the region on the computer screen to capture.  

 

• Full Screen: Allow you to capture the entire computer screen. When you select this 
mode, the entire screen will be treated as the recording window and the blue rectangle 
is invisible. Besides, ActivePresenter will temporarily change the screen resolution 
before capturing and automatically revert to the previous setting when you finish 
capturing.  

• Custom: Allow you to customize the captured screen in any size and direction by 
dragging the floating blue rectangle. ActivePresenter will capture anything that 
happens inside this blue rectangle while ignoring the rest of the screen. The fancy 
cross hair in the middle is just a visual reminder that this is a target-seeker window. 
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Alternatively, you can specify the captured frame size by entering the width and height 
value in the Size spin boxes. Besides, ActivePresenter provides some popular preset 
video sizes. You can quickly apply them by using the Preset Sizes button next to the 
spin boxes (the down arrow next to the Size spin boxes). 

Click Lock to application to select a running application window to snap into the 
captured area. The Change Lock Mode button next to the list-of-application combo 
box provides two options to define the snap behavior. The Fit To Boundary option will 
resize the window of the selected application to fit the recording area. On the other 
hand, the Fit To Application option will resize the recording area to fit the window of 
the selected application.  

Audio and Webcam Section  

This section provides options for recording audio and webcam during the recording screen. 
You can record system audio, audio from microphone and webcam simultaneously, which is 
common in the practice. 

Audio Section 

 

Click the  button to enable audio recording. The following options become available: 
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• Input Devices: Select the input device such as microphone. If you don’t want to record 
any input device, select Do not record microphone. 

• System Audio: Select the system audio (also speaker sound). If you don’t want to 
record any system audio, select Do not record system audio. 

• The Volume slider displays the input audio signal level for the audio input device. 
Before actual recording, you can speak something into the microphone to test the 
sound. 

The system audio volume can be changed by using the adjust volume tool in your computer. 

Webcam Section 

Recording screen and webcam video simultaneously comes in handy for instructional 
purposes such as presentations or game streaming.  

To record webcam video, do the following: 

1. In the Record Video Project dialog, click the  button to enable webcam recording. 
A live preview of the camera appears next to the button.  

2. Click the arrow on the  button to select the webcam. 

 

3. Adjust the following two webcam options if you wish: 

o Click Webcam Properties to adjust video signal and camera control.  

o Click Format Settings to fine-tune video format and compression.  

4. Click Record to start a capture session. 

After capturing, you will get a slide that displays a screencast and the webcam video at the 
bottom-right corner of it. You can reposition, resize, and edit the webcam video the same way 
as what you do with a normal video. 
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Record Button and Settings 

The Record button is a big red button which you can click to start recording. After clicking this 

button, there will be an ActivePresenter icon appearing in the system tray .  

 

The gear icon at the top-right corner of the dialog allows you to adjust the following options:  

 

• Recording Settings…: Launch the Recording Settings for Video dialog where you 
can change the settings for audio and video, cursor, and hotkeys. 

• Show Recording Area: Show the blue rectangle which indicates the recorded screen 
area. 
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• Show Recording Toolbar: Display a toolbar with all necessary controls for the 
recording. You can click the gear icon at the top-right corner of the toolbar to toggle its 
sections. 

 

The Statistics section shows the following project statistics:  

o Mode: Show the current recording project mode (Video). 

o Frames: Show the current frame number of the recording project.  

o Dropped: Show the number of missed frames of the recorded video. 

• Use Direct3D for Recording Screen: AP may record screen with a very high frame 
rate without overloading.   

• Calibrate Audio Input…: Open the Calibrate Audio Input dialog which allows you to 
change the audio input volume automatically or manually. 

When you finish the recording, click the Stop Recording button, ActivePresenter will end the 
recording and enter the edit mode with an intuitive interface. You can also use the hotkey 
CTRL+END to stop the recording.  

Recording Software Simulations 

Creating Software Simulation is a great way to show others how you practice an application 
or software engagingly and lively. Using this feature, you will have a project containing a series 
of slides describing how to achieve a specified purpose with the application you are capturing.  

To capture a new project, do one of the following: 

• On the Start Page, click Record Software Simulation. 

• In the open project window, click the ActivePresenter button > Record Software 
Simulation. 

The following dialog will appear: 
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Recording Area Section 

This section allows you to specify the region on the computer screen to capture. It has the 
same properties and functions as the Recording Area section when you record a video 
project.  

Audio Section  

This section provides the option for audio recording. You can record system audio and audio 
from microphone simultaneously. For creating software simulations, recording webcam isn’t 
available. 

Record Button and Settings 

This section is the same as that of the Record Video Project dialog, except the following two 
differences: 

• When you click the gear icon > Recording Settings…, you open the Recording 
Settings for Software Simulation dialog where you can change the settings for audio 
and video, cursor and hotkeys. 

• The mode of the recording can be either Video or Slide. Whenever you scroll the 
mouse or carry a drag-n-drop action, ActivePresenter will automatically switch to the 
Full Motion Recording mode (Video). Otherwise, it will switch back to previous capture 
mode (Slide). The recording mode is shown in the Recording toolbar. 

How to Stop Recording 

When you’re done with recording a project, stop the recording and start to edit it. Press 
CTRL+END on your keyboard to end the recording.  

Alternatively, you can stop the recording using the Recording toolbar. On the system tray of 
your computer, click the ActivePresenter icon  to show the toolbar. If the Recording toolbar 
is currently shown on screen, skip this step.   

• Click the Pause button  to pause the recording for a while. Click on it again to 
continue recording. You can also press SPACE BAR to pause and resume the 
recording.  

• Click the Stop button  to end the recording and step into the editing process. 

• Click the Discard button  to discard the recording. In this case, ActivePresenter will 
offer you three further options:      

o Discard: Abort the current recording without saving the recorded project. 

o Re-capture: Abort the current recording without saving the recorded project and 
start a new recording project with previous settings. 

o Continue: Resume the current recording. 
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Using Themes 

A theme is a set of design elements, including colors, fonts, background styles, and layouts. 
Using themes is a quick way to give your slides a consistent and attractive look and feel. 

A design theme consists of: 

• A set of theme colors that contains four text and background colors and eight accent 
colors for objects. 

• A set of theme fonts that contains fonts for the heading and body text. 

• A set of twelve preset background styles that defines the color of the slide 
background. 

• A slide master that defines the formatting and placement of text and objects in a slide. 
Each slide master has a master layout and a set of custom layouts. If you use more 
than one theme in your project, that project will have more than one slide master (and 
sets of layouts).  

Available themes are displayed on the Start Page. From here, you can click a theme to create 
a new project using it. In the open project window, you can view thumbnails of available 
themes in the Design tab. In this tab, just click the arrow at the bottom-right corner of the 
theme gallery to expand the list. 

The theme applied to the current slide will be displayed with a gray outline in the This Project 
section. Below this section are two sections for any Custom themes you’ve created and the 
Built-in themes of ActivePresenter. You can hover the mouse over each thumbnail to see a 
live preview before applying a theme.  
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Applying Themes 

ActivePresenter lets you apply different themes to different slides in your project. To apply a 
theme to the current slide, in the Design tab, click a theme thumbnail. The selected theme is 
also applied to any other slides using the same theme with the current slide.  

You can also right-click a thumbnail and choose the following options: 

 

• Apply to Matching Slides: This applies the theme to all slides that use the same slide 
master as the current slide. Slides using other slide masters remain unchanged. This 
option has the same effect as you left-click a theme thumbnail. 
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• Apply to Selected Slides: This applies the theme to the selected slides only. 

• Apply to All Slides: This applies the theme to all slides in your project. 

• Delete...: This removes the selected custom theme. (This option isn’t available for built-
in themes.) 

• Set as Default Theme: This sets the theme as the default for new projects.  

Note: If your desired theme (*.aptheme) doesn’t appear in the theme gallery, do one of the 
following: 

• Copy the theme file to the ActivePresenter Templates folder 
(C:\Users\\Documents\ActivePresenter Templates (for Windows) or 
/Users//Documents/ActivePresenter Templates (for macOS)). Then, restart the app to 
see the theme appear in the theme gallery. 

• Click the Design tab > theme gallery > Browse for Themes… to look for this theme 
and select it. 

Customizing Built-In Themes and Saving as Custom Themes 

You can make the following changes to a built-in theme: 

• Changing the theme colors. 

• Changing the theme fonts. 

• Changing the preset background styles. 

• Changing items in the slide master. 

Changes you make to a theme will be saved within the current project. If you want to reuse 
the custom theme for other projects, do the following: 

1. Click the Design tab.  

2. Expand the theme gallery by clicking the arrow at its bottom-right corner. 

3. Click Save Current Theme….  

 

This will save the current theme as a custom one. When you open another project, in the 
Design tab, custom themes are available in the Custom section of the theme gallery. If you 
don’t want a custom theme anymore, right-click it > Delete.  

Working with Theme Colors 

ActivePresenter includes sets of built-in theme colors that determine the default color choices 
for text, background, fill styles, and outlines. You can use built-in theme colors or set up your 
own sets to fit your needs. 

To see available theme colors, in the Design tab, click the Colors button . This opens the 
theme color gallery that contains both Custom and Built-in theme colors. Each set of theme 
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colors contains four colors for text and background and eight accent colors for objects. The 
theme colors in use are shown with a gray outline. You can hover the mouse over a set of 
theme colors to see a live preview before applying it. 

 

Applying Theme Colors 

To apply a set of theme colors, do the following: 

1. Click the Design tab > Colors  to open the theme color gallery.  

2. Click a theme color set to apply it to the current slide and any other slides sharing the 
same slide master with the current one. 

You can also right-click a theme color set and choose the following options: 
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• Apply to Matching Slides: This applies the theme colors to all slides that use the 
same slide master as the current slide. This option has the same effect as you left-
click a set of theme colors. 

• Apply to Selected Slides: This applies the theme colors to the selected slides only. If 
the change doesn’t satisfy you, click Reset Slide Theme Colors to restore the original 
colors.  

• Apply to All Slides: This applies the theme colors to all slides in your project. 

• Edit…: This lets you modify the selected custom theme colors. This option isn’t 
available for built-in theme colors. 

• Delete...: This removes the selected custom theme colors. This option isn’t available 
for built-in theme colors. 

Creating Custom Theme Colors 

To create a set of custom theme colors, do the following: 

1. Click the Design tab > Colors  to open the theme color gallery. 

2. Click Create New Theme Colors…. 

3. In the dialog that appears, assign a color to each item. If you don’t see the color you 
want in the color picker, click More Colors.... You can also click Eyedropper… to 
sample a color from within the application window. 
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4. If you want to discard all changes and start over, click Reset. 

5. In the Name text box, enter a name for your new theme colors. 

6. Click Save to save changes. The custom theme colors are now available in all projects. 

After that, in the theme color gallery, you can right-click a set of custom theme colors > Edit… 
to modify it. If you don’t want a set of custom theme colors anymore, right-click it > Delete…. 

Working with Theme Fonts 

You can apply a consistent set of theme fonts to an entire project. Theme fonts allow you to 
quickly change the fonts used for all the objects in a slide, including slide titles, shapes, text 
captions, text boxes, buttons as well as text in questions and answer choices. You can use 
built-in theme fonts or create your own theme fonts as you wish. 

To see available theme fonts, in the Design tab, click the Fonts button . This opens the 
theme font gallery that contains both Custom and Built-in theme fonts. Each set of theme 
fonts contains a heading font for slide titles and a body font for body text. The theme fonts in 
use are shown with a gray outline. You can hover the mouse over a set of theme fonts to see 
a live preview before applying it. 
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Applying Theme Fonts 

To apply a set of theme fonts, do the following: 

1. Click the Design tab > Fonts  to open the theme font gallery.  
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2. Click a theme font set to apply it to the current slide and any other slides sharing the 
same slide master with the current one. 

You can also right-click a theme font set and choose the following options: 

 

• Apply to Matching Slides: This applies the theme fonts to all slides that use the same 
slide master as the current slide. This option has the same effect as you left-click a set 
of theme fonts. 

• Apply to Selected Slides: This applies the theme fonts to the selected slides only. If 
the change doesn’t satisfy you, click Reset Slide Theme Fonts to restore the original 
fonts.  

• Apply to All Slides: This applies the theme fonts to all slides in your project. 

• Edit…: This lets you modify the selected custom theme fonts. This option isn’t 
available for built-in theme fonts. 

• Delete...: This removes the selected custom theme fonts. This option isn’t available for 
built-in theme fonts. 

Creating Custom Theme Fonts 

To create a set of custom theme fonts, do the following: 

1. Click the Design tab > Fonts  to open the theme font gallery. 

2. Click Create New Theme Fonts…. 

3. In the dialog that appears, specify the heading and body fonts. You can preview the 
fonts in the Sample box. 
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4. In the Name text box, enter a name for your new theme fonts. 

5. Click Save to save changes. The custom theme fonts are now available in all projects. 

After that, in the theme font gallery, you can right-click a set of custom theme fonts > Edit… 
to modify it. If you don’t want a set of custom theme fonts anymore, right-click it > Delete…. 

Working with Preset Background Styles 

Each theme comes with a set of twelve preset background styles that can be used to quickly 
change the background fill in a slide. You can also customize the preset background styles as 
you wish. 

To see the preset background styles, click the Design tab > Background Styles . This 
opens the preset background gallery that contains twelve styles. The colors of these styles 
depend on the theme colors of the project. The background style in use is shown with a gray 
outline. You can hover the mouse over a style to see a live preview before applying it. 

 



ActivePresenter User Manual  Version 7.5 

Working with Themes > Using Themes 50 

Applying Preset Background Styles 

To apply a preset background style, do the following: 

1. Click the Design tab > Background Styles  to open the preset background gallery.  

2. Click a style to apply it to the current slide and any other slides sharing the same slide 
master with the current one.  

You can also right-click a style and choose the following options: 

 

• Apply to Matching Slides: This applies the style to all slides that use the same slide 
master as the current slide. This option has the same effect as you left-click a style. 

• Apply to Selected Slides: This applies the style to the selected slides only. If the 
change doesn’t satisfy you, click Reset Slide Background to restore the original 
background style.  

• Apply to All Slides: This applies the style to all slides in your project. 

Note: In a slide, you can hide the background graphics originating from the slide master. Just 
select Hide Background Graphics.  

Customizing Preset Background Styles 

You can customize the preset background styles in the slide master view. Do the following: 

1. Select the slide that you want to modify its preset background style. 

2. Click the View tab > Slide Master to open the slide master view. In the left pane, the 
layout used by the current slide is selected. 

3. Click the Properties pane > Slide Properties > Background Fill. Use options in this 
section to modify the background style. 



ActivePresenter User Manual  Version 7.5 

Working with Themes > Using Slide Masters 51 

 

4. To hide the background graphics originating from the slide master, select Hide 
Background Graphics. 

5. If you want to discard all changes and start over, click Reset Background. 

6. Click Apply to Preset and select a preset background you wish to change. The new 
style will be applied immediately. 

Using Slide Masters 

Slide masters allow you to easily design the default themes, colors, fonts, background styles, 
text, and objects for slides. Besides formatting, slide masters let you determine the placement 
of objects in slides. Thus, you can use slide masters to apply the same look and feel to multiple 
slides in your project. 

Opening and Closing Slide Master View 

To view and customize slide masters, you need to switch to the slide master view. Click the 

View tab > Slide Master  to open the slide master view where any slide master previously 
set up for the project appears in the left pane. If you create a blank project or haven’t designed 
any slide master yet, you will see a default slide master. 

A slide master consists of a master layout and a set of custom layouts. In the left pane, the 
master layout is the first thumbnail which appears slightly larger than all other thumbnails of 
custom layouts below it.  
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Custom layouts inherit all the properties from the master layout. However, you can make 
changes to each custom layout as you wish. All changed properties will be no longer inherited 
from the master layout. You can create a new slide master or add more custom layouts to a 
slide master if you want. 

In the tabbed toolbar, the Slide Master tab appears with a set of commands for customizing 
slide masters. When you’re done, click the Close Master View button to switch to the normal 
view and edit slides. Changes you make to slide masters and their layouts will be automatically 
applied to slides based on them. 

 

Adding Slide Masters and Layouts 

To add a new slide master, click the Slide Master tab > Insert Slide Master . Alternatively, 
right-click in the left pane > Insert Slide Master. The new slide master will be inserted below 
the selected slide master. 

To add more custom layouts to a slide master, do the following: 

1. In the left pane, select the slide master to which you want to add more layouts. 
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2. Click the Slide Master tab > Insert Layout . You can also right-click in the left pane 
> Insert Layout.  

The new custom layout will be inserted below the selected layout. It has a default title 
placeholder and three footer placeholders. 

Managing Slide Masters and Layouts 

Duplicating Slide Master and Layouts 

You can duplicate a slide master or layout to create a similar one. In the left pane, right-click 

the master layout or a custom one > Duplicate Master/Layout . 

Copying Slide Masters and Layouts 

To copy a slide master or layout, in the left pane, click the master layout or a custom one and 

press CTRL+C or right-click them > Copy . 

When copying slide masters, click Paste  or Paste (Keep Source Formatting)  to 
duplicate it. 

When copying custom layouts, do one of the following: 

• To take the theme of the destination slide master: Press CTRL+V or right-click > Paste 
to paste the copied layout in the destination slide master. This layout will adapt to 
match the destination slide master. 

• To maintain the theme of the slide master you are copying from: Right-click > Paste 
(Keep Source Formatting) to copy both the copied layout and its master layout. In 
other words, this creates a new slide master containing the copied layout and its 
master layout. 

Removing Slide Masters and Layouts  

If you no longer need a slide master or a custom layout, just remove it. Note that you cannot 
remove any slide master or layout that is currently used by any slide in your project.  

To delete a slide master and all of its layouts, select the master layout and press DELETE. 

Alternatively, click the Slide Master tab > Delete  or select Delete Master from the context 
menu. 

To delete a custom layout, select it and press DELETE. You can also click the Slide Master 
tab > Delete or select Delete Layout from the context menu. 

Renaming Slide Masters and Layouts 

If there are many similar slide masters or layouts within your project, you should give them 
descriptive names to easily select and apply them later. Just select the master layout or a 

custom one and click the Slide Master tab > Rename . In the dialog that appears, enter 
the desired name and click OK. Alternatively, you can right-click the master layout or a custom 
one > Rename Master/Layout. 
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Preserving Slide Masters 

A slide master that is not in use will be deleted automatically. If you want to keep it in your 
project for later use, just preserve it. In the left pane, select the master layout of the slide 

master you want to preserve and click the Slide Master tab > Preserve . Alternatively, right-
click the master layout > Preserve Master. Then, a pushpin icon appears at the top-left corner 
of the master layout. 

 

If you don’t want to preserve a slide master anymore, click the Preserve button again. In that 
case, if the slide master isn’t used by any slide, a confirmation dialog will appear asking 
whether you want to delete it.  

Keep in mind that a newly added slide master is automatically preserved. 

Designing Slide Masters and Layouts 

A layout consists of one or more placeholders. Placeholders are containers that hold different 
types of content such as text, images, videos, and questions. They provide a quick and easy 
way to insert different types of content into slides. In addition, using placeholders is a good 
way to consistently define the formatting and positioning of slide contents across slides in your 
project.  

To design a layout, you can add or remove placeholders as well as apply themes, theme 
colors, theme fonts, and preset background styles. Use commands in both the Slide Master 
tab and the Home, Annotations, Interactions, Transitions, and Animations tabs to design 
slide master and layouts. 

Inserting Placeholders 

You can modify custom layouts by adding any of eight placeholder types. 

• Content : Hold any one type of the following content: images, videos, questions 
(nine types in total), and report controls. 

• Text , Image , Video , Report , Button : Hold text, images, videos, report 
controls, and buttons, respectively. 

• Media : Hold either images or videos. 

• Question : Hold any one type of questions. 

Do the following to add placeholders to a custom layout (not the master layout):  

1. In the left pane, select the custom layout to which you want to add a placeholder. 
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2. Click the Slide Master tab > Insert Placeholder  > select a placeholder. The 
placeholder is added to the layout immediately. 

3. Reposition and resize the placeholder as you want. 

4. If you add a text placeholder, you can modify the text style. 

Removing Placeholders 

To remove placeholders from the master layout and its corresponding custom layouts, do the 
following: 

1. Click the master layout. 

2. Select a placeholder and press DELETE. Alternatively, click the Slide Master tab > 
Master Layout > clear any check box. 

To remove a placeholder from a custom layout, select it and press DELETE. In case of title 
and footer, you can clear the Title and Footers check boxes in the Slide Master tab. 

Applying Themes to Slide Masters 

Using themes allows you to apply a consistent design to a slide master and its layouts. Just 

select a slide master and click the Slide Master tab > Themes  > click a thumbnail. The 
selected theme will be applied to all slides in your project. 

You can also right-click a thumbnail and choose Apply to Selected Slide Master or Apply 
as New Slide Master.  

 

These two options work as follows: 

• If the selected slide master is in use or not preserved, this theme will be applied to it. 

• If the selected slide master is preserved, a new slide master based on this theme will 
be added. 

• If there are multiple selected slide masters, this theme will be applied to any slide 
master that is in used or preserved. Other selected slide masters will be removed 
completely.  

If your desired theme (*.aptheme) doesn’t appear in the theme gallery, click Browse for 
Themes… to look for this theme and select it. You can also customize a built-in theme and 
save it as a custom theme. To learn more about themes, see Using Themes. 

Applying Theme Colors to Slide Masters 

Using theme colors allows you to apply a consistent color scheme to a slide master and its 

layouts. You can preview a theme color set by clicking the Slide Master tab > Colors  and 
hovering over it.  
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• To apply a theme color set to one or more selected slide masters, just click the set or 
right-click it > Apply to Selected Slide Masters. 

• To apply a theme color set to all slide masters, right-click it > Apply to All Slide 
Masters. 

• To apply a theme color set to one or more selected layouts, right-click it > Apply to 
Selected Layouts. If the change doesn’t satisfy you, click Reset Slide Theme Colors 
to restore the original colors.  

• To create a set of custom theme colors, click Create New Theme Colors….  

• To learn more about theme colors, see Working with Theme Colors. 

Applying Theme Fonts to Slide Masters 

Using theme fonts allows you to apply consistent fonts to a slide master and its layouts. You 

can preview a theme font set by clicking the Slide Master tab > Fonts  and hovering over 
it.  

 

• To apply a theme font set to one or more selected slide masters, just click the set or 
right-click it > Apply to Selected Slide Masters. 

• To apply a theme font set to all slide masters, right-click it > Apply to All Slide 
Masters. 

• To apply a theme font set to one or more selected layouts, right-click it > Apply to 
Selected Layouts. If the change doesn’t satisfy you, click Reset Slide Theme Fonts 
to restore the original fonts. 

• To create a set of custom theme fonts, click Create New Theme Fonts....  

• To learn more about theme fonts, see Working with Theme Fonts. 

Applying Preset Background Styles to Slide Masters 

Using preset background styles allows you to apply a consistent background to a slide master 
and its layouts. You can preview a preset background style by clicking the Slide Master tab 

> Background Styles  and hovering over it.  
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• To apply a preset background style to one or more selected slide masters, just click 
the style or right-click it > Apply to Selected Slide Masters. 

• To apply a preset background style to all slide masters, right-click it > Apply to All 
Slide Masters. 

• To apply a preset background style to one or more selected layouts, right-click it > 
Apply to Selected Layouts. If the change doesn’t satisfy you, click Reset Slide 
Background to restore the original background style.  

• To hide the background graphics originating from the slide master, select Hide 
Background Graphics. This option is only available for custom layouts. 

• To customize a preset background style, use options in the Properties pane > 
Background Fill. 

• To learn more about preset background styles, see Working with Preset 
Background Styles. 

Changing Slide Size 

The size of layouts in the slide master view is the same as that of slides in the normal view. If 
you want to change the slide size as well as the layout size, do one of the following: 

• In the slide master view, click the Slide Master tab > Slide Size . 

• In the normal view, click the Design tab > Slide Size. 

• To change the default slide size when creating new projects, click the ActivePresenter 
button > Preferences > General > Default Project Size. 

Note: Slide size isn’t applicable to responsive projects. 

Applying Slide Layouts to Slides 

There is more than one way to apply layouts to slides in your project. You can insert a new 
slide using the layout you’ve designed or change the layout of an existing slide.  

Applying Layouts to New Slides 

To apply layouts to new slides, in the normal view, do the following: 

1. In the Home tab or Slide tab, click the arrow on the New Slide button .  

2. Choose a layout.  

A new slide using the selected layout will be inserted below the current one. 

Changing Layouts of Existing Slides 

To change the layout of an existing slide, in the normal view, do the following: 
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1. Select one or more slides whose layouts you want to change. 

2. Click the Home tab or Slide tab > Layout . Select a layout from the gallery. 

The selected layout will be applied to all the selected slides. Alternatively, in the Slides pane, 
you can right-click slides > Layout and choose a layout. 

Using Feedback Masters 

Feedback Master Overview 

Feedback Master allows you to create feedback layers which are shown as popups on the 
slide. With this feature, you can easily show and edit complex feedback. The layers provide 
users with feedback on their result. They also contain buttons allowing users to decide what 
to do next. You can edit the text of the layers, add more objects like buttons or images to the 
layers to give users more information or details.  

The feedback message now is isolated from slides or slide masters so users can freely edit 
and customize it.  

1. Generally, feedback master is almost like slide master, except for some differences: 

• The feedback layers are used directly in the Show/Hide Feedback Layer action. You 
can select which layer to show or hide from the list when adding events and actions to 
objects. 

• The placeholders in the feedback layer are treated as normal objects. You can 
customize them the way you want. Besides, you can change the background style for 
the feedback layer. The style will be inherited from feedback master layout. 

2. A feedback layer is almost the same as a slide. So, users can add object, animations or 
transition to it. 

3. In the previous version of ActivePresenter, the default action of the On Correct, On 
Incorrect, On Complete, On Incomplete, and On Timeout event is show a corresponding 
feedback message. For example, when users answer a question correctly, a Correct message 
appears. However, in this version, those events have the default action which is show the 
feedback layer. For example, the default action of the On Correct event is show the Correct 
Feedback layer. 
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Default feedback messages for other interaction objects like Mouse Click, Key Stroke, Text 
Box, Drop Area remain unchanged.  

4. A Show Feedback Layer action has two options:  

• Hide After: The feedback layer automatically hides after a period of time that you set 
in the spin box.  

• Blocking: Checking this option will block the main timeline when the feedback layer is 
showing. 

Opening and Closing Feedback Master View 

To open the feedback master view and edit the default feedback master, click the View tab > 

Feedback Master . Then, the feedback master will appear in the left pane. If there is no 
custom feedback master yet, you will see the default feedback master.  

By default, a feedback master includes at least one master feedback layout and 7 built-in 
feedback layers. These feedback layers are used in question events. However, you are free 
to customize them to meet your needs. You can also add more feedback layers.  
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• Correct Feedback: Used in the On Correct event to let users know that their answer 
is correct.  

• Incorrect Feedback: Used in the On Incorrect event if the current attempt is the last 
attempt, letting users know that their answer is not correct.  

• Try Again Feedback: Used in On Incorrect event if the current attempt is not the last 
attempt. The message lets users know that their answer is not correct and they can try 
it again.  

• Complete Feedback: Used in the On Complete event to let users know that they have 
completed the answer.  

• Incomplete Feedback: Used in the On Incomplete event. The message lets users 
know that they have to complete answering the task before moving to the next one.  

• Timeout Feedback: Used in Timeout event. The message appears to let users know 
that the time to do the task is run out.  

• Review Feedback: This feedback layer is used in the review mode. It is triggered in 
the On Load event of the slide. You have to use the apReviewMode variable to check 
if the presentation is in the review mode or not. There are two buttons (Previous and 
Next) in this layer. They let users navigate the presentation when reviewing a course.  
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• Blank Feedback: A preserve feedback layer. 

ActivePresenter provides you with the Feedback Master tab with tools allowing you to make 
the adjustment for the feedback messages.  

 

With this tab, you can:  

• Insert new layouts. The newly inserted layouts will have the same style with the master 
feedback layout.  

• Delete or rename selected layouts. 

• Define which placeholders will be included on the selected layout (title, text, and 
button). 

To close the feedback master view, click Close Master View  in the Feedback Master tab. 
All the changes you made will be applied to the feedback messages.  

Adding New Layers 

ActivePresenter allows adding as many new feedback layers as you want.  

To insert an additional layer into a feedback master, do one of the following: 

• In the Feedback Master tab, click Insert Layer . 

• Right-click any thumbnail in a left pane and select Insert Layer . 

Note that each slide master can have only one feedback master and you cannot add more 
feedback masters to it. You can only add more feedback layers.  

Managing Feedback Masters and Layers 

Duplicating Feedback Layers 

ActivePresenter allows you to duplicate the feedback layers, making it easier for you to create 
similar layers when needed. You cannot duplicate the feedback master. 

To do that, right-click any layer on the left pane > Duplicate Layer . 

Copying Feedback Layers 

To copy a layer, select the layer > CTRL+C or right-click it > Copy. You cannot copy the 
feedback master layout. Then:  

• Press CTRL+V or right-click > Paste. ActivePresenter will duplicate the copied layer. 

• Right-click > Paste (Keep Source Formatting). Then, the copied layer is duplicated. 

Removing Layers 

If there are any layers that you don’t want to use, just remove them. Note that you cannot 
delete the feedback layout.  
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To delete layers, select them > Feedback Master tab > Delete or press the DELETE key. 

Renaming Layouts and Layers 

Do any of the following to rename the layouts and layers: 

• Select the layouts or layers > Feedback Master tab > Rename . 

• Right-click the layouts or layers > Rename Master/Rename Layout. 

Inserting and Removing Placeholders 

Each layout and layer can have up to three placeholders, namely title, text, and button. To 
show or hide them on the feedback, simply select/clear the check boxes of corresponding 
properties.  

Styling Feedback Messages 

You are free to change the background color and the button style of the feedback messages. 
Besides, the text font and size are editable. Every change in the layout will be applied to all 
the corresponding layers.  

• To change the background style, in the feedback master view, select the layout on the 

Canvas > Style & Effects tab  > change the fill, line, and shadow the way you want. 
Note that you cannot change the style for the whole message with the layer. You can 
only do that in the layout. 

• To design the button of the message, select the button > Format tab > change the 
shape, styles, etc., for the button.  

• To change the text font, size, and color, select the text, then use the buttons and 
commands in the Home tab or the toolbar that appears.  
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Inserting Slides 

Inserting slides is a very basic step when working in ActivePresenter. There are several 
different ways to insert slides, from inserting a new slide to copying slides from other projects. 

Inserting Slides 

Inserting Blank Slides 

To insert a new slide, in the Home tab or the Slide tab, click the arrow on the New Slide 

button  and select a slide from the slide gallery.  

 

You can also simply click the New Slide button or right-click the Slides pane > New Slide to 
insert a new slide that uses the same layout as the current slide. The new slide will be inserted 
below the current one. 

Slides always come with layouts. You can do the following: 

• Change layouts: Click the Home tab or the Slide tab > Layout  > select a layout. 
Alternatively, in the Slides pane, right-click a slide > Layout > choose another layout. 

• Restore original layouts: Click the Home tab or Slide tab > Reset . You can also 
right-click a slide > Reset. 
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• Modify and create new layouts: Click the View tab > Slide Master  to open the 
master view.  

Recording Slides 

ActivePresenter allows you to record a screencast or a software simulation and insert them 
as new slides in your project. These two methods are similar as recording projects, but instead 
of creating new projects, they just create new slides in the current project. 

To record new slides, click the Home tab > Record Screen  > Record Video  or Record 

Software Simulation . You can also find the two buttons in the Slide tab. 

Inserting Images as Slides 

You may have a collection of pictures and want to import them into ActivePresenter as slides. 
Supported image input formats include BMP, PNG, JPG, JPEG, JPE, GIF, ICO, CUR, ANI, 
and XPM. 

To insert images as slides, in the Home tab, click the arrow on the New Slide button  > 

Slides from Images…  . Alternatively, click the Slide tab > Import Images . 

 

In the dialog that appears, do the following: 

• Add images: Click  to import images from your computer. 

• Remove images: Click  if you no longer want an image. 

• Reorder images: Click  or . The image order will be the slide order in the Slides 
pane. 

• Flip images: Click  or  to flip images horizontally or vertically. 

• Rotate images: Click  or  to rotate images 900 right or left. 
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• Select Use images as objects if you want each image is inserted into each slide as 
slide object. Otherwise, images will be treated as the background of each slide. 

Note: Images will be clipped if their size is larger than the slide size. In this case, you can 
change the slide size so that the images are displayed properly. 

Inserting Slides from PowerPoint Presentations 

You can convert PowerPoint slides to new slides in the current project. This method is similar 
to creating a new project by converting PowerPoint presentation. However, instead of creating 
new projects, it just creates new slides in the current project. 

To insert slides from PowerPoint presentations, in the Home tab, click the arrow on the New 

Slide button  > Slides from PowerPoint…  . Alternatively, click the Slide tab > Import 

PowerPoint . 

Inserting Slides from ActivePresenter Projects 

You can reuse slides from another ActivePresenter project. Do the following 

1. In the Home tab, click the arrow on the New Slide button  > Slides from 

ActivePresenter… . Or, click the Slide tab > Import ActivePresenter . 

2. Select an ActivePresenter project. 

3. In the dialog that appears, select the slides you want to reuse.  

4. Click OK to import slides. 
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You can also copy slides across projects. However, bear in mind that different projects may 
have different slide sizes. Thus, importing or copying slides may make the slide content 
clipped or distorted. Therefore, always check the slide size of both the source and destination 
projects beforehand. 

Inserting Slides from Templates 

Besides themes, you can use slide templates (also templates) to quickly create new projects 
with ready-made slide layouts and contents. Everything you’ve added to a slide is reusable 
when you use slide templates.   

To insert slides from a slide template, do the following: 

1. In the Home tab or the Slide tab, click the arrow on the New Slide button  > Slides 
from templates....  

2. In the window that appears, select the desired template. 

3. Select the slides you want to use. 

4. Click Insert Slide to insert the selected slides into the current project. 
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Note: Slide templates appear in the window only when they are stored in the ActivePresenter 
Templates folder (C:\Users\\Documents\ActivePresenter Templates (for Windows) or 
/Users//Documents/ActivePresenter Templates (for macOS)). 

Copying Slides 

You can copy slides in the same project or across different projects. To copy slides, do the 
following: 

1. Select one or more slides. 

2. Press CTRL+C or right-click > Copy. Alternatively, click the Home tab > Copy. 

3. You can paste the copied slides into the same project or another project. The copied 
slides will be inserted below the current slide: 

• To take the theme of the current slide: Press CTRL+V or right-click > Paste or click 

the Home tab > Paste (Use Destination Theme) . This will adapt the copied 
slides to match the destination theme. 

• To maintain the theme of the slides you are copying from: Right-click > Paste 

(Keep Source Formatting)  or click the Home tab > Paste (Keep Source 
Formatting). This will make the copied slides keep their original theme format. 
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Removing Slides 

If you no longer want a slide, select it and press DELETE. Alternatively, right-click it > Delete. 
You can hold down CTRL while clicking slides to select more than one slide and remove them 
at the same time. 

Changing Slide Properties 

Naming Slides 

It’s always a good idea to give slides recognizable names, so it makes easier for you to find 
them later. 

To name a slide, click the Properties pane > Slide Properties > General. Give the slide 
name and description using the corresponding text boxes. You can further edit the slide name 

and description by clicking the Edit buttons  next to the text boxes. 

 

In the Slides pane, if the view mode is slides in titles (right-click Slides pane > Slides In 
Titles), you can double-click each entry or right-click an entry > Edit Name to name a slide. 

 

Another way to name slides is using a batch operation that generates slide name from the first 
shape in each slide. This is useful when you want to name slides in a software simulation. 
Do the following: 

1. Click the Slide tab > Batch Operations  > Generate Slide Name From First 
Shape.  

2. In the dialog that appears, the Current Name column shows the current name of slides 
while the New Name column shows the text inside the first shape in each slide. To 
rename a slide, double-click a name in the New Name column or click a row > Edit 
Name. 
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3. Select the slides you want to name by selecting their corresponding check boxes. 

4. Click OK to apply changes. 

Ordering Slides 

It’s easy to reorder slides. In the Slides pane, just drag a slide to the order you want. Keep in 
mind that you cannot drag slides when the view mode is slides in titles. 

Advancing Slides 

By default, the presentation jumps to the next slide immediately when the current slide ends 
thanks to the Auto Advance option. You can find this option in the Properties pane > Slide 
Properties > General. 

You can disable this option and use actions, such as Continue Presentation, Go Forward, 
and Go to Slide, to advance slides. 

Changing Slide Background Fill Styles 

You can fill the slide background with a solid color, a gradient, or an image. Get this done 
using the Background Fill section in the Properties pane.  
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Besides, you can: 

• Hide Background Graphics: Hide the background graphics originating from the slide 
master. 

• Apply to All: Apply the background fill style of the current slide to all slides in your 
project. 

• Reset Background: Restore the default background fill style of the current slide. 

Adding Background Images to Slides 

Apart from background fill styles, you can add background images to slides. Do the following: 

1. Select one or more slides. 

2. Click the Properties pane > Slide Properties > Background Image. 

 

3. Choose an image from your project   or your computer . 

4. Specify the position and size using the Left, Top, Width, and Height spin boxes. 

5. If you want to revert the image to its original size, click Restore Original Size. 

6. If you want to stretch the image so that it fits into the background, click Fit To 
Background. 

7. If you no longer want a background image, click Remove . 
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To further edit the background image, on the Canvas, right-click a slide > Edit Background 
Image or click the Slide tab > Edit Background Image. This opens the Image editor and the 
Drawing tab which help you edit the image as you wish. 

 

While editing the background image, once you click Save in the Quick Access Toolbar, all 
your changes to the image will be applied and reflected in the slide. When you’re done, close 
the Image editor and go back to editing the slide. 

Adding Transition Effects 

Slide transition effects indicate the end of one slide and the beginning of another during a 
presentation. You can control the style and speed of transition effects and apply different 
effects to different slides in your project. 

Adding Transition Effects 

To apply a slide transition effect, do the following:  

1. In the Slides pane, select one or more slides. 

2. Click the Transitions tab > select an effect from the gallery. 

 

3. Specify effect option (if any) and duration of the effect. 

4. In the Timeline pane, the transition effect is represented by a blue diamond. Click the 

Play button  or press SPACE BAR to preview. 
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Slide transition effects can also be applied to slide masters. 

Removing Transition Effects 

To remove slide transition effects, select a slide, then do one of the following: 

• In the timeline, drag the blue diamond downward until it turns gray, then release the 
mouse button. 

• Click the Transitions tab > None from the gallery. 

Managing Slides 

Splitting and Merging Slides 

When a slide is rather long with many contents, you may want to split it into two or more slides.  

To split a slide, do the following: 

1. In the timeline, choose a timestamp where you want to split the slide. 

2. Click Split Slide .  

Then, your slide will be split into two slides at the Playhead position. The new slide contains 
all the objects and other properties on the right side of the Playhead and is inserted right below 
the current one.  

If the Playhead lies in the middle of an object time bar, the time bar will be split and the latter 
part will be transferred to the new slide. 

If you want to merge slides into one, hold down CTRL or SHIFT to select multiple slides and 
right-click them > Merge Slides. 

Changing Slide View Modes 

The Slides pane displays slide thumbnails in the following three modes: 
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• Slides in Column  (1): Slide thumbnails expand their size to fit into the pane. This 
is the default view mode. 

• Slides in Grid  (2): Slide thumbnails are arranged into multiple columns and rows.  

• Slides in Titles  (3): Only slide titles are displayed. 

To change the view mode, right-click the Slides pane > choose the mode you want. You can 
also click the View tab and choose the view mode. 

Saving Slides as Images 

ActivePresenter allows you to export your project to images. That way, each slide will be 
exported to an image. If you want to save just one slide to an image, the app gives you another 
feature. On the Canvas, right-click a slide > Save Slide As Image… or you can click the Slide 

tab > Save Slide As Image . Supported formats include PNG, JPG, and BMP. 

This feature is useful when you have a particular slide that you want to use in different projects. 
It also lets you save a particular scene in a video to image so that you can use it in written 
tutorial, for example. 
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Inserting Objects 

There are two types of objects in ActivePresenter: 

Annotation objects: shapes, text caption, highlight, spotlight, equation, gesture effects, 
footer, image, YouTube video, web object, cursor path, zoom-n-pan, closed caption, 
audio, and video. 

Interaction objects: mouse click, key stroke, text box, drop area, button, check box, 
radio button, animated timer, and questions.  

Inserting and Removing Objects 

To insert an object, click the Annotations tab or Interactions tab and choose the object you 
want. The object will be inserted into the current slide. After that, you can rename the object 
by clicking the Properties pane > Interactivity > General or going to the Selection pane. 

If you no longer want an object, select it on the Canvas, in the Timeline pane or the Selection 
pane, then press DELETE. Alternatively, right-click the object > Delete. The same steps are 
applied to remove more than one object in a single slide.  

Inserting and Removing Objects in Multiple Slides 

ActivePresenter makes it easy to insert objects into multiple slides as well as remove multiple 
objects from multiple slides. 

Inserting Objects into Multiple Slides 

If you want to do a batch operation to insert an object into multiple slides, do the following: 

1. Click the Slide tab > Batch Operations  > Insert Objects…. 

2. In the dialog that appears, select the object type that you want to insert. 
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3. Specify the slides into which you want to insert the object. If you choose Specified 
Slides, separate the ordering numbers of slides by commas. Otherwise, use hyphens 
to indicate ranges. For example, the range 3-6 indicates the 3rd, 4th, 5th, and 6th slides. 

4. Click OK to apply. 

Once the batch processing finishes, the selected object will appear in all specified slides with 
the same properties. Then, you can edit each of these objects individually or style all of them 
in the same way. See Changing Style and Effects for details. 

Note: You might want to make a single object appear in all slides in the presentation. This is 
useful when the object is a corporate logo or background music. To do that, right-click the 
object > Show over Multiple Slides. Then, you can choose to place the object in the top layer 
or bottom layer of the stack order of slide objects. After that, in the Timeline pane, and click 

the All Slides button  to view all slides in the current project as well as the objects that span 
across multiple slides. 

Removing Multiple Objects from Multiple Slides 

If you want to do a batch operation to remove objects from multiple slides, do the following: 

1. Click the Slide tab > Batch Operations  > Delete Objects…. 

2. In the dialog that appears, select the object types that you want to remove. 

 

3. Specify the slides where you want the mass destruction to happen. If you choose 
Specified Slides, separate the ordering numbers of slides by commas. Otherwise, 
use hyphens to indicate ranges. For example, the range 3-6 indicates the 3rd, 4th, 5th, 
and 6th slides. 
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4. Select Include objects shown over multiple slides if you want to remove any objects 
shown over multiple slides. 

5. Click OK to apply. All selected objects will be removed from the specified slides. 

Copying Objects 

To copy objects, do the following: 

1. Select one or more objects in a slide. 

2. Press CTRL+C or right-click > Copy. Alternatively, click the Home tab > Copy. 

3. You can paste the copied objects into the same slide or another slide. In case of the 
latter, do either of the following: 

o To take the theme of the destination slide: Press CTRL+V or right-click > Paste or 

click the Home tab > Paste (Use Destination Theme) . This will adapt the 
copied objects to match the destination theme.  

o To maintain the theme of the slide you are copying from: Right-click > Paste (Keep 

Source Formatting)  or click the Home tab > Paste (Keep Source 
Formatting). This will make the copied objects keep their original theme format. 

Changing Object Properties 

Repositioning, Resizing and Rotating Objects 

After inserting an object into a slide, you often want to change its position, size, and rotation. 
Do that on the Canvas or in the Properties pane. Do one of the following: 

 

• On the Canvas, drag the object to a new position. You can also use the ARROW keys 
to move objects.  

• On the Canvas, select the object that you want to resize. Then, drag the resizing 
handles (green dots) to change the object’s size. You can also use SHIFT+ ARROW 
keys to resize objects. 

• On the Canvas, select the object that you want to rotate. Then, drag the rotation 
handles to rotate it. 

• Select the object > Properties pane > Size & Properties > Transform. Specify the 
position, size, and rotation value as you wish. 

Note:  

• To reposition, resize, or rotate objects in responsive projects, see Changing Object 
Position and Size. 
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• For images and videos, by default, the aspect ratio is locked to keep them proportional 
while being resized. To change the ratio, clear the Lock Aspect Ratio check box in 
the Properties pane > Size & Properties > Transform. In addition, if you want to 
revert these objects to their original size, just right-click them > Restore Original Size. 
This option also appears in the Transform section. 

 

Changing Style and Effects  

You can change the style and effects of more than one object in the Format tab, Home tab, 
and the Properties pane > Style & Effects. 

Quick styles are a useful way to quickly change an object’s fill, line, shadow, and text style. 
To apply a quick style, do the following: 

1. Select one or more objects of the same type. 

2. Click the Format tab or Home tab > Quick Style  > choose the style you want. The 
color choices will depend on the theme you are using for your project.  

 

If your project has many objects of the same type and you want them to have the same 
animation effects or formatting style, do the following: 
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1. Animate an object or format it the way you want. 

2. Apply the animation and style of the object to all other existing objects of the same 
type. To do that, right-click the object > Apply to All Objects > Animation and/or 
Style. 

Note:  

• The Apply to All Objects option affects existing objects only. It has nothing to do with 
objects that haven’t been inserted yet. If you want the newly added objects to use the 
same style as those existing ones, you must use the default object.  

• If you want to restore the default object which comes with ActivePresenter, click the 

ActivePresenter button > Project > Reset Default Objects  > choose the object 
type. 

Object Operation Modes 

When creating HTML5 content, you have to choose operation modes for objects to determine 
if objects appear in a certain mode in the output. For example, by default, the operation modes 
for mouse clicks are Demonstration and Tutorial. This means these objects only appear in 
these two modes. They don’t appear in the Practice and Test modes.  

You can determine operation modes for objects in the current slide, not multiple slides in your 
project at the same time. Do the following: 

1. Select one or more object. 

2. Click the Properties pane > Size & Properties > Show in Mode > choose the modes 
you want. 

 

Animating Objects 

Animation is a great tool to engage your audience. ActivePresenter allows you to animate 
objects with four types of animation effects: entrance, exit, emphasis, and motion path. In the 
Animations tab, entrance effects are colored green, exit effects are colored red, emphasis 
effects are colored yellow, and motion paths are pre-made paths or custom paths that you 
draw by yourself. 

 

Entrance effects control how an object appears. These effects start at the start point of an 
object (the left edge of the object time bar). For example, an object moves slowly into a slide 
using the Float In effect. 
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Exit effects control how an object disappears. These effects end at the end point of an object 
(the right edge of the object time bar). For example, using the Zoom Out effect, an object 
gradually scales down and disappears.  

Emphasis effects add highlights or movement to draw attention to an object already in a slide. 
For example, you can make an object shake using the Teeter effect. 

Motion paths move objects already in a slide along a predetermined path, like a line, circle, 
or a star. You can also draw your own paths. 

While you can apply only one entrance or exit effect to an object, multiple emphasis effects 
and motion paths can be added to a single object. You can set all the animations to play in 
turn or simultaneously. For example, apply the Fly In entrance together with the Spin emphasis 
to make a shape fly in while rotating. However, keep in mind that always use animations for a 
purpose. Don’t overuse animations as it can distract your audience. 

Timeline contains animations. As ActivePresenter supports multiple timelines, a single 
object can hold different animations in different timelines. So, make sure you add the right 
animation effect in the right timeline.  

To apply animations to objects, do the following (skip unnecessary steps, if any): 

1. Select one or more objects that you want to animate. 

2. Click the Animations tab. 

3. To add an entrance or exit effect, click the Entrance Effects or Exit Effects button > 
choose an effect.  

 

4. To add an emphasis effect or a motion path, click the arrow at the bottom-right corner 
of the emphasis & motion path gallery to expand the gallery, then choose an effect. 
Emphasis effects and motion paths will be added at the Playhead position, so 
remember to specify the Playhead position beforehand. 

 

5. Specify the effect option to tweak the effect. Some effects have effect options which 
determine their direction or a shape that the object moves long. For example, the Spin 
effect can rotate an object clockwise or counterclockwise. 

6. Specify the start time and duration of the effect. 

7. Preview the effect by pressing SPACE BAR or clicking the Play button  in the 
Timeline pane. 

In the timeline, entrance effects are colored green, exit effects are colored red, both emphasis 
effects and motion paths are colored yellow. To expand animation effects as in the below 
figure, in the timeline, right-click an object time bar > Expand Animations. 
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When you add a motion path, you will see the path on the Canvas. It appears as a dotted line 
with a green arrow indicating the path’s start and a red arrow indicating its end.  

 

Adding Multiple Emphasis Effects and Motion Paths 

You can apply more than one emphasis effect or motion path to an object. Do the following: 

1. Select one or more objects that you want to animate. 

2. Specify the timestamp where you want the effect to start. 

3. Click the Animations tab > Add Animation > choose an effect.  

 

4. Specify the effect option (if any), start time, and duration of the effect. 

5. Preview the effect by pressing SPACE BAR or clicking the Play button  in the 
Timeline pane. 

Note: 
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• If you try to add more effects by using the emphasis & motion path gallery, you won’t 
add an additional effect. Instead, you’ll replace the existing effect with the one you’re 
adding. 

• Multiple effects can have the same start time or play simultaneously, making it hard to 
select and manipulate them in the timeline. In that case, right-click the object time bar 
> Expand Animations to expand the animation time bars. 

Editing Animation Effects 

After applying an animation effect, you may want to change its timing, direction, etc. You may 
also want to replace it with another one. Do the following to modify an effect: 

• Change timing: Drag the effect time bar in the timeline or select the object > 
Animations tab > Start Time. 

• Change duration: Lengthen or shorten the effect time bar in the timeline or select the 
object > Animations tab > Duration. 

• Change options: Select the object > Animations tab > Effect Options. 

• Replace effects: Select the object > Animations tab. For entrance and exit effects, 
click the Entrance Effects or Exit Effects button and choose an effect to replace the 
existing one. For emphasis effects and motion paths, choose an effect from the 
emphasis & motion path gallery.  

In the timeline, you can also double-click the effect time bar or right-click it > Animation 
Settings. Both ways open the dialog which allows you to modify the effect. 

 

Note: 

• For emphasis effects and motion paths, you can make an effect repeat automatically 
when it ends using the Repeat option. An effect can be repeated for a specific number 
of time or until the end of the slide. If you want a motion path to repeat end-to-start, 
select the Auto-reverse check box. 

• For details about motion paths, see Adding and Editing Motion Paths. 
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• You can apply an animation effect to all the objects of the same type in your project. 
To do that, apply the effect to one object, then on the Canvas, right-click the object > 
Apply to All Objects > Animation. 

Removing Animation Effects 

To remove an animation effect, do one of the following: 

• In the timeline, drag the effect time bar downward until it turns gray, then release the 
mouse button to delete the effect. 

• In the timeline, right-click the effect time bar > Remove Animation.  

• Select the object > Animations tab > None from the effect galleries. 

• For motion paths, you can also select the path on the Canvas > DELETE. 

Adding and Editing Motion Paths 

Adding Motion Paths 

To add a motion path to an object, select the object and do the following:  

1. Select one or more objects that you want to animate. 

2. Specify the timestamp where you want the effect to start. 

3. In the Animations tab, click the arrow at the bottom-right corner of the emphasis & 
motion path gallery to expand the gallery, then choose a motion path. 

• If you choose a predefined path, the path will appear on the Canvas immediately. 

• If you choose the Custom Path option, you will draw your own path. Drawing a 
custom path is the same as drawing a freeform shape. 

4. Specify the path option, start time, and duration of the effect. 

5. On the Canvas, select the path and resize it or move it to the position you want. 

6. Preview the effect by pressing SPACE BAR or clicking the Play button  in the 
Timeline pane. 

Locking Motion Paths 

By default, a motion path follows an object when you move the object. That’s thanks to the 
unlocked state where the path and the object move together. You can choose to lock the path 
so that it remains the same position when you move the object.  

To lock or unlock a path, select it > Effect Options > Lock Origin. 

Opening and Closing Paths 

For closed paths like Shapes, Loops, and Stars, right-click the path > Open Path to separate 
the start and end point.  
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For open paths like Lines, Arcs, and Turns, right-click the path > Close Path to make the 
object return to its start point. A linear path is added from the previous end point to the start 
point.  

 

Changing Path Shape 

To change the shape of a path, double-click the path or right-click it > Edit Points to enter the 
edit mode. In this mode, you can modify the path shape by moving, adding, or removing the 
anchor points (black squares) that appear. For more details, see Editing Freeform. 

 

 

Reversing Path Direction 

To exchange the start point and end point of a path, right-click the path > Reverse Path 
Direction. 

 



ActivePresenter User Manual  Version 7.5 

Inserting and Managing Objects > Arranging Objects 84 

Arranging Objects 

Ordering Objects 

A slide may have numerous objects, such as shapes, text captions, images, videos. When 
being inserted into a slide, new objects are placed in front of others and may cover them partly 
or fully. This stack order of objects is called z-order. 

ActivePresenter gives you the ability to arrange objects in z-order. You can move an object to 
the front or the back of the slide even when they do not overlap each other. Do the following: 

1. Select one or more objects. 

2. Click the Format tab > Order  or the Home tab > Arrange > Order. Alternatively, 
on the Canvas or in the timeline, right-click objects (time bars) > Display Order. 

3. Choose the desired display order option.  

4. You can go to the Selection pane and drag an object up or down to change its position 
in the stack order. Moving an object higher means that you bring it to the front of the 
stack. 

Icon Name Hotkey Function 

 

Bring to Front CTRL+HOME Place the object at the very top of the 
stack. 

 

Bring Forward CTRL+PAGE UP Send the object higher by one level in 
the stack. 

 

Send to Back CTRL+END Place the object at the very bottom of 
the stack. 

 

Send Backward CTRL+PAGE DOWN Send the object lower by one level in 
the stack. 

Grouping Objects 

ActivePresenter lets you group multiple objects into a group so that you can edit and manage 
them easily.  

Note that you cannot group closed captions, audio tracks, spotlights, videos, web objects, 
YouTube objects, zoom-n-pans, gesture effects, and questions. 

Grouping Objects 

ActivePresenter lets you group objects of several types: shapes, images, text captions, etc. 
Note that object grouping is unavailable to some objects including closed captions, audio 
tracks, spotlights, videos, web objects, YouTube objects, zoom-n-pans, gesture effects, and 
questions. 

Do the following: 

1. Hold down CTRL while selecting all the objects that you want to include in a group.  

2. Right-click objects > Group > Group . Alternatively, click the Format tab > Group 
> Group or the Home tab > Arrange > Group. 
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The selected objects are grouped. A single box with resizing handles appears around 
the entire group.  

 

At the same time, in the Timeline pane, all the child objects’ time bars are merged into 
the only time bar of the group. The Selection pane lists all the child objects under and 
at the next indent level compared to their group. Click the +/- button to expand or 
collapse these child objects. 

3. Rename the group to make it easier to find and work with. Click the Properties pane 
> Interactivity > General or go to the Selection pane. 

Note: 

• Another way to select multiple objects is dragging the mouse across them. In other 
words, use a rubber-band selector. Click on a slide and drag the mouse, a rubber-band 
selector appears. All the objects that stay in or intersect with the selector will be 
selected. 

• If you’ve already selected several objects and want to select more, hold down CTRL 
and click them. If you include some objects you don’t want, hold down CTRL and click 
redundant objects to clear the selection. 

• After you make a group, you can still work with child objects in that group. Select the 
group, then click an object to select it. 

• A group and its child objects are mutually exclusive when it comes to converting 
objects into drag sources/drop targets. That is, you can only convert either a group or 
its child objects into drag sources/drop targets. 

• Some features are not available to child objects, namely Attached audio, Show to 
the end of slide, Show In Mode, and Pause presentation to wait for user input. 

Adding Objects to a Group 

ActivePresenter lets you add objects to an existing group. Do the following: 

1. Select a group and one or more objects that you want to add to the group. 

2. Right-click > Group > Add to Group . Alternatively, click the Format tab > Group 
> Add to Group or the Home tab > Arrange > Add to Group. 

In the Timeline pane, the time bars of the extra objects are merged into the time bar of the 
group. In the Selection pane, extra objects are listed as child objects of the group. 

Note: You can nest groups within groups. Simply put, groups can contain groups as members. 
To nest a group in another group, use the same techniques for grouping objects. Just select 
all the objects/groups you want, right-click > Group > Group. A new group is created 
containing all the selected objects/groups as members. 
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Ungroup Objects 

Sometimes, you no longer need a group. You want to break it apart so that you can more 
easily select and format each individual objects. To ungroup a group, first select the group. 

Then, right-click it > Group > Ungroup . Alternatively, click the Format tab > Group > 
Ungroup or the Home tab > Arrange > Ungroup. 

Changing Group Layout 

ActivePresenter supports grid layout for groups. This feature places child objects of a group 
in a grid pattern, which is useful when you want to draw tables to display fields in a grid layout 
or when you want to align child objects in a group. 

To change the group layout to grid, select the group > Properties pane > Size & Properties 
> Group Layout > Mode > Grid. The grid layout ignores the original size of all the objects in 
a group and assigns a fixed size to all of them. 

 

The grid size is defined by the number of columns, horizontal spacing between columns, and 
vertical spacing between rows. Change the values for these parameters if needed. The 
number of rows will be automatically counted based on the number of child objects and 
columns. 

 

For further modification, click Advanced Settings…. A dialog appears, allowing you to define 
the width ratio between columns or the height ratio between rows. If the value is 0, the 
minimum size of objects will be used. 

For example, the group below has two columns (width ratio 1:2) and two rows (height ratio 
1:3). As you can see, the width of the blue rectangle is one-half of the orange one. Meanwhile, 
the height of the blue rectangle is one-third of the green one. 
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Aligning Objects 

ActivePresenter can automatically and perfectly align objects for you. 

Aligning Objects Using Canvas Snapping 

You can use canvas snapping to snap objects to the center/edge of the Canvas or of other 
objects. 

Snap lines appear as orange lines when you drag or reshape objects. They are vertical or 
horizontal lines through the edge/center of an object or the Canvas. Use snap lines to align 
an object relative to another object. Or, you can align an object relative to the center/edge of 
a slide. 

 

Canvas snapping is turned on by default. To turn it off, click the View tab > Canvas Snapping. 
Temporarily disable canvas snapping by holding down CTRL when resizing or moving objects. 

Aligning Objects with Anchor Objects 

Sometimes, you have an object’s position set perfectly and you want to align other objects 
with that specific object. To do that, use the Alignment options and an anchor object. 

An anchor object (also a reference object) is the one with which all other objects align. It is the 
last object you select with green resizing handles rather than white handles like others. To 
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define a different anchor object, click any of the currently selected objects without holding 
CTRL.  

 

You have many options for aligning objects both vertically and horizontally. Do the following: 

1. Hold down CTRL while selecting all the objects that you want to align. 

2. Click the Home tab > Arrange or the Format tab > Align. 

Icon Command Function 

 

Align Left Align the left side of all the selected objects with the left of the 
anchor object. 

 

Align Center Align the center of all the selected objects with the vertical 
center of the anchor object. 

 

Align Right Align the right side of all the selected objects with the right of the 
anchor object. 

 

Align Top Align the top of all the selected objects with the top of the 
anchor object. 

 

Align Middle Align the center of all the selected objects with the horizontal 
center of the anchor object. 

 

Align Bottom Align the bottom of all the selected objects with the bottom of 
the anchor object. 

Aligning Objects to the Canvas 

You can align one or more objects to the center of the Canvas. Do the same steps to align 
objects as mentioned above, but choose either of the following: 

Icon Command Function 

 

Center Horizontally Move all the selected objects to the horizontal center of the 
Canvas. 

 

Center Vertically Move all the selected objects to the vertical center of the 
Canvas. 
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Distributing Objects 

If you arrange objects in a row or column, you may want them to be an equal distance from 
one another for a neater appearance. Do that by distributing the objects horizontally or 
vertically. Perform the same steps to align objects as mentioned above, but choose either of 
the following: 

Icon Command Function 

 

Distribute 
Horizontally 

Make the horizontal spacing equal between the selected 
objects. 

 

Distribute Vertically Make the vertical spacing equal between the selected 
objects. 

Note: These commands work only when you select more than two objects. 

Resizing Objects to Anchor Objects 

If you have multiple objects that you want to size equally, use the following alignment options: 

Icon Command Function 

 

Make Same Width Match the width of all the selected objects with that of the 
anchor object. 

 

Make Same Height Match the height of all the selected objects with that of the 
anchor object. 

 

Make Same Size Match the height and width of all the selected objects with 
those of the anchor object, respectively. 

Using Object States  

Object states allow you to change the appearance of an object in response to user interaction. 
A state is a collection of visual elements that define the look of an object. You can add states 
to many types of objects such as shapes, text captions, images, or buttons. Using actions, 
you can shake an image on hover and make it appear disabled after being clicked. 

Besides adding new custom states, you can apply several built-in states to objects. 
ActivePresenter also adds built-in states to some types of objects by default, such as buttons, 
check boxes, and radio buttons, so that you can use these multi-state objects right away. 

There are four types of states, including: 

• Normal state: Each object always has a neutral state that cannot be deleted and 
renamed. By default, it’s the initial state (default state) of an object. 

• Default state: This is the initial state of an object, in other words, this is how an object 
looks when it first appears. By default, the normal state is the default state of an object, 
but you can change the default state to any other state. 

• Custom state: You can create many custom states for an object. 



ActivePresenter User Manual  Version 7.5 

Inserting and Managing Objects > Using Object States 90 

• Built-in state: ActivePresenter provides several built-in states that you can apply to 
objects. The normal state is actually a built-in state. 

Built-In States 

The built-in states of objects are as follows: 

• Normal: This is the neutral state of an object. By default, it’s how an object looks when 
it first appears. 

• Hover: This is how an object looks when being hovered. This state is available for 
buttons, check boxes, and radio buttons and is added by default. You don’t need to 
use an action to trigger it. 

• Pressed: This is how an object looks when being clicked. This state is available for 
buttons, check boxes, and radio buttons and is added by default. You don’t need to 
use an action to trigger it. 

• Disabled: This is the state you use when you want to disable an object. A disabled 
object is visible but cannot respond to any user action. Unless this state is added to an 
object by default, you need to use an action to trigger it. 

• Normal/hover/pressed/disabled checked: These are the states of the selected 
check box or radio button. They are added to check boxes and radio buttons by default, 
so you don’t need to trigger them using actions.  

There are several built-in drag-n-drop states that you can apply to drag sources and drop 
areas. As you add these states to a drag source or drop area, they will be automatically 
displayed when the corresponding events occur, in other words, when you interact with the 
drag source or drop area.  

• Drag start: This is how a drag source looks when it’s dragged from its location.  

• Drag end: This is how a drag source looks when you release the mouse button while 
dragging it.  

• Drag enter: This is how a drop area looks when a drag source enters it.  

• Drag leave: This is how a drop area looks when a drag source leaves it.  

• Drop correct: This is how a drag source or drop area looks when a drag source is 
dropped onto the correct drop area. 

• Drop incorrect: This is how a drag source or drop area looks when a drag source is 
dropped onto the incorrect drop area. 

• Accept: This is how a drop area looks when any accepted drag source is dropped onto 
it.  

• Reject: This is how a drop area looks when any rejected drag source is dropped onto 
it.   

Opening Object States Pane 

You use the Object States pane to manage states. To open this pane, click the View tab > 
Object States.  

Alternatively, you can select an object that you want to manage its states and click the 
Properties pane > Interactivity > General > State View, or right-click the object > Object 
States. 
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Adding States 

An object may have no, one, or several states by default. However, you can add more states 
to it using the following steps:  

1. Select an object. 

2. In the Object States pane, click the Edit States button. This enters the state edit mode 
where all other objects except the selected one are grayed out and unclickable. 

 

3. Click Add State  or right-click the pane > Add State to add a built-in state or a 
custom state. A custom state will inherit all visual properties from the normal state.  

4. Assign a name to the new custom state and click OK. 

5. If you want to change the appearance of the newly added state, follow the steps in the 
next part. 

6. If you want to add states to another object in a slide, switch to that object using the 
States of combo box. 

7. When you’re done adding and editing states, click the Done Editing States button to 
exit the state edit mode. 
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Editing States 

You can change the appearance of any state, including its size, position, shape type, text, 
color, border, etc. Just enter the state edit mode, select a state, and make an edit. All your 
changes will be saved when you click the Done Editing States button.  

  

As mentioned earlier, if you want to edit states of multiple objects in a slide, use the States of 
combo box to switch between objects. Take note of the following: 

Property State editing mode Normal mode 

Size, position, 
and rotation 

When the active state is the 
normal state, your changes will be 
applied to all other states which 
inherit from the normal state. 

Otherwise, changed property will 
no longer inherit from the normal 
state. 

Your changes will be applied to all 
other states with the same 
transformation matrix. 

Other visual 
properties 

If the default state is the normal 
state or inherits from the normal 
state, your changes will be applied 
to all other states which inherit from 
the normal state. Otherwise, your 
changes will be applied to the 
default state only. 
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Managing States 

To manage states, first enter the state edit mode by clicking the Edit States button. Then, use 
the buttons in the toolbar of the Object States pane or right-click a state and select an option 
in the context menu. Be aware that you cannot rename, remove, or reset the normal state. 

• Rename State : Rename the active state. 

• Remove State : Remove the active state. 

• Reset State : Restore the original appearance of the active state. Use this option 
when you aren’t satisfied after editing a state. 

• Duplicate State : Create a copy of the active state. 

• Set State as Default : Make the active state the default state, in other words, the 
initial state of an object. 

Triggering States Using Actions 

Use actions to display a state based on the user’s interaction with the content. While the event 
depends, you will use the Change Object State action to invoke a state. For more details, see 
Adding Events - Actions. 

Using Object Templates 

Object template is a good way to reuse objects across slides in the same project or across 
different projects. By adding objects to an object template, you save not only the objects 
themselves but also the animations and event actions attached to them.  

ActivePresenter uses the ActivePresenter Templates folder and the Object Templates pane 
to help you manage object templates. Your object templates (*.apobject) are stored in the 
ActivePresenter Templates folder (C:\Users\\Documents\ActivePresenter Templates (for 
Windows) or /Users//Documents/ActivePresenter Templates (for macOS)). Any object 
templates stored in that folder will appear in the Object Templates pane. This pane is where 
you add and manage template items in an object template. 

Opening Object Templates Pane 

The Object Templates pane contains object templates. Each object template includes one or 
more object template items. These items can be annotation or interaction objects. By default, 
ActivePresenter gives you a Default object template. You can add objects to this template or 
create other object templates to use.  

The Object Templates pane automatically opens when you add objects to template. When 
you want to open this pane, click the View tab > Object Templates. 
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Adding Objects to Object Templates  

You can add any object to object templates, except cursor path, zoom-n-pan, and closed 
caption. 

To add an object to the object template, do the following:  

1. Right-click the object > Add to Template. Then, the object will appear as a template 
item in the current object template. 

 

2. Right-click the object template item > Rename  to rename it. 

3. If you don’t want a template item anymore, click it and press DELETE or right-click it > 

Delete . 

Note: 
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• When you add multiple objects to the object template at once, all the selected object 
will be treated as a single template item. That said, this doesn’t group the selected 
objects or make them a single object. When you insert that template item into a slide, 
the objects are still separate objects. 

• An object template item can hold the event actions attached to it. However, if the action 
involves other objects and you don’t add those objects to the same template, the action 
will be removed. Otherwise, if you add all the objects to the same template, the actions 
will remain. For example, if you have the object A with the action Show object B when 
clicked. If you add these objects to the object template simultaneously, the action will 
remain. Otherwise, if you just add the object A to the object template, the action will be 
removed. 

Using Object Template Items 

To insert an object template item into a slide, in the Object Templates pane, do one of the 
following: 

• Double-click a template item. 

• Drag and drop a template item onto the Canvas. 

• Right-click a template item > Insert.  

By default, object template items added to slides will maintain their original theme thanks to 
the Keep Source Formatting check box at the bottom of the pane. If you want the template 
items to adapt to the theme of the destination slide, clear this check box. 

Saving and Sharing Object Templates 

You can save a project as an object template and reuse it for other projects. 

To save a project as an object template, click the ActivePresenter button > Save or Save 
As…. Next, select ActivePresenter Object Template (*.apobject) from the Save as type drop-
down list.  

  

Then, do either of the following: 

• Save file in C:\Users\\Documents\ActivePresenter Templates (for Windows) or 
/Users//Documents/ActivePresenter Templates (for macOS). That way, the object 
template will appear in the Object Templates pane.  
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• Save the project in other folders on your computer. The object template will not appear 
in the Object Templates pane. 

After that, you can rename or delete the object template file in the same way as you normally 
do. You can also share the template file with others.  

If you have any *.apobject file and want to import it into ActivePresenter as an object template, 
just copy the file and paste it into the ActivePresenter Templates folder. Then, in the Object 

Templates pane, click Reload  to refresh the Templates folder, making the new object 
template appear in the pane. 

Setting Default Objects 

You can format a certain object and set it as the default. After that, the same properties will 
be applied to all new objects of the same type in the same project. Do this by right-clicking the 
object > Set as Default.  

You can also export and reuse the object settings across projects. Do the following: 

1. Save the current project as a slide template (*.apslide) or theme (*.aptheme). 

2. Navigate to the location where you want to save the file > Save.  

If you save files in C:\Users\\Documents\ActivePresenter Templates (for Windows) or 
/Users//Documents/ActivePresenter Templates (for macOS), the template or theme will 
appear on the Start Page. Then, use this template or theme to start a new project.  
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Annotation objects include shapes, images, audio, videos, and other objects commonly used 
to add information to a project.  

Annotation objects are listed as follows: 

Object Icon Usage 

Shapes 

 
Insert a shape on/around the point of interest.  

Text Caption 

 
Insert text to explain content. 

Highlight 

 
Overlay a part of the screen with a colored semi-transparent 
area to highlight it. 

Spotlight 

 
Overlay the display area with a dark screen, allowing only a 
certain area to be fully visible.  

Equation 
 

Insert common math equations or build up your own 
equations using a library of math symbols and structures. 

Icons 
 

Insert an icon into a slide. 

Gesture Effects 

 
Insert a widget that shows how users interact with the 
application on the touch screen. 

Footer 

 
Insert date, slide number, and text into the bottom of the slide. 

Image 

 
Insert an image into a slide. 

Audio  

 
Insert an audio into a slide. 

Video 

 
Insert a video or a webcam recording into a slide. 

YouTube Video 

 
Embed a YouTube video within a slide. 

Web Object 

 
Embed a webpage within a slide.  

Cursor Path 

 
Handle mouse movements and clicks to simulate user 
actions. 

Zoom-n-Pan 

 
During rendering, zoom in the virtual camera on a part of the 
screen to show it in more details. 
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Closed Caption 

 
Insert a closed caption into a slide. Users can control whether 
to show or hide closed captions on screen. 

Shapes  

Inserting Shapes 

ActivePresenter offers five groups of ready-made shapes, namely basic shapes, callouts, lines 
and arrows, block arrows, and stars. To insert a shape, click the Annotations tab or the Home 
tab > Shapes > select a shape. The shape will be automatically inserted into a slide. 

 

The initial fill color, line color, text color, and font of a shape are determined by the theme you 
are using for your project. However, you can change these properties by using commands 
provided in the Format tab, Home tab, or the Style & Effects tab in the Properties pane. For 
more details, see Changing Object Properties. 

 

Adjustments to shapes include: 

• Reposition: Drag a shape to a new location or click the Properties pane > Size & 
Properties > Transform. 
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• Resize: Drag the resizing handles and the yellow diamond  (if any) or click the 
Properties pane > Size & Properties > Transform. If a shape contains a pointer, you 
can make it point anywhere in a slide by dragging the yellow diamond at the end of the 
pointer. Note that if you scale down a shape too much, some text within it may be 
clipped or hidden, so be careful when resizing the frame. 

• Add text: Click inside a shape or click the default text of a text caption. You can also 
right-click a shape > Edit Text or press F2 on your keyboard. Use commands in the 
Home tab to format text. 

• Edit shape: Right-click a preset shape (shape, text caption, highlight, spotlight) > Edit 
Points. Then, you can edit it in the same way you edit a freeform drawing. 

• Switch to another shape type: Click the Format tab > Change Shape > select a new 
shape type. 

If you customize a shape and want to use the same formatting on future shapes of the same 
project, you can right-click it > Set as Default Shape. That way, the current formatting will be 
set as default and used each time you insert a new shape in the project.  

Drawing Freeform  

ActivePresenter provides four types of drawing tools, namely Line, Curve, Freeform Shape, 
and Freeform Scribble, allowing you to draw your own lines and shapes. 

Lines 

To draw a straight line, click the Annotations tab or Home tab > Shapes > Lines & Arrows 

> Line . As soon as you select the drawing tool, the cursor changes into a cross hair . 
Click anywhere on the Canvas to set the start point. Move the mouse without releasing the 
mouse button to draw a line.   

While moving the mouse, hold down SHIFT to make a truly horizontal, vertical, or diagonal 
straight line. You can draw a 0, 30, 45, 60, 90, 120, 135, 150, and 180-degree line. To set the 
end point, just release the mouse button. 

 

Curves 

To draw a curve, click the Annotations tab or Home tab > Shapes > Lines & Arrows > 

Curve . As soon as you select the drawing tool, the cursor changes into a cross hair . 
Click anywhere on the Canvas to set the start point. Move the mouse to a different position to 
form a line.  

To curve the line, just click the mouse button. As you move the mouse, the curve changes 
correspondingly. Each click adds a new turn to the curve. 
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A curve can be open or closed. If you want an open curve, double-click to set the end point. 
Otherwise, move the mouse near the start point and left-click to get a closed curve. 

 

Freeform Shapes 

Freeform Shape drawing tool has a dual capability as you can draw both straight and freeform 
lines. To draw a freeform shape, click the Annotations tab or Home tab > Shapes > Lines & 

Arrows > Freeform Shape . As soon as you select the drawing tool, the cursor changes 

into a cross hair . Click anywhere on the Canvas to set the start point.  

To draw a straight segment, release the mouse button and place the cursor elsewhere, then 
click. If you keep holding down the mouse button, you’ll draw a freeform segment. You can 
alternate between straight and freeform segments within the same shape. 

 

A freeform shape can be open or closed. You can double-click at any time to set the end point, 
making an open freeform shape. Otherwise, move the mouse near the start point and release 
the mouse button or left-click to get a closed shape.  
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Freeform Scribbles 

The Freeform Scribble tool is almost similar to the Freeform Shape tool as you can mimic 
drawing with a pencil on a paper. However, there is one essential difference between these 
tools. Once you start drawing a scribble, you have to keep holding down the mouse button 
until you finish as the point where you release the mouse button will be the end point of your 
drawing.  

Click the Annotations tab or Home tab > Shapes > Lines & Arrows > Freeform Scribble 

. As soon as you select the drawing tool, the cursor changes into a cross hair . Click 
anywhere on the Canvas to set the start point. Move the mouse without releasing the mouse 
button to draw the shape.  

 

The point you release the mouse button will be the end point of your drawing. If you want an 
open scribble, release the mouse button at any time. Otherwise, move the mouse near the 
start point and release it to get a closed scribble. 

 

Editing Freeform 

To edit a freeform drawing, right-click it > Edit Points  to enter the edit mode. In the edit 
mode, the shape is outlined by a red dashed line containing multiple black squares. These 
black squares are anchor points which indicate the start and end of each line segment. When 
you select an anchor point, two blue handles appear with control points (white squares) at 
their ends. 

You can click and drag an anchor point to sharpen or smooth a corner or curve. Alternatively, 
drag a control point to change the degree of the curve or line. A red dashed line appears 
indicating changes. 
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Once you finish editing, click any elsewhere outside to exit the edit mode. Alternatively, right-
click a shape no matter its outline, anchor points, or control points, and select Exit Edit Points. 

Adding and Removing Anchor Points 

Right-click a freeform shape > Edit Points to enter the edit mode: 

• To add an anchor point, click and drag the outline of the shape. 

• To delete an anchor point, hold down CTRL and click it, or right-click it > Delete Point. 
The selected anchor point will disappear, making the shape change accordingly. 

 

Opening and Closing Paths 

In the edit mode of an open shape, right-click an anchor point > Close Path to close the shape. 
A linear path is added from the previous end point to the start point. 

 

Otherwise, select Open Path to open a closed shape right at the selected point. 
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Changing Point Types 

In the edit mode, right-click an anchor point and select an option to change the type of the 
point. 

• Smooth Point: The two handles point in exactly the opposite direction (180 degrees) 
from each other. They’re also positioned the same distance away from the anchor 
point. 

• Straight Point: The two handles point in exactly the opposite direction (180 degrees) 
from each other. 

• Corner Point: The two handles go off in different directions. This is the default mode. 

Making Straight Segments 

If you want to straighten a curved segment between two anchor points, in the edit mode, right-
click along the segment > Straight Segment.  

Text Caption 

Text caption is a rectangle shape that can contain multi-line formatted text. You can use text 
captions to direct the audience’s attention toward certain areas in a slide, give them extra 
information, or explain important concepts.  

To insert a text caption, click the Home tab or Annotations tab > Text Caption . To add 
text to the text caption, click the default text to open the inline text editor, then enter text.  

 

In fact, text caption is a variant of shapes, where only the text is given prominence, and the fill 
and line properties are muted. Therefore, the discussion for shapes also applies here.  

Highlight 

Highlight is a transparent, colored rectangle shape that can be placed over a certain area in a 
slide to draw the audience’s attention to that area.  

To insert a highlight, click the Annotations tab > Highlight . You can change the formatting, 
color, transparency, and size of highlight objects to fit the target area. 
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Think of highlight as a variant of shapes, where the text and border line are removed and the 
background is made semi-transparent (50% transparent). Therefore, the discussion for 
shapes also applies here. 

Spotlight 

Spotlight retains the original brightness within the shape and darkens the rest of the screen, 
creating an effect like you are watching a dark screen with a searchlight. Thus, it is able to 
instantly draw the audience’s attention to even a tiny part of the screen. 

To insert a spotlight, click the Annotations tab > Spotlight . 

 

Spotlight is actually a more aggressive version of highlight, where the rest of the screen isn’t 
darkened. It is also a shape object with special properties. For that reason, the discussion for 
shapes also applies here, but there are two exceptions: 

• In the Properties pane, the Style & Effects tab shows the properties of the area that 
lies OUTSIDE the shape (not inside it). 

• Spotlight object doesn’t have the rotation property. 

Equation 

Equation allows you to place math equations and formulas in a slide. Besides built-in 
equations, you can write your own equation using math symbols and structures. Of course, 
you can modify the built-in equations if they don’t satisfy you. Moreover, it’s possible to copy 
equations from Microsoft Office and paste into ActivePresenter. 

Inserting Built-In Equations 

To insert a built-in equation, in the Annotations tab, click the arrow on the Equation button, 
then select the equation you want from the list. You can also find this button in the Home tab. 



ActivePresenter User Manual  Version 7.5 

Annotation Objects > Equation 105 

 

As you insert an equation in a slide, in the tabbed toolbar, the Formula tab opens. This tab 
contains symbols and structures that you can add to your equation. 

Writing and Editing Equations 

You can write an equation from scratch or edit the built-in equations. In the Annotations tab, 

click the Equation button . This inserts a placeholder for your new equation in a slide and 
opens the Formula tab.  

 

Do one of the following:  

• Click the Equation button at the left corner to insert built-in equations. 

• Insert math-related symbols using the Symbols group. To see more symbols, click the 
arrow at the bottom-right corner of the gallery. To see other sets of symbols, click the 
arrow at the top-right corner of the gallery. 



ActivePresenter User Manual  Version 7.5 

Annotation Objects > Icons 106 

 

• Insert structures using the Structures group. Just select a structure to insert it, then 
replace the small dotted-line boxes with your own values.  

 

• To edit an equation in a slide, just click in the equation to open the Formula tab and 
make changes as you want. 

Icons 

Using icons is a good way to add visuals to your presentation. Icons are illustrative vector files 
which can be resized without pixelation. Once you’ve inserted an icon into a slide, you can 
move, resize, rotate, or style it the way you want. 

To insert an icon, click the Annotations tab > Icons  > select an icon. 
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Some icons are actually groups of freeform shapes, so you can edit them in the same way to 
how you edit groups. In fact, icons are a variant of shapes, so the discussion for shapes also 
applies here. 

Gesture Effects 

Gesture effects are mostly used in the demonstration mode to show how users interact with 
the software on the touch screen. Basically, a gesture effect looks like an animated GIF image. 

To insert a gesture effect, click the Annotations tab > Gesture Effects  > select an effect 
from the list of 14 types. 
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To change a gesture effect, click the Properties pane > Size & Properties > Gesture Effects 
and select a new gesture effect from the Type drop-down list. Note that gesture effect object 
doesn’t have the rotation property. 

Footer 

Footer allows you to add a date and time, slide numbers, and text to the bottom of a slide. To 

insert a footer, click the Annotations tab > Footer . A dialog appears as follows: 
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• Date: Add a date and time. 

o Update Automatically: Add a date and time that is updated each time you open 
or print the project. 

o Fixed: Add a fixed date and time. 

• Slide Number: Add slide numbers. 

• Footer: Add text to the center bottom of the slide. 

• Don’t show on title slide: Make the footer not appear in the title slide. 

• Click Apply to add footer to the current slide. Click Apply to All to add footer to all 
slides. 

Image 

Images are a good visual to enhance content. Depending on the context of the project, images 
may be screenshots of applications, drawings (electrical, civil, mechanical, etc.), or photos of 
persons, products, places, buildings, etc. 

Inserting Images 

ActivePresenter currently supports five image types: PNG, JPG, JPEG, BMP, and GIF. 

To insert images, do the following:  

• Click the Annotations tab > Image  > select images. You can also drag images 
directly from your computer onto the Canvas. 

• Click the Annotations tab > Screenshot  to take a screenshot of anything on 
screen.  

Editing Images 

After inserting an image, you can resize it to the size you want. If you want to revert the original 
size, right-click the image > Restore Original Size.  

Besides, you can: 

• Make images transparent: Right-click > Image Properties to open the Image section 
in the Properties pane. Drag the opacity slider to change the transparency level for 
the image.  

• Replace images: Right-click > Image Properties to open the Image section in the 
Properties pane. Click From Project… or From File… to choose another image from 
the current project or your computer, respectively, to replace the selected image. Bear 
in mind that if the new image has different size or ratio compared to the selected image, 
it will be stretched to fit into the selected image object. 

• Further edit images: Right-click > Edit Image.... This opens the Image editor and the 
Drawing tab which help you edit the image as you wish. While editing the image, once 
you click Save in the Quick Access Toolbar, all your changes to the image will be 
applied and reflected in the slide. When you’re done, close the Image editor and go 
back to editing the slide. 
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Exporting Images 

You can export both images you’ve created within your project, such as screenshot, and 
imported images to files. There are three supported file formats: PNG, JPG, and BMP. 

To export images, do the following: 

1. Select an image either on the Canvas or in the timeline. 

2. Right-click it > Export To File…. 

3. Specify the file name, file format, and file location, then click Save to export. 

Taking Screenshots 

A typical application has a top-level window, which may have child windows that appear to 
accomplish different tasks. The windows form a hierarchical tree. A window at any level 
(top/child) has objects (menus, panes, toolbars, controls, etc.). ActivePresenter allows you to 
take a screenshot of any of these windows/objects, which is then inserted into the current slide 
of your project. 

To take screenshots, click the Annotations tab > Screenshot  > select a screenshot mode. 

 

Window 

Select the Window mode  to capture a screenshot of the target window or any object in it. 
You can capture a window at any level of the application.  

1. Use the mouse to select a window or its object (toolbars, panes, menus, etc.). You can 
click on screen and the target application normally as this doesn’t trigger a screenshot. 

As you move the mouse over different parts of the screen, a red dashed outline  
appears around the areas that can be captured. 

2. When you find the correct area to be captured, press PRINT SCREEN or CTRL+Click. 
A screenshot is captured and placed on the current slide. 

Note: ActivePresenter cannot detect some objects in certain target applications. This is 
because those applications don’t provide MSAA interface for those controls. ActivePresenter 
typically captures the whole toolbar because it is usually the lowest child level window. 

Object 

Select the Object mode  to capture a screenshot of any object in any window. 

1. As you move the mouse over different parts of the screen, a red dashed outline  
appears around the areas that can be captured. 

https://en.wikipedia.org/wiki/Microsoft_Active_Accessibility
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2. When you find the correct area to be captured, press PRINT SCREEN or CTRL+Click. 
A screenshot is captured and placed on the current slide. 

Note: ActivePresenter cannot detect some objects in certain target applications. This is 
because those applications don’t provide MSAA interface for those controls. Typically, 
ActivePresenter can capture the individual tools in any toolbar, depending on the accessibility 
support level of the target application. 

Full Screen 

Select the Full Screen mode  to capture a screenshot of the entire screen of your PC. 
ActivePresenter will minimize its own window, and capture whatever visible on your computer 
screen.  

A screenshot will be placed on the current slide. Be careful that the screenshot is very likely 
to be larger than your slide. If you resize it to fit the slide size, the details in the image will get 
blurred, and users may not be able to read specific details. 

Application or Region 

Select the Application or Region mode  to capture a screenshot of the top-level window 
of the target application, or a rectangle region of the screen. Immediately, a blue rectangle 
and a dialog appear. You can drag and position the rectangle around the target part of the 
screen. You can also resize it as you want. 

 

The Take Screenshot command window works as follows: 

https://en.wikipedia.org/wiki/Microsoft_Active_Accessibility
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1. Screenshot Usage: Insert the screenshot as an image into the current slide, and/or 
as a background image of a new slide that will be inserted below the current slide. 

2. Screenshot Size: Specify the size of the screenshot. The Preset Sizes button allows 
you to select from several predefined sizes. 

3. Application: Provide a list of all current applications running on the PC that have a 
visible window.  

o Fit To Application: Resize the blue rectangle to fit into the application window. 

o Fit To Boundary: Resize the application window to fit into the blue rectangle. 

4. Wait for: Specify a delay (in seconds). Use this delay to quickly interact with the target 
application and capture its response. 

5. To take a screenshot, click the Take Screenshot button. 

Screenshot Options 

To change screenshot settings, click the Annotations tab > Screenshot > Options.   

 

• Capture Window Shadow: When an application window is in non-maximized state, 
the Windows OS casts a drop-shadow around its border. Select this option to capture 
this shadow while taking a screenshot of the target window. 

Note that this drop-shadow is treated as a part of the image but not the shadow 
property of the screenshot. In other words, you can add one more shadow to this 
captured image with a different set of parameters (color, distance, angle, etc.) 

• Process Rounded Corners: When an application window is in non-maximized state, 
the Windows OS offers an option to display rounded corners. Select this option to 
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capture those rounded corners. If you turn off this option, the captured image will have 
sharp corners. 

• Use Opaque Background: Windows 7 and later have an option to use Aero theme, 
where the border of windows appears semi-transparent. While the windows look great, 
they mess up the screenshot because any text/images in the background will also 
show up through the border. Select this option to replace this transparency in the 
screenshot with opaque border.  

• Show Usage Guide: Show a yellow text box that describes how to capture a 
screenshot when capturing windows or objects. If you are apt to forget the shortcuts, 
leave this display on. 

Note that the first three options work only when you capture a window at any level but not 
when you capture a region or an object. 

YouTube Video 

YouTube videos can be used as an effective tool to make your presentation more informative. 
Do the following steps to embed a YouTube video in a slide: 

 

1. Click the Annotations tab > YouTube . A dialog appears, letting you add the video. 

2. Type the URL of the YouTube video into the Link text box. 
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3. Click Preview or press ENTER to load and preview the video within the dialog. 

4. Specify playback options for the video (see below for more details). 

5. Click OK to finish. 

Below are available playback options: 

• Autoplay: Make the video start playing as soon as the slide’s timeline reaches the 
start of the video object.  

• Hide Annotations: Hide annotations in the video such as notes, labels, or titles. 

• Hide Controls: Hide the player controls for the video. Remember that without controls, 
you can still play or pause the video by clicking it. 

• Disable Scaling: Keep embedded content the same when scaling a slide (for example, 
in the AutoFit mode of the presentation, when zooming and panning). This option is 
turned on by default. 

• Play Specific Part: Embed just a part of the video. Select this option and enter the 
start time and end time (in seconds) in the spin boxes. 

For example, if a video is of 2 minutes, and you want it to start playing at the 20th 
second and stop at the 60th second, enter 20 and 60 in the two spin boxes, respectively. 

After embedding a YouTube video within an object in a slide, you can resize the YouTube 
object to the desired size. In case you aren’t satisfied with the change and want to bring back 
the original size, right-click the object > Restore Original Size. 

You can also update the video thumbnail to the latest thumbnail on YouTube and to the current 
object size in ActivePresenter. Just right-click the object > Update Thumbnail. 

To change a YouTube video, click the Properties pane > Size & Properties > YouTube > 
Edit. 

Note: 

• YouTube video only works in HTML5 output. In other outputs, it is exported as image. 

• Due to technical limitation, there is no warranty that the playback of a YouTube video 
will always synchronize with the playback of the project. 

• On mobile devices, only user-initiated playback is acceptable. So, users need to click 
a YouTube video to play it even when they enable the Autoplay option. For this reason, 
you should not select the Hide Controls option when creating content for mobile 
devices. 

Web Object 

Web objects allow you to embed a website directly in a slide. They can help enhance your 
project with web-based resources such as websites, games, social media, and reference 
material. In ActivePresenter, both full/absolute and relative URLs are supported for web 
objects. 

To insert a web object, do the following: 



ActivePresenter User Manual  Version 7.5 

Annotation Objects > Web Object 115 

 

1. Click the Annotations tab > Web Object . A dialog appears, letting you embed a 
webpage using either a web address or a piece of code. The latter is useful when you 
want to control the size of the window or its relative position on screen. 

2. Type the URL of the webpage into the text box or switch to Embed Code and type the 
code. 

3. Click Preview or press ENTER to load and preview the web object within the dialog. 

4. Specify scrolling and scaling behaviors for the object.  

o Scrolling: Allow scrolling down the content. 

o Disable Scaling: Keep the embedded content the same when scaling a slide (for 
example, in the AutoFit mode of presentation, when zooming and panning).  

5. Click OK to finish. 

After embedding a webpage within an object in a slide, you can resize the web object to the 
desired size. In case you aren’t satisfied with the change and want to bring back the original 
size, right-click the object > Restore Original Size. 

You can also update the thumbnail to the latest thumbnail and to the current object size in 
ActivePresenter. Just right-click the object > Update Thumbnail. 

To change a web object, click the Properties pane > Size & Properties > Web Object > Edit. 

Note: Web object only works in HTML5 output. In other outputs, it is exported as image.  
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Cursor Path 

Cursor path enables you to simulate mouse movements and clicks, which is extremely useful 
for software training. A cursor path has a start point (1), an end point (2) and a dotted line (3) 
presenting the movement of the pointer between these two points.  

 

• The red arrow shows the direction of the cursor movement. 

• Half of the dotted line toward the start point is green in color, and its remaining half 
gradually turns red toward the end point. 

• The spacing between dots indicates the speed of the cursor on screen. That is, the 
faster the cursor moves across the screen, the farther are the dots. On the contrary, 
closely spaced dots mean slower speeds. 

• When you click the start point, a square appears to denote that the start point is 
currently selected. ActivePresenter shows a control point (4) associated with the end 
point. The line between the control point and the end point is tangent to the path at the 
end point. Move the control point to change the shape of the path. 

In practice, cursor path objects are generated in two different ways: 

• During the capture phase, ActivePresenter records your mouse movements and 
converts them into cursor paths. You can edit these paths by adding mouse click 
sounds and effects in the edit phase. 

• During the edit phase, you can insert your own cursor path and style the path the way 
you want. In general, the idea is to insert a cursor path, then add points to the path and 
place them over buttons or other clickable objects. Optionally, you can add click points, 
where ActivePresenter produces the click sound in the rendered project.  

Adding Cursor Paths 

You can insert only one path to a slide. Do the following: 

1. Click the Annotations tab > Cursor Path . This inserts a cursor path into the current 
slide. 

2. Add points to the path. Hover anywhere over the dotted line, the pointer changes to a 
pencil (1). Click to add a point (2) and drag that point (3) to the position you want (4). 
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3. Any path segment can be made a curve or a straight line. Just right-click the start point 
> Straight/Curved Cursor Path. Another way to change the path is to move the 
control point. 

Tip: 

• Highlight the mouse cursor so that users follow it more easily. To do that, select one 
point on the path > Properties pane > Size & Properties > Cursor Path > Highlight. 

• In the Cursor Path section, select Show to end to show the path until the end of the 
slide. 

Changing Cursor Styles 

To add a cursor image to a point or replace the original pointer with another shape. Do the 
following: 

1. Click a point. 

2. Click the Properties pane > Cursor > Cursor Image. 

3. Select the cursor image you want from the gallery. You can even use your own image 
by clicking the From Project or From File button.   
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In the following example, several points are added to the original path. The cursor for each of 
those interim points is also changed. When rendered, this path will keep changing the cursor 
shape along the way. 

 

Changing Timing and Speed of Mouse Movements 

Take a look at the cursor movement in time. The cursor path has four segments in total. 
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The figure shows the 3rd segment with four instants 1-4 marked on both the Canvas and the 
timeline. From the timeline, you can see that: 

• The gray vertical line (1) starts the life of the segment. 

• The instant when the cursor starts moving is marked with a red vertical line (2).  

• During the 1→2 gap, the cursor is at rest (there is no movement). This is the start 
duration of the cursor.  

• The instant when the cursor stops moving is marked with a second red vertical line (3).  

• During the 3→4 gap, the cursor is at rest (there is no movement). This is the stop 
duration of the cursor. 

• The green horizontal line indicates the moving duration of the cursor. 

• The second gray vertical line (4) denotes the end of the segment. 

• The yellow diamond  represents a click point. This is where ActivePresenter 
simulates a click by creating a click sound and click effect. 

You can drag the lines above to change where the movements of the cursor begin and how 
long they last. Alternatively, click the Properties pane > Cursor > Timing to adjust the timing 
and speed of the mouse movement. 

Adding Click Points and Effects 

You can convert any point along the path into a click point by doing the following: 

1. Click a point. 

2. Click the Properties pane > Cursor > Click Point. 
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3. Select the desired type of click point from the Type drop-down list. Select None if you 
don’t want to add a click point.  

4. Further customize the click sound, time and effect if you wish. 

5. Click Apply To All to apply changes to all click points of the same type.   

Continuation of Cursor Paths between Slides 

Normally, when you drag the start or end point of a cursor path, ActivePresenter also moves 
the corresponding point in the previous/next slide to ensure a smooth mouse movement. 
That’s thanks to the Cursor Snapping tool in the View tab. 

If you don’t want the cursor path to move continuously between slides, click the View tab and 

turn off Cursor Snapping . 

Let us explain this with an example. In the following figure, the end point of the cursor path (1) 
in a slide has the same coordinates as the start point of the cursor path (2) in the next slide. 
As result, when the rendered presentation transitions from the first slide to the next one, the 
movement of the cursor appears to be continuous (without any jerks). If you move the end 
point (or the start point) in any slide, ActivePresenter automatically moves the corresponding 
point in the other slide to match their coordinates. 
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In rare cases, the cursor path can be out of sync. For example, when you delete a slide that 
is in the middle, or delete the cursor path in that slide. This results in an abrupt movement of 
the mouse cursor in the rendered presentation when the slide changes. To avoid this, you can 
again stitch the ends of cursor paths of adjoining slides together. Do the following: 

• Right-click the start point > Snap to Previous. 

• Right-click the end point > Snap to Next. 

Tips to Compose Cursor Paths 

Here are a few tips for composing a realistic-looking cursor path: 

• Avoid showing the mouse all the time. It is OK if the mouse vanishes from the scene 
for a while. 

• Remove aimless wandering of the mouse to prevent distraction. 

• Avoid using the mouse as a presentation pointer. Instead, use shapes, zoom-n-pan 
effects, spotlights, or other types of annotations. 

• The resting periods are important in realistic depiction of the mouse movement. In fact, 
they contain the click points (you cannot click while the mouse is moving). 

• When you are narrating something, keep the mouse at rest. 

• Before clicking any important control, first prepare users, by (a) describing which 
control you are going to click, and (b) what will be the consequence of that action. That 
way, users will be able to observe the action closely and correlate the happenings on 
screen. It is a poor practice to first do something and then tell users about what you 
did. While users struggle to make sense of what you said, they would lose track of 
what you will say next. 
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Zoom-n-Pan 

Zoom-n-pan allows you to zoom in a specific area of a slide during playback. This is useful 
when you want your audience to focus on a specific part instead of the entire screen.  

Consider this object with an example. In the following screenshot, the image of the Taj Mahal 
occupies the entire screen. Now imagine you were standing on the right minaret. You would 
like to zoom in that minaret. 

 

Creating Zoom-In Effects 

To insert a zoom-n-pan object, do the following: 

1. In the timeline, position the Playhead where you want the effect to start. 

2. Click the Annotations tab > Zoom-n-Pan . The zoom area appears on the Canvas. 
This resizable rectangle must always have the same aspect ratio as slides. 

3. Change the size and position of the zoom area directly on the Canvas or in the 
Properties pane > Size & Properties > Position & Zoom Scale.  

4. Change the timing and speed of the effect in the timeline or in the Properties pane > 
Size & Properties > Timing. The effect should not be too fast, otherwise it becomes 
nauseating. 

5. By default, zoom-n-pan objects only appear in the Demonstration and Tutorial modes. 
To change the operation modes for showing them, click the Properties pane > Sizes 
& Properties > Show In Mode.  
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When the slide is rendered, the camera shows the entire scene, then zooms in and 
simultaneously pans sideways to the minaret.  

Creating Panning Effects Using Multiple Zoom Areas 

You can create a continuous panning effect using multiple zoom areas. Just position the zoom 
areas at different places in a slide. In the timeline, place the zoom time bars so that the effect 
occurs as desired.  

Zooming Back to Normal View  

The zoom-n-pan object has a one-way effect. When it ends, it doesn’t restore the zoom back 
to normal. So, in the above example, the camera will keep looking at the minaret till the slide 
ends. To go back to the normal view, you have to use another zoom-n-pan object to zoom out. 
Just resize the zoom area so that it covers the entire slide.  

Closed Caption 

Closed captions (CC) are a text version of the spoken part of televisions, movies, videos, or 
presentations. The qualifier term “closed” means that the user has the power to display or hide 
the closed caption lines. 

A closed caption object is quite different from other object types: 

• A slide may have no or multiple CC lines. Each CC line is represented by a time bar in 
the timeline. All CC lines in a slide are considered as one CC object. Thus, you can 

only toggle the lock and visibility state of all CC lines at a time by clicking the  and 

 icons on the left side of the timeline. 

• The visual properties of all CC objects can only be set globally in your project. You 
cannot set a different visual property for each CC object. In other words, if you change 
the style of the CC in one slide, it will be applied to the CC in all other slides of that 
project. 

• CC lines are arranged in time order and there is no overlapping in time between CC 
lines. This means only one CC line can be displayed at a time. 

• You cannot switch the order of the CC lines. 

• CC lines are often converted into speech. When converted, all lines of a CC object 
produce a combined single audio object.  

Adding and Importing Closed Captions 

You can make a closed caption from scratch or import closed captions from a caption file with 
the *.srt file extension. 

To add a CC line from scratch, do the following: 

1. In the timeline, place the Playhead at the timestamp that you want to add a CC line. If 
the timestamp isn’t specified, ActivePresenter will append the new CC line to the end 
of all existing CC lines. 

2. Click the Annotations tab > Closed Caption  or click the Insert Caption button in 
the Timeline pane.  
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Immediately, a time bar (1) appears in the CC object line. On the Canvas, the CC editor 
(2) appears, allowing you to type the caption. 

 

3. Type the closed caption in the editor. Then, position the Playhead to another 
timestamp and repeat the cycle. All CC lines in a slide are put in the same line and 
considered as one CC object. 

4. Drag the CC line or either of its end points to change its timing and duration. You 
should display each CC line for adequate time so that your audience can read it 
comfortably. 

5. To remove one or more CC lines, in the Timeline pane, select them and press 
DELETE. To remove all CC lines in a slide, click the Closed Caption name to select all 
lines and press DELETE. 

On the other hand, if you have a caption file created in ActivePresenter or another software, 
you can import it to a slide. ActivePresenter supports only *.srt file format for closed caption 
files. 

1. In the Annotations tab, click the arrow on the Closed Caption button > From File > 
select the file you want.  

2. The captions will be added to the timeline from the beginning. Click the Preview button 
to view the captions with a slide. 

Formatting Closed Captions 

The style of all CC lines is set globally in your project. If you change the style of one CC line 
in a slide, the change will affect all CC lines in that slide and in other slides in the same project. 

To format a CC line, do the following: 

1. In the timeline, place the Playhead at the timestamp that the CC line appears. That 
makes the CC line visible on the Canvas. 

2. Click the CC line on the Canvas to open the inline text editor. 

3. Edit the text or the fill style of the CC line. Do that by using commands and options 
available in the Home tab, Format tab, or the Properties pane. 
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Adjusting Closed Captions in Timeline 

If you have annotated a slide with shapes and zoom-n-pan effects, your closed captions and 
text to speech (TTS) audio must refer to the feature that is being highlighted at that particular 
moment. However, this doesn’t happen automatically. There may be several sync problems: 

• The CC may run into the subsequent scene which has no relation to what the CC is 
talking about. 

• The converted audio may interfere with an audio embedded within the slide during the 
capture phase.  

• The converted audio may overlap with TTS audio of other objects (shapes, for 
example). 

• The converted audio may overlap with other stand-alone audio/video objects. You 
have to check the project for these problems and sort them out. 

To synchronize the CC with your annotations, go back to the slide and look at the timeline. 
Each CC appears in the timeline as a separate time bar. Look at its relationship with other 
objects in the timeline, and adjust the time bars. 

• Display each CC for adequate time so that your audience can read it comfortably. The 
longer the CC is, the more time it needs to be shown. 

• If you have used TTS narration, it needs to be read fully while the corresponding 
feature is still highlighted. 

• In case of videos, you can freeze the frame for a few moments till the narration and 
CC play out. After that, resume the playback. 

When you adjust the CC time bars in the timeline, changes are reflected in the CC editor on 
the Canvas. Consider the following example: 

The following screenshot shows the Taj Mahal project. It shows three time bars in the CC line, 
which means there are three captions. 
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The time bars in the timeline are adjusted as follows: 

• The first CC (1) introduces the Taj Mahal. It should start a couple of seconds after the 
slide starts. Its duration is adjusted so that the audience can read the text comfortably. 

• The intent is zoom in a minaret (2) and reveal an amazing fact that the minarets are 
intentionally built tilted, so that from afar, they actually look perfectly vertical. So, the 
zoom-n-pan (2’) takes the audience to the minaret. 

• Once the view is zoomed in, the second CC (3) is displayed. Since this is a longer 
sentence, more time is given to it. 

• Another zoom-n-pan (4) brings the view back to normal. This is intentionally done at a 
faster pace, because it only reverts to the full view that was already there. After that, a 
small gap is allowed so that the audience can reorient themselves. 

• Finally, the third CC (5) starts. Adequate time is given so that the audience can read it 
comfortably. 

Here are some tips for manipulating CC lines that can help you position the CC time bars 
correctly (for example, to synchronize with the audio): 

• You can select multiple CC time bars by pressing SHIFT+Click (to select all adjoining 
time bars) and/or CTRL+Click (to select all non-adjoining time bars). 

• You can shift multiple selected CC time bars simultaneously by dragging the mouse. 



ActivePresenter User Manual  Version 7.5 

Annotation Objects > Closed Caption 127 

Converting Closed Captions to Speech 

ActivePresenter lets you convert closed captions to speech using the Text to Speech feature 
(also TTS). When converted, all CC lines in a slide produce a single audio object. This audio 
object works just like other audio objects, meaning that you can use the built-in audio tools to 
edit it. 

ActivePresenter also allows you to use different voices, speeds, and volumes for each CC 
lines. This is useful when you want to make conversations, for example. Besides, you’re 
enabled to do a batch operation to generate audio from closed captions in some specified 
slides or in all slides in your project. 

Converting Closed Captions in a Single Slide 

You can apply different settings to each CC line in a slide, then convert all of them into audio. 
To do that, select a CC line and do the following: 

1. Click the Properties pane > Size & Properties > Caption. 

 

2. In the Text To Speech part, specify the voice, speed, and volume for the CC line. 
Then, click Speak to listen to the voice and click Stop to stop listening. 

3. Optionally, click Change Default Settings to change the default TTS settings in the 
Text To Speech dialog. Thereby, newly added CC lines will apply the new default TTS 
settings. 

The Text To Speech dialog appears as follows: 
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To check the settings, enter a test sentence in the Preview text box. Then, change the 
voice, speed, and volume, and click Speak to listen to the voice. 

o If the results aren’t OK, change the parameters and try again. Repeat the cycle till 
you are satisfied. 

o If your settings aren’t good enough, click Reset and start over. 

o When you are satisfied, click OK to close the dialog. 

4. After adjusting each CC line, in the timeline, right-click a CC line > Convert Closed 
Caption to Audio. This converts all CC lines in a slide into speech. 

5. After the conversion, you’re asked whether to extend the duration of the CC object to 
match the duration of the converted speech. If you select Always do this from now 
on, ActivePresenter will remember your preferences. 

 

Regardless of your choice, the TTS audio will be generated and placed right below the 
CC object in the timeline. 

Note: 

• It’s possible to adjust the speed and/or volume of a CC line and apply the same settings 
to other CC lines. To do that, right-click a CC > Apply Speed/Volume For All Caption 
Nodes. 

• You can change the default settings for what ActivePresenter does when you convert 
text to speech: Should it display the dialog so that you can make further changes to 
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the TTS settings before converting? Do this by clicking the ActivePresenter button > 
Preferences > Miscellaneous > Extend object duration to match the duration of 
generated audio. 

Converting Closed Captions in Multiple Slides  

ActivePresenter also provides a batch operation to convert closed captions in some specified 
slides or in all slides in your project. Do the following: 

1. Click the Slide tab > Batch Operations > Convert Closed Captions To Audio. A 
dialog appears as follows: 

 

2. Specify the slides where you want to convert closed captions to audio. If you choose 
Specified Slides, separate the ordering numbers of slides by commas. Otherwise, 
use hyphens to indicate ranges. For example, the range 3-6 indicates the 3rd, 4th, 5th, 
and 6th slides. 

3. Click Change Default Settings to change the default TTS settings in the Text To 
Speech dialog. These settings will be applied to all CC lines which are inserted 
afterward. Once you’re satisfied, click OK to close the dialog and back to the main 
dialog. 

4. In the main dialog, select Extend caption duration to match the duration of 
generated audio if needed. This may cause sync problems, so you have to check out 
the project carefully. 

Note: Even when you have already converted many CC objects, you can still launch this batch 
operation safely, without any adverse effects. 

Miscellaneous Tips 

Here are some general tips for using closed captions: 

• Always ensure correct spellings. 

• Use words that match the actual voice narration. Do not try to paraphrase; otherwise 
the audience may find it hard to read the CC. 
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• Use punctuation to clarify the meaning. If a sentence ends normally, use the 
appropriate mark (.?!) at the end. However, a sentence that is left unfinished should 
end with an ellipsis (…). 

• Translate foreign words in parenthesis ( ). 

• Use italics (or ALLCAPS) to denote a new word or a heavily emphasized part of 
speech. 

• Show music or other sound effects in square brackets, such as [music], [door slams], 
[crowd at the bar], or [laughter]. 

• Use square brackets to describe any mood conveyed through voice modulation, such 
as [whispers], [shouts], [menacingly], [croons], [sobs]. Always use the appropriate 
word to convey the degree of intensity of an action. For example, chuckles, smiles, 
laughs, and guffaws are all different. Similarly, door closes and door slams convey 
entirely different moods. 

• When the speaker is off screen, identify him/her by name. 

• When more than one person is on screen, identify the speaker by name.  

• As a rule, show only one line of closed captions at a time. An exception is when multiple 
people speak simultaneously. In that case, it is OK to show their sentences together; 
but always maintain the correct sequence (a sentence that starts first should be listed 
at the top of the CC stack). Another exception is when one person is interrupted by 
another. Here, end the first (interrupted) sentence with a dash “–”; and place the 
second (interrupting) sentence in the second line. 

https://en.wikipedia.org/wiki/Punctuation
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Inserting Audio and Videos 

You can insert audio and video tracks into a slide to engage audience. ActivePresenter 
currently supports audio/video formats as follows: 

• Audio: MP3, OGG, WMA, and WAV. 

• Video: MP4, MKV, WMV, FLV, AVI, WebM, and M4V. 

Inserting Audio  

An audio object is displayed on the Canvas as the  icon and its time bar is displayed in the 

timeline. The  icon is just a visual indicator to remind you that there is an audio object in a 
slide. Its placement on the Canvas doesn’t matter as this icon isn’t visually rendered in the 
final output. However, you can right-click the icon > Audio Properties to open the Audio 
section in the Properties pane where you can edit your audio. 

In a recorded project, audio objects are created when you narrate the operation of the target 
software and record system audio. Later, during the edit phase, you can add audio objects to 
a slide in many different ways: inserting audio from files, inserting built-in audio, recording 
audio, and converting text to speech. Depending on how audio objects are created, they are 
displayed in three different ways: 

• When an audio object is inserted into a slide, the Canvas displays the  icon (only in 
the edit mode; not in the output). The timeline displays the time bar of the audio object. 

• When an audio track is attached to an object (for example, the audio attached to a 
shape), the timeline displays its waveform bar within the target object time bar. There 

is no  icon on the Canvas. 

• When a closed caption is converted into audio, a separate audio object is created. The 
timeline shows a separate time bar of the audio object. 

In all cases, the time bar of the audio object in the timeline shows the actual audio waveform, 
which facilitates editing. 

Inserting Audio from Files 

To insert an audio into a slide, click the Annotations tab > Audio  > From File… and 
choose an audio file. You can also drag an existing audio file from your computer onto the 
Canvas. 

Inserting Built-In Audio 

ActivePresenter provides you with some useful built-in audio for mouse clicks and questions. 

To insert built-in audio, click the Annotations tab > Audio  > Built-in and choose an audio 
file. 
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Recording Audio 

There are two ways to record an audio. First, use the Record Narration button in the Timeline 
pane to record and create a new audio object. Do the following: 

1. Click the arrow next to the Record Narration button > Recording Options. 

2. In the dialog that appears, select an input device, adjust input volume, and calibrate 
input volume.  

3. Place the Playhead at the timestamp you want to add audio recording. 

4. Click Record Narration to start recording your voice.  

5. Click Pause/Resume to pause/resume the recording. 

6. Click Stop to stop the recording. Your narration is recorded as an audio object. 

Note: It’s good to reduce noise after recording narration. 

The second way to record audio is to insert an empty audio which will be later use for recording 
or converting text to speech. Do the following: 

1. Click the Annotation tab > Audio > Create New to create an empty audio object. 

2. Click the Properties pane > Media > Audio. From here, you can record your voice 
using the Recording part or generate TTS voice using the Text To Speech part. 

Converting Text to Speech 

You can generate audio from text for audio objects and other objects with attached audio. For 
audio objects, click the Properties pane > Media > Audio. For objects with attached audio, 
click the Properties pane > Audio tab. For more details, see Audio. 

Inserting Videos 

You can enhance your presentation with videos from files, webcams, and screen recordings.  

Inserting Videos from Files 

To insert a video into a slide, click the Annotations tab > Video  > From File… and select 
a video file. You can also drag an existing video file from your computer onto the Canvas.  

After that, you can resize the video to the size you want. If you want to revert the original size, 
right-click the video > Restore Original Size. 

Inserting Videos by Recording Screen 

You can record screen and insert the recorded video as a video object into the next slide below 
the current slide. Just click the Home tab > Record Screen > Record Video or the Slide tab 
> Record Video. 

For more details, see Recording Videos. 

Inserting Videos by Recording Webcam 

To record a video from webcam, click the Annotations tab > Video  > Webcam 
Recording. A dialog appears, allowing you to record your webcam. 
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1. Select a webcam device from the (Webcam) Device list. You can click Refresh to 
detect new webcam devices. Besides, click Properties to adjust video signal and 
camera control and Settings to fine-tune video format and compression. 

2. Select an audio recording device from the (Audio) Device list. You can click Volume 
to adjust input volume and Calibrate Input… to change recording sensitivity levels. 

3. Click Record to start recording. 

4. Click Stop to stop recording. 

Converting Videos to Author Videos 

For instructional purposes or presentations, you may want to record screen and webcam at 
the same time. At run time, users often see the webcam video appear at a corner of the 
screencast and cover a portion of it. While this may be useful to instruct users, both the 
presenter and the user may experience potential disadvantages. For example, the webcam 
video may block the user's view of some important information that the screencast conveys. 
As for users, chances are that they find the webcam video unnecessary or even distracting 
and don't want to watch it, but they have no way to turn it off. 
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Taking that into account, ActivePresenter provides the author video feature, which turns a 
normal video into an author video. The author video appears in the side bar of the player 
instead of covering the content. Thus, users can choose to watch the author video and the 
content simultaneously or hide it by hiding the side bar. The Show/Hide Side Bar button is 
enabled by default and appears at the bottom-right corner of the player toolbar. 

 

To convert a video to an author video, on the Canvas, right-click it > Convert To Author 
Video. This will play the video over multiple slides in the project and place the video in the 
side bar of the player.  

Note: 

• A single project can have more than one author videos. To adjust the timing and 

duration of author videos, in the Timeline pane, click the All Slides button  to view 
objects that span across slides. Then, drag the time bars of the author videos as you 
wish.  

• If you don’t want an author video anymore, on the Canvas, right-click it > Remove 
Author Video. 

• To display the author video in the side bar of the player, click the Export tab > Player 
Settings > General > General Parameters > Side Bar > Display Author Video. 

Changing Playback Options 

ActivePresenter lets you control how an audio/video plays using several playback options. On 
the Canvas, just right-click an audio/video object > Audio/Video Properties to open the 
Audio or Video section in the Properties pane. In these sections, you can view some 
information about the audio/video, replace the audio/video, and control playback. 
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There are three generic options: 

• Loop: Make the audio/video replay continuously. 

• Autoplay: Make the audio/video start playing as soon as the object starts showing.  

• Show Media Controls: Display the media controls that allow users to control the 
audio/video playback in the HTML5 output.  

For audio objects, there is one specific option named Background Music. Select this option 
to set an audio object as background music of the presentation. See Background Music for 
more details. 

Exporting Audio and Videos 

You can export both audio/video you’ve created within your project and imported audio/video 
to files. These are the supported file formats: 

• Audio: MP3, OGG, and WAV. 

• Video: MP4, MKV, WMV, FLV, AVI, and WebM. 

To export audio/video objects, do the following: 

1. Select an audio/video object. 

2. Right-click it > Export To File…. 

3. Specify the file name, file format, and file location, then click Save to export. 

Basic Audio and Video Editing  

Range-Editing 

The Timeline pane has four range-editing commands  that work only when 
a range is defined first. 

Consider these commands with the following examples, in which each command is used in 
two different circumstances: (a) when none of the objects are selected, and (b) when some 
objects are selected. 

Each set has three figures: (1) the original objects, (2) result when none of the objects are 
selected, and (3) result when some objects are selected. 

Cutting Ranges 

Click the Cut Range button  to remove the range and place it on the clipboard. You can 
paste the cut content into the current slide or the new one. 

The following example shows the effect of the command when no objects are selected in the 
slide: 
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Original slide 

 

No object selected 

The slide and all the objects are 
edited. The entire slice of the range 
(with the parts of objects enclosed in 
it) is cut away. Thus, the slide 
duration is reduced by the duration of 
the range. 

If an object spans on both sides of 
the range, its remaining parts are 
joined. (Shape 1). 

Shape 4 is deleted, because it is 
completely inside the range. 

When some objects are selected, the command behaves differently, as shown in the following 
example: 

 

Original slide 

There are two identical sets of 
objects (1-6; 7-12). 

Only one of the two sets is selected 
to show the difference. 
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At least one object selected 

Only selected objects are edited. 
The slide itself and unselected 
objects (7-12) aren’t affected at all. 

For the selected objects only: The 
range is folded up and removed. 
Any object parts that lie in the range 
are deleted (Shape 3 & 5). Shape 4 
is deleted, because it is completely 
inside the range. 

Objects/parts that follow the range 
are shifted to the left by the duration 
of the range (Shape 1, 2 & 3). 

If the selected object spans on both 
sides of the range, its remaining 
parts are joined (Shape 1). 

Copying Ranges 

Click the Copy Range button  to copy parts of objects that fall inside the range and put 
them on the clipboard. 

• If there is no selected object, the command checks all the objects in the slide. 

• If there is at least one selected object, the command checks only these selected 
objects. 

• If an object doesn’t have any part inside the range, it isn’t copied. 

The following figure illustrates these conditions: 

No object selected 

 

Some objects selected 
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All the objects’ paths falling inside the range are 
pasted at the Playhead position. 

 

Only parts of selected objects falling inside the range 
are pasted at the Playhead position. 

Note: The lower figures show fresh slides into which the clipboard content is pasted. Just 
imagine that a slice is taken out of the original slide, and placed at the Playhead position in 
the current or another slide. 

Deleting Ranges 

The Delete Range button  works just like the Cut Range button, except for one difference: 
While the former is used to delete the content inside the range, the latter “cuts” the content 
from the range and places it on the clipboard, then you can paste it where you want. 

In short, deleting stands for removing while cutting stands for reallocating.  

Note: You can also press CTRL+DELETE to delete a range. 

Cropping to Ranges 

The Crop to Range command  simply deletes everything outside the range. 

 

Original slide 
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No object selected 

Only the content falling inside the 
range is retained while the rest is 
deleted. Thus, the slide duration is 
reduced to the duration of the range. 

If an object doesn’t have any part 
inside the range, it is dropped. 
(Shape 2 & 6). 

When there are some selected objects, the Crop to Range command behaves differently, as 
shown in the following example: 

 

Original slide 

There are two identical sets of 
objects (1-6; 7-12). 

Only one of the two sets is 
selected to show the difference. 
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At least one object selected 

Only selected objects are edited. 
The slide itself and unselected 
objects (7-12) aren’t affected at 
all. 

The parts of the selected objects 
that lie inside the range are 
retained. 

If the selected object doesn’t 
have any part inside the range, it 
is deleted entirely from the slide. 
(Shape 2 & 6). 

Freezing the Frame 

Sometimes, a video contains a significant scene, which lasts only for a few seconds. The 
scene is over before the audience has enough time to absorb the important information. If this 
were a live lecture, you would pause the video and explain various parts of the frozen scene 
to your audience. However, that is impossible in a self-running video.  

This is where the freeze-frame control comes in handy. It allows you to pause a video for a 
certain duration. You can extend this pause as long as you want and add a commentary track 
or annotations to analyze the frozen video frame. 

Freeze-frame also works on audio objects. Normally you would only apply this control to a 
significant audio track that needs to be synchronized with the visual part of the presentation. 
A typical example is to re-sync a stand-alone commentary track with the rest of the slide by 
holding it off for a few seconds. 

Inserting Freeze-Frames 

To insert a freeze-frame, do the following: 

1. Select one or more audio/video tracks.  

2. Place the Playhead where you want to pause the track.  

3. In the Timeline pane, click the Insert Time button .  

4. In the dialog that appears, specify the duration of the control and click OK to finish. 
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A yellow diamond and a yellow bar will get superimposed on the time bar of the audio/video 
object. The yellow diamond specifies the point where the track pauses. Meanwhile, the yellow 
bar represents the pause you’ve inserted into the audio/video object.  

 

Note: 

• If you have defined the freeze-frame duration in the fourth step, the yellow bar is 
adjusted to this duration. However, the usual practice is to drag the diamond and the 
right-side edge of the yellow bar to change the start time and duration of the control.  

• Each freeze-frame extends the host track by its duration. In other words, if you insert 
an n-second pause in an audio/video track, its total duration will be increased by n 
seconds. 

• You can insert any number of pauses in any selected track. The only condition is that 
two pauses cannot overlap. 

• Freeze-frame also works on other types of objects. Basically, it inserts an interval of 
time into the selected object at the position of the Playhead. For example, if the 
duration of a shape is 3 seconds (3000 ms) and you insert 2 seconds (2000 ms) into 
its duration, then the total duration of the shape will be 5 seconds (5000 ms). 

• If there is no selected object in a slide, the control will insert an interval of silence into 
the entire slide and all the objects that appear at the Playhead position. Other objects 
that don’t intersect with the Playhead will not be affected at all. 

Removing Freeze-Frames 

To remove a freeze-frame from the host track, in the timeline, click the yellow bar and drag it 
downward till it turns gray, then release the mouse button. Alternatively, drag the right-side 
edge of the yellow bar toward the diamond till the yellow bar disappears. After that, the duration 
of the host track will be reduced by the duration of the yellow bar. 

Splitting and Joining 

Splitting Audio and Videos 

Sometimes, it’s necessary to split one video into several parts, for example, to save each of 
them as a single file and use for different purposes. In that case, just select the audio/video 

object and click the Split Audio/Video Objects button  in the Timeline pane to split the 
object at the Playhead position. 
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• The timeline shows the latter part as a new object, but still place it in the same object 
line with the other one. If you want to move the latter part to a new object line, right-
click it > Move Up/Down into a New Line. 

• The split parts are treated as new project-level resources (which appear in the 
Resources pane), and can be further used in any slide within the project. 

• In case of audio objects, each split part is shown as a separate  icon on the Canvas. 
However, all these icons are stacked together, so you can only distinguish between 
them when you drag them apart. 

Joining Audio and Videos 

To join multiple audio or video objects, click the Join Audio/Video Objects button  in the 
Timeline pane. You can join an audio object with other audio objects; and a video object with 
other video objects, but cannot join an audio object with a video object. 

When you join audio/video, all selected audio/video objects will merge together based on 
ascending order of their start times. It means that the object with smaller start time will play 
first in the combined object. A red mark appears showing where the objects join. 

Some cases you may encounter: 

• If audio/video objects have the same start time, ActivePresenter will sort them by their 
z-orders in ascending order. The object with a lower stack order will appear prior to the 
one with a greater stack order.  

• If audio/video objects don’t have identical properties such as width, height, or 
resolution, the combined object will use all the properties of the first object that plays. 
In other words, the output object will apply all the properties of the object having the 
smallest start time. 

Changing Playback Speed 

Changing the speed of a video or an audio can be useful in many different situations. For 
example, you are creating a tutorial showing how to export videos in ActivePresenter. The wait 
time for the exporting process to complete should be speeded up to shorten the duration of 
your tutorial. 

In that case, you can change the playback speed to make that part of the video run faster. 
That way, you will save the duration and the file size of your video and provide better user 
experience. You can also use this command to slow down your video, thus making it look 
professional like the slow-motion scene on TV. 

The command is only active when you select an entire audio/video object or just a part of it. 

In the Timeline pane, click the Change Playback Speed button  and the following dialog 
appears: 
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The input is a relative value in range 10-1000%. ActivePresenter will scale the current speed 
of the selected range using this value. In case you want to quickly reset to the original speed 
of the selected range, select Reset to original speed. 

Adjusting Volume 

If a slide has multiple concurrent audio tracks, you will have to ensure that only one of those 
tracks is dominant at a time, and the other tracks are either muted or with lowered volume. 
This balance keeps changing. In other parts of the slide, you may have to give dominance to 
other tracks. This is where the adjust volume control in the Timeline pane comes in handy. 

You can adjust the volume of an entire audio or just a part of it. Just select the audio 

object/range and click the Adjust Volume button . This opens a dialog containing a relative 
volume scale with a default value of 100% (the original volume). Use this scale to adjust the 
volume from 0 (mute) to 500% (original volume x 5). You can also select the Mute check box 
to quickly silence the track. 

 

Note:  

• When you adjust the volume of a range, the start and end points of the range are 
marked with red vertical marker lines. These markers cannot be moved within the time 
bar because they actually denote the range in which the volume is altered. 

• When you adjust the volume, the original track isn’t affected at all. You can bring back 
the original volume at any time. Just select an object/range and click the arrow next to 
the Adjust Volume button > Restore Original Volume. 

• If this control is used to mute a track, it doesn’t affect the original duration of the track, 
because unlike the freeze-frame control, this control doesn’t insert an additional period 
of silence. 
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Advanced Audio Effects 

Advanced audio effects let you improve your audio quality in general and audio recording 

quality in particular. Advanced audio effects, including audio fade in , audio fade out , 

audio noise reduction , and audio normalization , are accessible from the Timeline pane. 

Audio Fade In/Out 

When you add an audio to a slide, you may often end up with a sudden start or end that can 
be rough on the ears. Audio fade in and audio fade out come in handy to smooth the beginning 
and end of an audio track. Fade in (1) begins with silence and gradually becomes louder until 
full volume while fade out (2) makes an audio progressively softer until it can no longer be 
heard.                                                                                                                      

 

You can apply fade in and fade out effects several times to strengthen the fade. Do the 
following to apply audio fade in or fade out to an audio: 

1. Specify the audio range you want to apply the effect. 

2. In the Timeline pane, click Audio Fade In  or Audio Fade Out . Apply the effects 
several times if needed. 

3. To remove the effect, select the faded range and click the arrow next to the Adjust 
Volume button > Restore Original Volume. 

Audio Noise Reduction 

Your recordings often have some background noise, regardless of the microphone quality. 
Audio noise reduction can reduce constant background noise such as tape hiss, electric fans 
or hums. This effect doesn't work well with inconstant noise like talking or music and is often 
best done by trial and error. You may have to try the effect several times until getting the best 
result. 

To apply audio noise reduction, do the following: 

Step 1. Get a noise profile.  

1. Specify the range that contains only background noise.  

2. In the Timeline pane, click the arrow next to the Audio Noise Reduction button  > 
Get Noise Profile.  

Step 2. Reduce noise. After getting a noise profile, you can apply noise reduction to a certain 
range in an audio track or to the entire track. You can even apply the effect to multiple tracks 
simultaneously. 

1. Specify the ranges or the audio tracks you want to apply the effect.  

2. In the Timeline pane, click the Audio Noise Reduction button . A dialog appears 
offering necessary controls to reduce noise.  
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o Noise reduction (dB): Control the amount of volume reduction (0 - 48 dB) applied 
to the identified noise. Higher values reduce higher amount of volume reduction, 
making the noise quieter, but can distort the audio track. Keep this control as low 
as possible. 

o Sensitivity: Control how much of the audio will be considered noise, on a scale 
from 0 (off) to 24 (maximum). Greater sensitivity will remove more noise but can 
damage the track. Keep this control as low as possible. 

o Frequency smoothing (bands): Spread the noise reduction into the specified 
number of neighboring bands. Smoothing can make the desired audio less clear, 
so set the value to 0 if your desired signal is strong and of wide frequency range 
and the noise is low. 

Step 3. Click OK to apply the effect to the selected audio ranges/objects. 

Step 4. If the effect doesn’t work as you expect, click Restore Defaults and try the effect 
again with different settings.  
Tip: 

• The noise profile you got will be stored in the application. It will be lost if you close the 
application or be replaced by another noise profile when you get a noise profile again. 
Therefore, if there are different types of noise in different positions in the audio track, 
you should repeat the following process several times. Pick the profile for the first type 
of noise, reduce the noise for it, then pick the next type and reduce that until you get 
your desired result. 

• When getting a noise profile, you shouldn’t choose a very short range because a longer 
selection is better to get a more accurate picture of the noise. A selection of 2 - 4 
seconds of only noise is recommended. You must select a minimum 2048 samples, or 
about 0.05 seconds at 44100 Hz sample rate. 

• Sometimes a recording has no noise sample available because there is no part that 
contains only background noise. In that case, you can create a recording made in 
identical conditions that contain silence only, then use a noise sample from that to 
reduce noise from the target recording. 

Audio Normalization 

Audio normalization applies a certain amount of gain to an audio to bring the amplitude to a 
target level (the norm). This is useful when you have a group of audio objects at different 
volumes and want them to have a consistent volume level. This is also helpful when you 
cannot speak at the same volume level in a recording session. 

In ActivePresenter, you can normalize every audio in your project, including narrations, 
recorded system audio, and imported audio, for consistent volume across slides. You can 
apply the effect to the entire object or just a part of it, or to multiple objects at the same time. 
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Do the following: 

1. Select one or more audio objects/ranges. 

2. In the Timeline pane, click the Audio Normalization button . This opens the 
following dialog. Adjust the settings and click OK to normalize the selected track.  

 

o Remove DC offset: DC offset is an offsetting of a signal from zero. The problem 
can be seen from the waveform as it appears above or below the 0.0 horizontal 
line. DC offset is mostly a hardware problem that can cause clicks, distortion, or 
loss of audio volume, which can limit the possible loudness. Thus, removing DC 
offset is required when normalizing audio as it centers the waveform on the 0.0 
amplitude level. Note that if you are sure your audio has no offset, you should clear 
this option to speed up the normalization. 

o Normalize maximum amplitude to (peak normalization): Peak normalization 
brings the highest peak to the norm. A level of -1 dB (the initial default setting) is 
just below the maximum amplitude (0 dB) possible without clipping, but gives a 
little headroom for effects and distortion-free playback on all equipment. For this 
option, enter zero or a negative value for the maximum amplitude you would like 
the selected track to have. A more negative value means you normalize the 
selected track to lower amplitudes.  

o Normalize stereo channels independently: Normalization can work on the left 
and right channels of a stereo track as a pair or independently. When you select 
this option, normalization adjusts the amplitude of the channels separately to the 
same peak level. This is useful for correcting stereo imbalances. Otherwise, when 
you don’t select this option, normalization adjusts the level of both channels by the 
same amount, which is practical if your audio is already balanced. 

If you want to discard all changes, click Restore Defaults to go back to the original settings. 

Video Blur Effects 

Blur effect is used to hide sensitive information such as identity or private information. You 
can apply blur effects to a recorded or imported video to blur both moving and static objects.  

Applying Blur Effects 

To apply a blur effect, select a video object and do the following: 

1. In the timeline, specify where you want the effect to start. 

2. Click the Insert Blur Area button . In the dialog that appears, specify the effect 
duration and click OK. You can change the duration later, so don’t worry much about 
the choice you make at this moment.  



ActivePresenter User Manual  Version 7.5 

Audio and Videos > Video Blur Effects 147 

 

3. On the Canvas, change the size and position of the blur area so that it covers what 
you want to hide. You can drag the resizing handles or use the ARROW keys on your 
keyboard.  

 

4. Click the Properties pane > Media > Blur Effect to make further adjustments to the 
blur area. Later, if you want to change these properties, select the blur area on the 
Canvas or the blur time bar in the timeline to open the section. 

o Blurriness: Specify the amount of blur. The higher the value, the more the blur. 

o Blur Orientation: Specify the orientation of the blur (horizontal and vertical, 
horizontal, or vertical). 

o Mask Type: Specify the shape of the blur area (rectangle or ellipse). 

5. Change the effect duration by lengthening or shortening the blur time bar in the 
timeline. You can also drag the blur time bar to another position to change the start 
time of the effect.  

 

Blurring Moving Objects 

These above steps are enough if the area you want to blur maintains the same size and 
position. If the target area is moving, you need to do further steps to cover it precisely.  

Blur effect uses keyframes to mark specific areas in the video. The size and position of the 
blur area at any timestamp are interpolated from the values of the nearest keyframes on the 
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left and right of the timestamp. The more keyframes you insert, the more exactly the blur area 
covers the moving object. 

 

To add more keyframes, do the following: 

1. In the timeline, select the blur time bar. This enables you to change the blur area on 
the Canvas. 

2. Seek the Playhead along the timeline, then change size and/or position of the blur area 
on the Canvas. ActivePresenter will automatically insert a new keyframe each time you 
make changes. You can also add new keyframes by clicking the Add/Remove 

Keyframe button  in the Timeline pane, then edit the blur area on the Canvas. 

3. From the position of the Playhead, to navigate between keyframes, click the Go to 

Next Keyframe button  or the Go to Previous Keyframe button . 

4. To remove a keyframe you don’t want, drag it downward until it grays out and release 
the mouse button. Alternatively, place the Playhead at the keyframe > Add/Remove 

Keyframe . 

Removing Blur Effects 

To remove the blur effect, in the timeline, drag the blur time bar downward until it grays out 
and release the mouse button. Note that if you select the blur area on the Canvas and try to 
delete it by pressing DELETE, you will end up deleting the video. 

Video Green Screen Effects 

Green screen, technically known as chroma-key, is the technique of masking a video by keying 
out a background of a consistent color, so you can put one video on top of another. You often 
see this technique in movie stunts or in weather forecast where a presenter stands in front of 
a moving weather map. 

Basically, green screen works as your tool chooses a specific color and makes it transparent 
- all pixels having that color become transparent. Although it’s called green screen, you don’t 
have to use a green screen all the time. In fact, any solid color can be used theoretically, but 
green is the most commonly used because it provides a good contrast and luminescence and 
rarely occurs on human body. 

To apply a green screen effect, do the following: 
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1. Select a video object. 

2. Click the Properties pane > Media > Green Screen Effect. 

3. Specify a color you want to key out.  

4. Move the Tolerance slider to adjust the range of color to key out. Higher values key 
out a wider range of color near the key color. 

5. If you don’t satisfy with the result, click the Reset Color button to discard all changes. 

Picture-In-Picture Effects 

The picture-in-picture effect (also called video overlay) lets you place a video clip in a small 
frame on top of another so that they play at the same time. You often see this effect in 
instructional videos where webcam videos are placed at the corner of the tutorial ones. 

 

ActivePresenter allows you to use picture-in-picture effect in video editing. Do the following: 

1. Insert the picture-in-picture (PIP) video (the smaller video clip placed on top of 
another) into a slide. 
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2. Resize and reposition the video and change its timing. You can also add animation 
effects to the video to make it more engaging. 

3. Optionally, create a zoom-n-pan effect to zoom in the PIP video. That way, audience 
can focus on the PIP video instead of the entire screen. 

Note:  

• ActivePresenter enables you to record screen and webcam at the same time. What 
you get is a slide that displays both your screencast and webcam as two separate 
videos. The webcam video is smaller and placed at the bottom-right corner of the 
screencast, making a PIP effect. 

• Alternatively, you can record your webcam separately and insert the webcam video 
into a slide. 

• It’s practical to combine the video overlay effect with the green screen effect. Use the 
latter to key out the background of the superimposed video to integrate two videos. 

Cursor Effects in Recorded Video 

When you record a screencast, you can record the mouse cursor and edit the cursor effects 
of the recorded video after that. To enable this feature, select the two options Record Mouse 
Cursor and Make Cursor Editable for Full Motion Recording in the Cursor tab of the 
Recording Settings dialog.  

To change the cursor effects of a recorded video, select the video and click the Properties 
pane > Media > Cursor Effects. The cursor effects have the following options: 

• Render Cursor: Display the cursor, highlight effect, click effects, and play the click 
sounds when playing the video. If you don’t select this option, the cursor will not appear 
in the recorded video. 

• Cursor Highlight: Highlight the cursor. 

o Type: Type of the highlight effect (none, circle, square). 

o Size: Size of the highlight effect. It is the radius of the circle in the circle highlight 
or half of the width of the square in the square highlight. 

o Color: Color of the highlight. 

o Opacity: Transparency of the highlight. 

• Left-Click/Right-Click/Left Double-Click Effects: Play a sound and render an 
animation when the mouse is left clicked, right clicked, or left double-clicked.  

o Click Sound: The sound which is played when a mouse button is pressed. 

o Click Effect: The animation effect which is rendered when a mouse button is 
pressed (none, circle, concentric circles, square). 

o Size, Color, Opacity: The same as those of the cursor highlight. 

Background Music  

ActivePresenter makes background music possible. Background music plays across slides in 
the background of the slide show. You can insert audio from your computer or record a track 
and make it the background music of your project. 
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To set an audio track as background music, do the following: 

1. Right-click an audio object > Play over Multiple Slides > Top/Bottom Layer to make 
the background music play continuously throughout all. Both the options create the 
same effect when you don’t show the player controls for the audio. However, the layer 
you place the audio object affects the stack order of objects in a slide. 

2. Click the Properties pane > Media > Audio > Playback Options > Loop to make the 
track replay automatically when it finishes. After that, you can drag the end point of the 
audio time bar to the duration you want. You can also right-click the audio time bar > 
Play to the End of Slide to make the audio duration equal the slide duration.  

 

Regarding HTML5 output, consider two other playback options in the Properties pane > 
Media > Audio > Playback Options: 

• Background Music: Make the track continue playing when the presentation is 
paused. That way, in an interactive presentation, while the presentation pauses to wait 
for user input, background music still plays. 

• Autoplay: Make the audio play automatically when the slide loads. 
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Interaction objects are designed to respond to user input in a predefined manner. Users can 
interact with them using keyboards, mouses, or other input devices. Interaction objects not 
only change the course of the presentation based on user input, but also keep track of user 
activities (for example, assess user performance in a test).  

Interaction objects are listed as follows: 

Object Icon Usage 

Mouse Click 

 

Respond when users click in a predefined area. Use of 
modifier keys (ALT, CTRL, and SHIFT) is also allowed.  

Key Stroke 

 

Respond when users press an individual key on the keyboard 
or a hotkey (such as CTRL+SHIFT+P). 

Text Box 

 

Respond when users enter specific text (string). 

Drop Area  

 

Respond when users drop a drag source on it. 

Button 

 

Respond when users click it. 

Check Box 

 

Respond when users click it. 

Radio Button 

 

Respond when users click it. 

Animated Timer 

 

Count up elapsed time or count down remaining time in a 
running presentation. 

Questions  There are nine types of questions, namely true/false, 
multiple choice, multiple response, essay, fill in blank, fill 
in multiple blanks, sequence, drag-n-drop, and rating 
scale. 

When you insert a question, the question and answer options 
appear on screen, and users are expected to respond within a 
predefined time. ActivePresenter can be programmed to take 
different actions depending on whether the response is correct 
or incorrect; or if users fail to respond within the time limit. 
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Mouse Click  

Mouse clicks are interaction objects placed at areas in a slide where users must click to trigger 
the next action. These objects are often used in software simulations to teach the use of 
applications. For example, place a mouse click object on buttons or menus where users must 
click to perform a certain task in the application. When you record software simulations, 
ActivePresenter inserts mouse clicks automatically wherever and whenever you make a click. 

Mouse clicks use click events to trigger actions, just like buttons, but they are designed to 
assess user knowledge of the target application. Mouse clicks validate mouse actions as 
correct and incorrect and can give users points for correct actions. 

Inserting Mouse Clicks 

To insert a mouse click, click the Interactions tab > Mouse Click . Alternatively, click the 

Home tab > Interactions  > Mouse Click . 

By default, a mouse click consists of three separate elements: (1) a target area, (2) a Correct 
message, and (3) an Incorrect message.  

 

When the interactive presentation is played, the mouse click displays only the target area and 
waits for the user to click anywhere on the slide. You can prompt the user to click on a specific 
area by inserting a shape with some guidance. If the user action is correct, the Correct 
message appears. If not, the Incorrect message appears. For example, if the predefined value 
is CTRL+Left click, but the user clicks on the target area without holding down CTRL, he is 
doing incorrectly. 

Note:  

• You can add Timeout and Hint messages by selecting the target area > Interactions 
tab > Message. To remove any message you don’t want, select the message and 
press DELETE. 

• For score and reporting settings, see Score & Reporting. 

• To add event actions, click the Properties pane > Interactivity > Events - Actions. 
By default, mouse clicks have four events, namely On Click, On Correct, On Incorrect, 
and On Timeout. You can add two other events, namely On Rollover and On Rollout. 
These events are helpful when you want to create a hover effect for the mouse click. 

• You can make the target area invisible so that users cannot see the correct click area. 
To do that, set the outline of the target area to No Line (Properties pane > Style & 
Effects > Line). However, this is not recommended. Instead, you should use the Show 
In Mode property of objects. You can show the click area in some modes (for example, 
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Demonstration and Tutorial) but hide it in other modes (for example, Practice and 
Test). 

Setting Correct Values 

Mouse clicks accept left-click, right-click, and left double-click with or without modifier keys 
(SHIFT, CTRL, and ALT).  

To define a correct action, do the following: 

1. Select the target area element. 

2. Click the Properties pane > Interactivity > General > List of Correct Values > Add 
Value. 

3. Place the cursor over the Correct Value text box and click the mouse button with or 
without the modifier keys. 

4. Click the Remove button  to remove a value you don’t want. 

 

Note: It’s great to let users know there is a clickable area on screen. For this reason, change 
the cursor for the target area to a hand cursor (Properties pane > Interactivity > General > 
Cursor). That way, the mouse pointer will turn to a hand cursor when it’s over the correct area 
in the output. 

Key Stroke 

In software simulations, you can use key stroke objects to simulate keyboard actions that 
interact with the target software. Key strokes respond when users press a key or a combination 
of keys on their keyboards. When you record software simulations, ActivePresenter inserts 
key strokes automatically whenever you press a hotkey. 

Inserting Key Strokes 

To insert a key stroke, click the Interactions tab > Key Stroke . Alternatively, click the 

Home tab > Interactions  > Key Stroke . 

By default, a key stroke consists of three separate elements: (1) a target area, (2) a Correct 
message, and (3) an Incorrect message. 
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When the interactive presentation is played, initially the key stroke displays nothing. It just 
waits for the user to enter a hotkey (such as CTRL+SHIFT+P), and ignores any text string. If 
the entered hotkey matches the reference, the Correct message appears. If not, the Incorrect 
message appears. For example, if the predefined value is CTRL+SHIFT+P, but the user 
presses CTRL+P without holding down SHIFT, he is doing incorrectly.  

Note: 

• You can add Timeout and Hint messages by selecting the target area > Interactions 
tab > Message. To remove any message you don’t want, select the message and 
press DELETE. 

• For score and reporting settings, see Score & Reporting. 

• To add event actions, click the Properties pane > Interactivity > Events - Actions. 
By default, key strokes have three events, namely On Correct, On Incorrect, and On 
Timeout. You can add three other events, namely On Key Press (occurs when each 
key or combination of keys is pressed), On Rollover, and On Rollout. 

Setting Correct Values 

Key strokes accept all keys or combination of keys on the keyboard except the WINDOWS 
key. Be sure to fully test your key stroke in your published output to avoid any unexpected 
behavior. Don’t use keys or key combinations that are common in browsers (CTRL+F, ALT+D, 
etc.). 

To define a correct action, do the following: 

1. Select the target area element. 

2. Click the Properties pane > Interactivity > General > List of Correct Values > Add 
Value button. 

3. Click inside the Correct Value text box and press a key with or without the modifier 
keys (SHIFT, CTRL, and ALT). 

4. Click the Remove button  to remove a value you don’t want. 
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Text Box 

Text boxes are interactive text fields into which users can enter text. Text boxes provide a 
great way to test user knowledge and collect information from users. When you record 
software simulations, ActivePresenter inserts text boxes automatically whenever you enter 
a text string. 

Inserting Text Boxes 

To insert a text box, click the Interactions tab > Text Box . Alternatively, click the Home 

tab > Interactions  > Text Box . 

By default, a text box consists of three separate elements: (1) a target area, (2) a Correct 
message, and (3) an Incorrect message. 

  

When the interactive presentation is played, the text box object displays only the target area 
and waits for the user to enter text strings. If the entered text matches the correct value, the 
Correct message appears, otherwise the Incorrect message appears. 

Note: 

• When users enter a text string, it appears in real time in the target area. If the entered 
text exceeds the area, the text is shifted so that the insertion point is always visible. 
You should resize the target area to appropriate size so that all text can be visible. 

• By default, text boxes use the graded mode which validates user input as correct or 
incorrect. To disable validation, set the mode to survey (Properties pane > 
Interactivity > Score & Reporting > Mode). This may be useful when you want to 
collect user name or other information.  

• There are two ways to submit the entered text: Submit key (Press Key) and Auto. 
(The survey mode only accepts the Submit key.) The former validates the entered text 
when users press the Submit key. Meanwhile, the latter validates the entered text 
whenever users press any key. As long as the entered text is a partial match for the 
correct value, the presentation will wait for users to input more text. The moment the 
last entered character is found to be different, it will be deemed as incorrect. 

• You can add Timeout and Hint messages by selecting the target area > Interactions 
tab > Message. To remove any message you don’t want, select the message and 
press DELETE. 

• To add event actions, click the Properties pane > Interactivity > Events - Actions. 
By default, text boxes have three events, namely On Correct, On Incorrect, and On 
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Timeout. You can add four other events, namely On Text Enter (occurs when an 
entered value is submitted), On Incomplete, On Rollover, and On Rollout. 

Setting Correct Values 

To define a correct value, do the following: 

1. Select the target area element. 

2. Click the Properties pane > Interactivity > General > List of Correct Values > Add 
Value. 

3. Type a text string in the Correct Value text box. 

4. Click the Remove button  to remove a value you don’t want. 

 

Drop Area 

Drag-n-drop interaction allows you to drag an object and drop it onto another. The interaction 
includes a draggable object and a place or an object to drop it. ActivePresenter calls them a 
drag source and a drop target, respectively. 

A drop area is a special drop target that assesses, scores and keeps track of user response 
instantly when they drop a drag source onto it. Each drop area can accept multiple drag 
sources, many of which can be set as correct values. However, a drop area holds only one 
drop source at the same time. When you drop another accepted drag source onto it, the drag 
source will replace the previous one while the previous one is sent back to its original place. 
Meanwhile, a normal drop target can hold multiple accepted drag sources at once. 

Inserting Drop Areas 

To insert a drop area, click the Interactions tab > Drop Area . Alternatively, click the Home 

tab > Interactions  > Drop Area .  

By default, a drop area consists of four separate elements: (1) a drop area with light red 
marker, (2) a drag source with light green marker, (3) a Correct message, and (4) an Incorrect 
message. There is also an orange drag-n-drop connector that connects the drag source to the 
drop area. This connector indicates that dropping the drag source to the drop area is a correct 
action, in other words, it demonstrates a correct drag-n-drop interaction. Note that all these 
markers and connector don’t appear in any output but the editor. 
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When the interactive presentation is played, the user can drag any drag source from its original 
place. When he drops a drag source onto a drop area, four cases may happen. (1) If the drag 
source is rejected, it will be sent back to its original place. (2) If it’s accepted but not correct, it 
will lie on the drop area while the Incorrect message appears. (3) If it’s accepted and correct, 
it will lie on the drop area while the Correct message appears. (4) If the user drops another 
accepted drag source onto the drop area, the current drag source will replace the previous 
one while the previous one is sent back to its original place. At the same time, the Correct or 
Incorrect message will appear depending on whether the current drag source is correct or not. 

Note: 

• You can add Timeout and Hint messages by selecting the target area > Interactions 
tab > Message. To remove any message you don’t want, select the message and 
press DELETE. 

• For score and reporting settings, see Score & Reporting. 

• To add event actions, click the Properties pane > Interactivity > Events - Actions. 
By default, drop areas have three events, namely On Correct, On Incorrect, and On 
Timeout. You can add six other events, namely On Accept, On Reject, On Drag Enter, 
On Drag Leave, On Rollover, and On Rollout. 

• You can make the drop area invisible by setting its outline to No Line (Properties pane 
> Style & Effects > Line). However, this is not recommended. Instead, you should 
use the Show In Mode property of objects. You can show the drop area in some 
modes (for example, Demonstration and Tutorial) but hide it in other modes (for 
example, Practice and Test). 

• To hide drag-n-drop markers and connector, click the View tab > Drag-n-Drop. 

Setting Correct Values 

A drop area can accept multiple drag sources, many of which can be set as correct values. To 
define a correct drag source, do the following: 

1. Select the drop area. 

2. Click the Properties pane > Interactivity > Drag-n-Drop > Accept List. 

3. In the dialog that appears, define accepted drag sources by selecting check boxes in 
the Accept column. Select Accept All to make the drop area accept all the drag 
sources in a slide.  
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4. Define correct drag sources by selecting check boxes in the Correct column. Note that 
an accepted drag source may not be a correct one. 

5. Click OK to save changes.  

Another way to set correct drag sources is to use the drag-n-drop connector. Just click the 
marker in the middle of a drag source and drag the mouse to the drop area. This creates a 
drag-n-drop connector that connects the two items.  

To remove a drag source as a correct value, you can click the connector and press DELETE 
or right-click it > Delete. You can also get the same result by using the Accept List dialog. 

Setting Drop Area Properties 

To set up properties for a drop area, click the Properties pane > Interactivity > Drag-n-Drop.  

 

• Effect: Specify the effect that appears when users drag any drag source over the drop 
area. 

• Snap Behavior: Specify properties of a drag source after it is dropped onto the drop 
area.  

o Size (%): Resize the drag source.  

o Opacity: Change the opacity for the drag source.  

o Position: Define the position of the drag source. 
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▪ Absolute: Keep the drag source at the same position as where users drop it.  

▪ Anchor: Snap the drag source to an anchor point of the drop area. Choose 
one from nine anchor points in the Direction list. 

▪ Tile: Arrange the drag source so that it lies on the drop area without covering 
each other. Choose one from eight tiling directions in the Direction list. 

Converting Objects to Drag Sources 

You may want to convert objects in a slide, such as images and shapes, to drag sources so 
that you can drag and drop them onto drop areas (or drop targets). ActivePresenter allows 
you to convert multiple objects to drag sources at the same time.  

Do the following: 

1. Select an object. 

2. Click the Properties pane > Interactivity > Drag-n-Drop > Drag Source. 

 

3. Specify properties for a drag source. 

o Effect: Specify the effect that appears when users drag the drag source (none, 
zoom, or highlight).  

o Revert: Determine whether the drag source is sent back to its original place if it’s 
dropped outside the drop area. 

Button 

Interactive buttons allow you to do certain tasks when users click it. For example, clicking the 
Next button takes users to the next slide in the presentation.  

When you insert a button into a slide, it comes with four built-in states which control the look 
of the button when users hover, click, or otherwise interact with it. 

Inserting Buttons 

To insert a button, click the Interactions tab > Button . Alternatively, click the Home tab > 

Interactions  > Button .  
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A button appears on the Canvas with default text. Give it a descriptive name by clicking the 
default text and enter your text. You can modify the text attributes in the same way that you 
normally modify text captions.  

Note: 

• You can modify the look of a button in the same way that you normally modify a shape. 
Use commands and options in the Format tab or in the Properties pane > Style & 
Effects.  

• After modifying a button, you can set it as default style for all new buttons in the same 
project. To do that, right-click the button > Set as Default Button. In case you want 
the new default style to take effect to existing buttons in the same project, right-click a 
button > Apply to All Button Objects > Style. 

• Buttons don’t validate user input as correct or incorrect. When users click a button, 
actions registered with the On Click event are executed. 

• Buttons have no Report ID and score settings so they don’t appear in the report. 

Working with Button States 

Buttons include four built-in states, namely normal, hover, pressed, and disabled. These states 
are added to buttons by default, so you don’t need to use actions to trigger them. 

 

• Normal: This is the neutral state of a button. By default, it’s how a button looks when 
it first appears. 

• Hover: This is how a button looks when being hovered. 

• Pressed: This is how a button looks when being clicked. 

• Disabled: This is the state you use when you want to disable a button. A disabled 
button is visible but cannot respond to any user action. 

You can modify built-in states and create additional states if needed. For more details about 
states, see Using Object States. 

Making Buttons Work 

To add event actions, click the Properties pane > Interactivity > Events - Actions. Add 
events and actions as you wish. Buttons can respond to both mouse and touch events. 
Normally, you want to add an On Click event to create actions when users click the button. 
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Check Box and Radio Button  

ActivePresenter comes with a variety of ready-made check boxes and radio buttons to help 
you create interactions in your course.  

Inserting Check Boxes and Radio Buttons 

To insert a check box or a radio button, click the Interactions tab > Check Box  or Radio 

Button .  

Alternatively, click the Home tab > Interactions  > Check Box  or Radio Button . 

 

A check box/radio button appears on the Canvas with default text. Give it a descriptive name 
by clicking the default text and enter your text. You can modify the text attributes in the same 
way that you normally modify text captions.  

Formatting Check Boxes and Radio Buttons 

Once a check box or a radio button is in a slide, you can move, scale, or customize it as 
desired. Use commands and options in the Format tab or in the Properties pane > Style & 
Effects. 

In the Format tab, do the following: 

 

• Change styles: Use the drop-down gallery to select a ready-made style to customize 
check boxes/radio buttons. 

• Change colors: Initially, check boxes/radio buttons use their default styles in which 
object colors come from your theme colors. However, you can always use custom 
colors to design check boxes/radio buttons. 

o Fill: Define the background color of check boxes/radio buttons. 

o Border: Define the color and style of the border of check boxes/radio buttons. 
Choose Weight to change the border thickness. 

o Mark: Define the color of the check mark/radio dot when a check box/radio button 
is checked. 

You can set a certain check box/radio button as the default style so that the same attributes 
will be applied to all new check boxes/radio buttons in the same project. To do that, right-click 
a check box/radio button > Set as Default Check Box/Radio Button. 
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In case you want the new default style to take effect to existing check boxes/radio buttons in 
the same project, right-click a check box/radio button > Apply to All Check Box/Radio 
Button Objects > Style. 

Working with Check Box/Radio Button States 

Check boxes and radio buttons include eight built-in states. These states are added to them 
by default, so you don’t need to use actions to trigger the states. 

• Normal: This is the neutral state of a check box/radio button. By default, it’s how a 
check box/radio button looks when it first appears. 

• Hover: This is how a check box/radio button looks when being hovered. 

• Pressed: This is how a check box/radio button looks when being clicked. 

• Disabled: This is the state you use when you want to disable a check box/radio button. 
A disabled check box/radio button is visible but cannot respond to any user action. 

• Normal/hover/pressed/disabled checked: These are the states of the selected 
check box or radio button.  

You can modify built-in states and create additional states if needed. For more details about 
states, see Using Object States. 

Making Check Boxes and Radio Buttons Work 

To add event actions, click the Properties pane > Interactivity > Events - Actions. Add 
events and actions as you wish. Check boxes/radio buttons can respond to four events.  

• On Check: Occur when a check box/radio button is marked. 

• On Timeout: Occur when users don’t respond within the specified time. 

• On Rollover: Occur when the mouse enters the boundary of the check box/radio 
button. 

• On Rollout: Occur when the mouse exits the boundary of the check box/radio button. 

Animated Timer 

An animated timer counts up elapsed time or counts down remaining time in a running 
presentation. There are two types of animated timer: Timer and Progress. While a timer 
simply shows how much time has passed or left with a digital display, a progress bar gives a 
visual progression of time.  

You can trigger an action when a timer is completed or timed out. For example, when learners 
don’t provide an answer within a given time and the timer finishes the countdown, a message 
appears to tell them that there is no time left. 

Inserting Timers 

To insert a timer, click the Interactions tab > Animated Timer  > select either Timer or 

Progress. Alternatively, in the Home tab > Interactions  > Animated Timer . 
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To adjust a timer, click the Properties pane > Interactivity > Timer and do the following: 

 

• Format: Specify the time format of a timer (hh:mm:ss, hh:mm, mm:ss, or ss:ms). This 
option is only available for a timer, not a progress. 

• Countdown: Change a countup timer to a countdown one.  

• Match object duration: By default, the duration of a timer equals that of a timer object 
in the main timeline. To set a different duration, clear the check box and specify the 
duration as you wish. Note that if the timer object is initially hidden and the check box 
is selected, the timer duration is the same as the slide duration. 

• Start automatically: Make a timer start as soon as a timer object starts showing in the 
main timeline. 

• You can style a timer as a normal shape using the fill, line, or shadow properties. 

Adding Event Actions to Timers 

To make timers interactive, add event actions in the Properties pane > Events - Actions. 
The On Timer Complete event is available to trigger an action when a timer completes the 
countup or countdown. 

You can also handle timers using three actions:  

• Start Timer: Make the timer start counting, do nothing if it is running. If the timer has 
finished, the action restarts it. 

• Pause Timer: Pause the timer but keep the current value, do nothing if it is paused. 

• Stop Timer: Stop the timer and reset its value. 
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Questions  

Questions can be used to assess learner performance (graded mode) and collect learner 
feedback (survey mode). ActivePresenter allows you to insert nine different types of questions: 

• True/False 

• Multiple Choice 

• Multiple Response 

• Essay 

• Fill in Blank 

• Fill in Multiple Blanks 

• Sequence 

• Drag-n-Drop 

• Rating Scale 

For more details about questions, see Common Question Properties. 
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Common Question Properties 

To create a question, click the Interactions tab and click any of the question buttons. Then, a 
new question slide will appear on the Canvas. The next section will give you more details 
about the common component of a question slide.  

Components of a Question Slide 

A typical question slide in ActivePresenter is composed of three sections: question title, 
answer, and button.  

 

• Title (1): The title of a question. 

• Answer (2): The answer of the question. The number of answers depends on the type 
of questions you are creating. You can add more or delete answers of question.  

• Button (3): ActivePresenter 6 has four predefined button types which are Back, Clear, 
Skip, and Submit. ActivePresenter 7 only has Submit. However, you can insert more 
buttons and customize them, then set the Events - Actions for them regarding your 
purposes.  

To insert buttons, click the Interactions tab > Button , or click the Home tab > 

Interactions  > Button . 

Note: Feedback messages of questions are also added by default. However, to view and edit 

them, you have to click the View tab > Feedback Master .  
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A question comes with default events - actions that are ready to use. However, you can edit 
them to make them more advanced if you want. That can be done in the Events - Actions 
section of the Properties pane. More than that, you can use the Advanced Action feature to 
create and manage complex actions. To open this section, do one of the following: 

• Select the question > Interactions tab > Event . 

• Select the question > Properties pane > Interactivity > Events - Actions. 

After that, the Properties pane will show all the necessary tools and properties allowing you 
to edit and customize the events and actions of the question. 

Question Modes: Graded and Survey 

A question can be used for assessing learner performance (graded mode) and collecting user 
feedback (survey mode). You can change this setting for a question by selecting the question 
> Properties pane > Interactivity > Score & Reporting > Mode > Graded/Survey. 

The table below shows the differences between graded mode and survey mode. 

Mode Graded Survey 

User validation Correct/Incorrect/Incomplete Complete/Incomplete 

Score settings Yes No 

Purpose Assessment Information Gathering 

Events  On Correct 
On Incorrect 
On Incomplete 
On Timeout 

On Complete 
On Incomplete 
On Timeout 

Creating Quizzes 

Quizzes are critical elements of a test. They allow you to test or track performances of learners, 
collect information and opinions of users, and so much more.  

There are nine types of questions in ActivePresenter: true/false, multiple choice, multiple 
response, essay, fill in blank, fill in multiple blanks, sequence, drag-n-drop, and rating scale 
(likert).  

 

To create a question, click the Interactions tab and select the question you want to have. Or 

you can click the Home tab > Interactions  > select a question. After that, ActivePresenter 
will create a new slide containing that question.  
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True/False 

This type of question allows learners to select either true or false for an answer.  

To insert a true/false question, click the Interactions tab > True/False . Alternatively, click 

the Home tab > Interactions  > True/False . The question will appear on the Canvas as 
follows:  

 

Each question must have two answers (True and False), and you cannot remove or add more 
answers to it. However, you can let answers display in a different layout: Select answers > 
Size & Properties tab > Group Layout > set 2 as the Number of Column.  

To set the correct answer, double-click the radio button that corresponds to the correct answer 
choice.  You can change the answers to Yes and No if needed.  

Click the Properties pane > Interactivity > Scores & Reporting to select the question mode 
and set properties for it. 

Click the Properties pane > Interactivity > Events - Actions to have more setting for 
question events and actions. 

After creating and customizing the question, you can set it as a default question to use in the 
current project: Right-click the question > Set as Default True - False Question. 

Multiple Choice 

This type of question allows learners to select only one answer for a question.  

To insert a multiple choice question, click the Interactions tab > Multiple Choice  . 

Alternatively, click the Home tab > Interactions  > Multiple Choice  . The question will 
appear on the Canvas as follows:  
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You can change the question layout: Select answers > Size & Properties tab > Group 
Layout.  

You can add more answers to the question by selecting answers and clicking the green button: 

 

To delete an answer, select it and press the DELETE key on your keyboard. If you want to 
delete multiple answers, hold down CTRL while clicking them, then press DELETE. 

To set a correct answer for the question, double-click the radio button that corresponds to the 
correct answer choice. Remember that you can set only one answer as a correct answer for 
a multiple choice question, which means you can only select one button.  

Click the Properties pane > Interactivity > Scores & Reporting to select the question mode 
and set its properties. 

Click the Properties pane > Interactivity > Events - Actions to have more settings for 
question events and actions. 

After creating and customizing the question, you can set it as a default question to use in the 
current project: Right-click the question > Set as Default Multiple Choice Question. 
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Multiple Response 

This type of question allows learners to select multiple answers for a question.  

To insert a multiple response question, click the Interactions tab > Multiple Response . 

Alternatively, click the Home tab > Interactions  > Multiple Response . The question 
will appear on the Canvas as follows:  

 

You can change the question layout: Select answers > Size & Properties tab > Group 
Layout.   

You can add more answers to the question by selecting answers and clicking the green button: 

 

To delete an answer, select it and press the DELETE key on your keyboard. If you want to 
delete multiple answers, hold down CTRL while clicking them, then press DELETE. 

To set correct answers for the question, double-click the check boxes that correspond to the 
correct answer choices. Unlike a multiple choice question, you can set more than one correct 
answer for a multiple response question.  

Click the Properties pane > Interactivity > Scores & Reporting to select the question mode 
and set properties for it. 

Click the Properties pane > Interactivity > Events - Actions to have more settings for 
question events and actions. 
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After creating and customizing the question, you can set it as a default question to use in the 
current project: Right-click the question > Set as Default Multiple Response Question.  

Essay 

This type of question contains a multiple-line text box that allows learners to input text.  

To insert an essay question, click the Interactions tab > Essay  . Alternatively, click the 

Home tab > Interactions  > Essay . The question will appear on the Canvas as follows: 

 

Click the answer text box, and open the General section of the Properties pane to set the 
correct answer list for the question.  

Click the Properties pane > Interactivity > Scores & Reporting to select the question mode 
and set properties for it. 

Click the Properties pane > Interactivity > Events - Actions to have more settings for 
question events and actions. 

Fill in Blank 

This type of question contains a single-line text box that allows learners to input text.  

To insert a fill in blank question, click the Interactions tab > Fill in Blank . Alternatively, 

click the Home tab > Interactions  > Fill in Blank . The question will appear on the 
Canvas as follows:  



ActivePresenter User Manual  Version 7.5 

Creating Quizzes > Creating Quizzes 172 

 

Click the answer text box, and open the General section of the Properties pane to set the 
correct answer list for the question. To know more details about it, see General Section. 

Click the Properties pane > Interactivity > Scores & Reporting to select the question mode 
and set properties for it. 

Click the Properties pane > Interactivity > Events - Actions to have more settings for 
question events and actions. 

After creating and customizing the question, you can set it as a default question to use in the 
current project: Right-click the question > Set as Default Fill in Blank Question. 

Fill in Multiple Blanks 

This type of question contains some single-line text boxes that allow users to input text. It is 
often used in the test that requires learners to fill missing words in a paragraph.  

To insert a fill in multiple blanks question, click the Interactions tab > Fill in Multiple Blanks 

. Alternatively, click the Home tab > Interactions  > Fill in Multiple Blanks . The 
question will appear on the Canvas as follows: 
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You can change the question layout: Select answers > Size & Properties tab > Group 
Layout.  

Each question can have more than one answer. Each answer contains a label and a text box. 
You can add more answers to the question by selecting answers and clicking the green button: 

 

To delete an answer, select it and press the DELETE key on your keyboard. If you want to 
delete multiple answers, hold down CTRL while clicking them, then press DELETE. 

Click the answer text box, and open the General section of the Properties pane to set the 
correct answer list for it. 

Unlike a fill in blank question, a fill in multiple blanks question has more than one text box, you 
have to set the correct answer list for each of the text boxes separately.  

Click the Properties pane > Interactivity > Scores & Reporting to select the question mode 
and set properties for it. 

Click the Properties pane > Interactivity > Events - Actions to have more settings for 
question events and actions. 

After creating and customizing the question, you can set it as a default question to use in the 
current project: Right-click the question > Set as Default Fill in Multiple Blanks Question. 
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Sequence 

A sequence question contains at least two answers that require learners to arrange in the right 
order.  

To insert a sequence question, click the Interactions tab > Sequence . Alternatively, click 

the Home tab > Interactions  > Sequence . The question will appear on the Canvas as 
follows:  

 

You can add more answers to the question by selecting the answer section of the question 
and clicking the green button:  

 

Initially, each answer is a shapes with text inside. Click the shape and replace the text. All the 
normal shape’s properties apply to this type of shapes, which means you can customize them 
just like customizing a normal shape.  

The order of answers you set is the correct answer for the question. To change that order, 
click and drag shapes to desired positions. However, before dragging, make sure that the 
None mode is selected in the Group Layout section. Otherwise, you cannot change the shape 
position. 

To delete an answer, select it and press the DELETE key on your keyboard. If you want to 
delete multiple of them, hold down CTRL while clicking them, then press DELETE. 



ActivePresenter User Manual  Version 7.5 

Creating Quizzes > Creating Quizzes 175 

After creating and customizing the question, you can set it as a default question to use in the 
current project: Right-click the question > Set as Default Sequence Question.  

Drag-n-Drop 

Before creating a drag-n-drop question, you should take a look at drop area to understand 
what drag sources and drop targets are. You can also have some basic concepts about drag 
and drop to make the most out of a drag-n-drop question. 

A drag-n-drop question is a type of question that includes multiple drag sources and drop 
targets that require learners to match correctly.  

To insert a drag-n-drop question, click the Interactions tab > Drag-n-Drop . Alternatively, 

click the Home tab > Interactions  > Drag-n-Drop . The question will appear on the 
Canvas as follows:  

 

Each drag source and drop target is a shape with a clickable Image button  inside. You can 
click this button to quickly add images, or you can type text in the shape. All the normal shape’s 
properties apply to this type of shapes, which means you can customize them just like 
customizing any normal shape.  

To insert more drag sources and drop targets, select the drag sources and drop targets, and 
click the green button that appears:  
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By default, a question has two columns, one for drag sources, and the other for drop targets. 
But you can change its layout if needed: Select drag sources and drop targets > Size & 
Properties tab > Group Layout.  

To set correct drag source and drop target pairs for an answer, you have to match them by 
selecting the drag source, and dragging the marker that appears in the center of it to the 
desired drop target.  

You can change the drag source and drop target position by clicking and dragging them to the 
desired position. However, before doing that, make sure the None mode is selected in the 
Group Layout section of the Size & Properties tab. Otherwise, you cannot change the shape 
position.  

To delete a drag source or drop target, select it and press the DELETE key on your keyboard. 
If you want to delete multiple of them, hold down CTRL while clicking them, then press 
DELETE. 

After creating and customizing the question, you can set it as a default question to use in the 
current project: Right-click the question > Set as Default Drag-n-Drop Question.  

Note: A drop target in a drag-n-drop question should accept one drag source. In cases that 
you want to create a quiz containing a drop target that accepts multiple drag sources, you 
should use the drop area object.  

Rating Scale (Likert) 

This type of question contains one or more answers used for taking a survey from users, not 
for an assessment.  

To insert a rating scale question, click the Interactions tab > Rating Scale (Likert) . 

Alternatively, click the Home tab > Interactions  > Rating Scale (Likert) . The question 
will appear on the Canvas as follows:  
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You can add more columns to the question or delete them, which means adding or deleting 
radio buttons in each answer: Select answers > Size & Properties tab > Group Layout > 
change the value in the Number of Column spin box.  

Each answer has a label and multiple radio buttons. You can add more answers to the 
question by selecting answers and clicking the green button: 

 

To delete an answer, select it and press the DELETE key on your keyboard. If you want to 
delete multiple answers, hold down CTRL while clicking them, then press DELETE. 

Since this type of question is used to take a survey from users, it only has the survey mode. It 
doesn’t have the graded mode.  

Click the Properties pane > Interactivity > Events - Actions to have more settings for 
question events and actions. 

After creating and customizing the question, you can set it as a default question to use in the 
current project: Right-click the question > Set as Default Likert Question.  
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Randomizing Questions 

While designing quizzes, you often want to create different versions of the same quiz to avoid 
quiz predictability. ActivePresenter lets you do that using slide pools and random slides.  

A slide pool contains a group of slides that don’t appear directly in the output. You have to 
draw slides in a slide pool into the main slides list using random slides. In other words, random 
slides display slides that are randomly selected from a linked slide pool. You can choose to 
display and randomize all the slides in a pool or just a subset. 

If you want to reuse slides in a pool, just import that pool into a different project. 

Creating Slide Pools 

Use the Slide Pools pane to create and manage slide pools. To open this pane, click the View 
tab > Slide Pools. By default, ActivePresenter provides the Pool 1 pool without any slide. You 
can add slides to this pool or create new pools as you wish.  

 

To create a new slide pool, in the Slide Pools pane, do the following: 

1. Click Add New Pool .  

2. In the dialog that appears, enter a name for the new pool. Then, click OK to apply. 

 

 

To manage slide pools, you can: 

• Rename Pool : Rename the current pool.  

• Remove Pool : Remove the current pool and all the slides it contains. 

• View Information : View the number of slides in the current pool and the number of 
random slides linked to it. 

Adding Slides to Slide Pools 

There are two ways to add slides to a slide pool. First, create new slides in the Slide Pools 
pane. Second, move slides from the main slides list to the pane. In addition, you can move 
slides from a pool to another if you wish. 
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Adding New Slides in Slide Pools 

To add a new slide to a pool, just right-click the Slide Pools pane > New Slide. In fact, this is 
similar to creating new slides in your project. 

Moving Slides from Main Slides List to a Pool 

You can move slides from the main slides list to a pool. To do that, in the Slides pane, right-
click one or more slides > Move Slide To > select a pool. As the slides are moved to the pool, 
they no longer appear in the Slides pane. 

Moving Slides from a Pool to Another 

In the Slide Pools pane, select a pool. Then, right-click one or more slides > Move Slide To 
> select another pool. You can also copy slides between pools. 

Removing Slides from Slide Pools to Main Slides List 

In the Slide Pools pane, select a pool. Then, right-click one or more slides > Move Slide To 
> Slides. You can also copy slides from a pool and paste them in the Slides pane. 

Importing Slide Pools 

You can reuse slide pools across projects. Do the following: 

1. Click the Slide Pools pane > Import Pool . 

2. Select a project file (*.approj) that contains the slide pools you want to reuse. The 
following window appears having two panes. The Pools pane shows pools in the 
selected project. The Slides pane shows all the slides in each pool. To change the 
view mode, click the Small or Large button.  
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3. Select a pool to import.  

4. Select an import option:  

o Append Pools: Import a pool as a new pool and keep all previously created pools 
in the current project.  

o Replace All Existing Pools: Import a pool as a new pool and replace all previously 
created pools in the current project.  

5. Click OK to apply changes. 

Using Random Slides to Draw from Slide Pools 

You can draw slides from a pool into the Slides pane using random slides. Random slides 
display slides that are randomly selected from a pool to which they are linked. For example, a 
random slide is linked to a pool containing five slides. At run time, the random slide randomly 
displays one of the five slides in the pool, thus creating different versions of the same quiz. 

Compared with normal slides, random slides have some differences: 

• In the HTML5 output, random slides will be replaced by the slides in the pool to which 
they are linked. 

• You neither insert anything into random slides nor insert random slides into slide 
masters.  
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Inserting Random Slides 

To insert a random slide, click the Slide tab > Random Slide . This insert a random slide 
below the current slide. As can be seen, the random slide has gray background and is labeled 
“Random Slide”. It is linked to the first pool in your project, by default. 

 

If you no longer need a random slide, just remove it. Click it and press DELETE or right-click 
it > Delete. 

Drawing Slides from Slide Pools 

Slide pool contains a group of slides that don’t appear directly in the output. You have to draw 
slides in a slide pool into the Slides pane using random slides. You can choose to display and 
randomize all the slides in a pool or just a subset. For example, a pool has five slides. You 
can use five random slides to display all the five slides randomly. Otherwise, you can use, for 
example, three random slides to display just three slides randomly. 

To draw slides from a slide pool, do the following: 

1. In the Slides pane, select one or more random slides. 

2. Click the Properties pane > Linked Pool > select the desired pool. 
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When randomizing questions, it’s better to ensure each learner get a quiz that is equally 
difficult. To do that, set the difficulty level for each question. Then, sort questions based on 
their degree of difficulty into separate pools. That way, you can have individual pools for each 
difficulty level with a certain number of questions, such as 10 difficult questions, 10 moderate 
ones, and 10 easy ones. 

Inserting Report Slides 

At the end of a course or presentation, you can insert a report slide to summarize user 
performance. The report slide allows you to track and review all graded questions in a course. 

To add a report slide, click the Slide tab > Report Slide . This inserts a report slide that, by 
default, has several parameters and the Review Course button. 

 

You can show or hide the default parameters using the Properties pane > Interactivity > 
Report Display. You can also add custom parameters using text captions and variable 
references.  

The Review Course button lets you review a quiz in the review mode. For more details, see 
Reviewing Courses. 

Note:  

• There is another way to add a report slide. In the Home tab or the Slide tab, click the 
arrow on the New Slide button > Report Slide. This inserts a new slide having a report 
placeholder. Just click the icon in the placeholder to add a report. 

• To modify the look of the report slide, open the slide master view and modify the report 
slide layout. For more details, see Using Slide Masters. 
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Reviewing Courses 

At the end of a course or presentation, you can add a report slide to summarize the 
performance of users. Besides displaying some reporting-related information, the report slide 
lets users review the entire course using the Review Course button. By click this button, users 
enter the review mode where they can see correct and incorrect answers, correct values, and 
the overall result of each interaction and slide.  

 

Here’s how ActivePresenter creates and handles the review mode. At the beginning of a slide, 
ActivePresenter checks if a course is in the review mode using the read-only apReviewMode 
variable. If the course is in the review mode (the variable value is equal to true), 
ActivePresenter will show all correct/incorrect response for graded interactions on the review 
feedback layer. 

 

You can:  

• Change the parameters of the Show Responses action. By default, all graded 
interactions are shown. 

 

o Interaction Object: Determine which object will show responses. 
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o Correct/Incorrect Check Mark: Show correct/incorrect check marks next to 
correct/incorrect answers. 

o Correct Values: Show correct values next to interaction objects. Available for 
mouse clicks, key strokes, text boxes, fill in blank, fill in multiple blanks, and essay 
questions. 

o Results: Show the overall result of the graded interaction at the bottom of a slide. 
If the slide has more than one graded interaction, all the results will overlap, so only 
the result of the last graded interaction can be seen. However, you can determine 
which result to be displayed as you wish. In common cases, there is only one 
graded interaction in a slide, so its result is treated as the overall result of the slide. 

• Change the feedback layer to be displayed. By default, ActivePresenter displays the 
review feedback layer. You can change this layer to any other feedback layer. Click 
the Feedback combo box and select the layer you want. 

 

o Hide After: Hide the feedback layer after a period of time. 

o Blocking: Block the main timeline until the feedback layer is hidden. 

• Open the feedback master view to modify the displayed feedback layer. For details, 
see Using Feedback Master. 
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Adding Events - Actions 

Events - Actions allows you to define actions for a given event of the object and slide of the 
project. 

To open this section, select the question/interaction object/slide > Interactions tab > Event 

. 

Alternatively, you can select the slide containing the question or interaction object > 
Properties pane > Interactivity > Events - Actions. 

The image below shows the sample Events - Actions of a slide:  

 

There are many types of events in ActivePresenter (On Correct, On Incorrect, On Accept, On 
Rollover, etc.). They may vary from question to question and object to object. On the other 
hand, there are a wide variety of actions that an event can have.  

The next parts will explain how to add and remove them in details. 

Since the structure of a given event, action, and condition does not change from object to 
object, the next parts will describe how to add and remove an event/action/condition for a 
question as a sample. You can do similarly for other types of objects. 

Adding and Removing Events 

Each question, object, or slide can have more than one event. 

To add an event to an object/slide, select it > hover the mouse over the question/object/slide 

title in the Properties pane > Add Event  > choose an event from the pop-up list. 
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Besides, to remove an event, click the event entry > Delete Event .  

 

Adding and Removing Actions for Events  

To add actions to an event, select the event > Add Action .  

Repeat these steps to add more actions if needed. Each event can have more than one action. 
In that case, actions will be played in the order that you insert. To change the order of an 

action, select it and click the Move Action Up button  or Move Action Down button  to 
bring an action up or down one level respectively. 

 

ActivePresenter will display the following action gallery: 
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To change the action, simply click the Action entry (e.g. Continue Presentation) and select 
one action from the action gallery. 

To delete an action, click/hover the mouse over the action entry, and click the Delete Action 

button . 
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Note: With the actions that require you to select objects (Show Object, Hide Object, etc.), the 
object on the Canvas will gain the highlight when you hover over its name from the drop-down 
list in the Events - Actions section. The highlight is a red line that borders the object to let you 
know which object you are selecting. 

Adding and Removing Conditions for Actions 

Each action can have specified conditions. This means the action can only be played if some 
certain contexts are met.  

To add a condition to an action, select the action and click the Add Condition button .  

 

The dialog appears as follows: 
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After adjusting the Add Condition dialog, click Add button to complete the process. Then 
click Close to close the dialog. Click Add & Continue to add the condition and continue adding 
other ones. After that, a Condition entry will be added right below the Action entry. 

Note: The content of this dialog will vary differently. It depends on which type of objects you 
are working with. 

Parameter Function 

And/Or  Use this to combine multiple conditions in an action. 

And Execute the action if all conditions are true. 

Or Execute the action if there is at least one condition is true. 

List  The type of object to be compared in a condition. 

Variables Compare a variable with a value or other variable. 

Shapes Compare the current state of a shape to a specified state of the shape. 

Attempt Compare the number of actions that users have tried. 

Mouse 
Compare the value of a mouse click event to a value. This is only 
available in the On Click event. 

Key 
Compare the value of key stroke event to a value. This is only available 
in the On Key Press event. 

If  Specify the variable, shape to be compared. 

Operator  The logical operator which is used to compare. 

State  
The state of the shape which the current state of the shape is compared 
with. 

Type Select to compare a variable with a variable or a value. 

Value Set the value to compare the variable with. 

To edit the condition that you’ve added, select the condition entry and click the Edit Condition 

button . This opens the Edit Condition dialog which has the same structure and content to 
the Add Condition one shown above. 
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Besides, to delete a condition, select the condition entry and click the Delete Condition button 

. 

 

Copying Events, Actions and Conditions 

ActivePresenter allows you to copy events, actions, and conditions easily. To do that, right-

click the event/action/condition entry > Copy . Then, right-click the destination 

object/event/action > Paste .  
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Events - Actions References 

Event actions can be attached to both annotation and interaction objects. You can specify the 
events (for example, “when the mouse rolls over this shape”), and what actions should be 
taken in response to those events (for example, “display the hint message”). 

In older versions of ActivePresenter, interactions are managed in the Event Editor dialog. From 
version 7, this dialog no longer exists. Instead, you can set up and manage interactions in the 
Properties pane > Interactivity > Events - Actions. 

Events  

Events are used to trigger actions - in other words, when an event is detected, one or more 
actions are provided as a response. 

Events available for objects and slides are explained as follows: 

Event  Description 

On Click Occur when users click an object. Available for mouse clicks, 
buttons, drag sources, drop targets (not including drop areas), 
animated timers, shapes (including all message types), images, 
and videos.  

On Key Press Occur when users press a key or a combination of keys. Available 
for key strokes only. All keys except WINDOWS key are supported. 
You can define actions for each key stroke value using 
conditional actions. 

Note that there are different keyboards for different languages. 

On Text Enter Occur when users enter a text string. Available for text boxes only. 
You can define actions for each entered text value using 
conditional actions. 

On Check Occur when users mark a check box or radio button. Available for 
check boxes and radio buttons only. 

On Drag Start Occur when a drag source is dragged from its location. Available 
for drop sources only. 

On Drag End Occur when users release the mouse button (end the dragging) 
while dragging a drag source. Available for drop sources only. 

On Drag Enter Occur when a drag source enters a drop area or drop target. 
Available for drop areas and drop targets only. 

On Drag Leave Occur when a drag source leaves a drop area or drop target. 
Available for drop areas and drop targets only. 

On Accept Occur when any accepted drag source is dropped on a drop area 
or drop target. Available for drop areas and drop targets only. 

On Reject  Occur when any rejected drag source is dropped on a drop area or 
drop target. Available for drop areas and drop targets only. 
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On Timer Complete Occur when a timer is completed or timed out. Available for timers 
only. 

On Correct Occur when users give a correct response. Available for all graded 
interactions. 

On Incorrect Occur when users give an incorrect response. Available for all 
graded interactions. 

On Complete Occur when users answer a question or fill in a text box. Available 
only when the mode of the question or text box is survey. 

On Incomplete Occur when an answer is incomplete, for example: 

• Users leave a field blank in a text box object or in a question 
containing a text box (fill in blank, fill in multiple blanks, and 
essay). 

• Users leave all check boxes or radio buttons unchecked in 
case of true/false, multiple choice, and multiple response. 

• Users leave all drop targets empty (contain no drag source) in 
drag-n-drop question. 

On Timeout Occur when users don’t respond within a specified time. Available 
for all graded interactions. 

On Rollover Occur when the mouse rolls over the shape of an object (enters 
the boundary of a shape). Available for mouse clicks, key strokes, 
text boxes, buttons, check boxes, radio buttons, drag sources, drop 
areas, drop targets, animated timers, shapes (including all 
message types), and images.  

On Rollout Occur when the mouse rolls out of the shape of an object (exits the 
boundary of a shape). Available for mouse clicks, key strokes, text 
boxes, buttons, check boxes, radio buttons, drag sources, drop 
areas, drop targets, animated timers, shapes (including all 
message types), and images. 

On Swipe 
Left/Right/Up/Down 

Occur when users swipe across an object to the 
left/right/top/bottom on the touch screen. Available for buttons, 
drop targets (not including drop areas), animated timers, shapes 
(including all message types), and images.  

On Load Occur when a slide starts showing. Available for slides only. 

On Unload Occur right before a slide completes. Available for slides only. 

Actions 

Actions are always paired with events, that is, they occur in response to events. For example, 
when you click a link in a slide, a new browser tab or window opens.  

All actions are listed as follows: 
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Action Description 

Presentation 

Continue 
Presentation  

Depending on the current state of the presentation: 

• If the presentation is playing, this action doesn’t change 
anything. 

• If the presentation has been paused, this action will continue 
playing the presentation from the time it stops. 

You can pause a presentation in two ways: 

• Click the Properties pane > Interactivity > General > Pause 
presentation to wait for user input for any interaction object. 
When the object is played, the presentation will pause. You can 
choose between pausing the presentation just before hiding the 
object or pausing it after showing the object for a specific 
amount of time.  

 
• Execute the Pause Presentation action (see below). 

Pause Presentation Half the presentation’s mainstream, thus making all the objects 
stop playing against the time. Users can still interact with 
interaction objects. 

The presentation is paused indefinitely until one of the following 
actions is executed: Continue Presentation, End Presentation, Go 
to Slide, Go to Slide at Index, Go Backward or Go Forward. 

End Presentation Exit the presentation. 

Review Presentation Enter the review mode where users can see correct and incorrect 
answers, correct values, and the overall result of each interaction 
and slide. 

Restart Presentation Reset the presentation to the original state and start from the 
beginning. 

Slide 

Go to Slide Go to a specific slide. The link is made to a specific slide, so if you 
move that slide to a new position, the link will follow it and jump to 
the new position. If the target slide is deleted, the link gets 
dissolved automatically. 

Go to Slide at Index Go to a slide at a specific index. When you add, remove, or reorder 
slides, the order of slides may change. Regardless of that, this 
action will jump to the nth slide in the order. 



ActivePresenter User Manual  Version 7.5 

Adding Interactivity > Adding Events - Actions 194 

Go Forward Go backward by a specified number of slides. The target is not a 
specific slide, instead the jump will land on any slide that is 
presently n slides away from the current slide. 

Go Backward Go forward by a specified number of slides. The target is not a 
specific slide, instead the jump will land on any slide that is 
presently n slides away from the current slide. 

Object 

Show Object Show an initially hidden shape, image, audio, or video object. 
Objects can be shown with animation and hidden automatically 
with animation after an amount of time. If you want to allow users 
to manually hide the object, execute the Hide Object action. 

Subsequent actions can be blocked until this action is completed. 
Otherwise, subsequent actions are executed right after the object 
is displayed. 

Hide Object Hide any object which is displayed by the Show Object action 
before it disappears automatically. Objects can be hidden with exit 
effects. 

Highlight Object Highlight an object using an emphasis effect. 

Change Object 
State 

Change the display state of a multi-state object. 

Play Audio Play an audio resource or built-in sound in your project. This action 
should be used to play short audio. For long audio tracks, you’re 
recommended to insert them into slides, make them initially 
hidden, and execute the Show Object action. After that, use the 
Hide After option in the Show Object action to stop the audio 
automatically or execute the Hide Object action to let users stop 
the audio manually. 

In fact, the Play Audio action is similar to the Show Object non-
blocking action with audio objects, except it doesn’t require that an 
audio object is inserted into a slide. 

Clear User Input Clear whatever users entered in a specific interaction object, for 
example: 

• Clear text in all text fields for text boxes and questions that 
contain text boxes. 

• Uncheck check boxes or radio buttons for questions. 

• Send dropped drag sources to their original positions. 

Submit Send whatever users entered in a specific interaction object to the 
presentation to evaluate. 

Timeline 

Start Timeline  Start the playback of the target timeline. 
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Pause Timeline Pause the playback of the target timeline. 

Continue Timeline Resume the playback of the target timeline. 

Feedback 

Show Feedback 
Layer 

Show a feedback layer. You can choose to hide the feedback layer 
after an amount of time. 

Hide Feedback 
Layer 

Hide a feedback layer.  

Show Responses Show responses for all graded interactions. You can determine 
which object will show responses as well as which types of 
responses to be shown. 

Miscellaneous 

Adjust Variable Change the value of a variable. You can assign a value (or 
another variable value) to the target variable, toggle the value of 
true/false variables, and do basic math with number variables.  

Start Timer Make the timer start counting, do nothing if it is running. If the 
timer has finished, the action restarts it. 

Pause Timer Pause the timer but keep the current value, do nothing if it is 
paused. 

Stop Timer Stop the timer and reset its value. 

Send Email Launch the default email client program installed on user PC, and 
load the previously configured contents in the mail (including 
recipient address and subject line). 

Note that the email is not sent silently or automatically, instead 
users must manually press the send button. Users can also modify 
the email contents before sending. 

Open Webpage Open a specified URL. Choose to open it in the current, new, 
parent, topmost, or named window. 

Execute JavaScript Execute a specified JavaScript. Write the script in the window that 
appears. 

Advanced Actions Execute an advanced action.  

Setting Up Interactions 

The following chart shows the events for each object type. 

Objects Events 
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Adding Advanced Actions 

The Advanced Actions feature allows you to define complex actions and reuse them easily. 
An advanced action can contain normal actions and parameters, which is divided into three 
components: action name, parameters, and a list of actions. The action list can include both 
types of actions that use and don’t use the parameters of the advanced action. You can reuse 
the advanced actions in many places by changing or adjusting its parameters. 

To create and use advanced actions, click the Properties pane > Interactivity > Events - 

Actions > Advanced Actions . Alternatively, click the Interactions tab > Advanced 

Actions . 

 

Then, the Advanced Actions dialog appears, allowing you to view and edit the parameters 
and actions. 
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Note: You can click the button  to see which slides the advanced actions are currently used. 

Take the following steps to create the advanced actions:  

Creating New Advanced Actions 

In the Action Name section, click the  button to create a new action.  

To rename an advanced action, select it from the Action Name list and click Rename Action 

. Besides, to delete an action, select it and click Delete Action . To duplicate an action, 

select it and click Duplicate Action .  

Creating Parameters 

The parameters you create here will be used as the references for the actions in the next part. 

To create new parameters, in the Parameters section, click Add button . Then, enter the 
parameter name in the Name box and select the corresponding type from the Type list. For 
example, if you are creating a parameter for an object, the type will be Slide Object.  
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After adding a parameter, you can rename it by clicking the Edit button . Besides, to delete 

a parameter, select it and click Remove . 

Adding Actions 

Click Add  to select an action from the gallery. This gallery is the same to the one you have 
when you add actions to events.  

Then, you can hover the mouse over the newly added action entry and click Click to edit to 
edit the action.  

 

Then, the following dialog will appear: 

 

First, click the Param box to enable selecting parameters from the list that you created before. 

In case there are more than one actions added, they will happen in the order that you add. To 

change that order, click  and . Besides, to delete an action, select it and click Delete .  

 

Adding Conditions to Actions 

Too add condition to advanced actions, select it and click Add Condition . This opens the 
Add Condition dialog. This dialog is similar to the one you have when adding conditions to a 
normal action. However, it has the option to use parameter. Select this option and choose a 
corresponding parameter. 
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Adding Advanced Actions to Events 

You can add advanced actions to events of an object the way you do with normal actions.  

To do that, click the Properties pane > Interactivity > Events - Actions > select the event 

entry > Add Action  > Advanced Action.  

After that, on the Advanced Action entry, click Click to edit and select one advanced action 
from the list. Then, in the dialog that appears, set the value for each parameter. 

 

 Using Variables  

Variables are a great way to collect, store, and retrieve dynamic information throughout a 
project. They are also useful for creating conditional interactivity with conditional actions that 
only occur when certain conditions are met. 

ActivePresenter provides three types of variables: true/false, text, and number. All come in 
two categories: system and user-defined. 

• System variables come predefined. You cannot modify and delete them. Find system 

variables in the Home tab > Variables  > System tab. 

• User-defined variables are project-specific variables created by users. You are free 
to create, modify, and delete these variables. 
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A variable can fall into three types: 

• True/false variables (boolean variables) have only two possible values: true and 
false. This true or false nature makes these variables a great way to keep track of 
things that are right or wrong, on/off, clicked/not clicked, visited/not visited, and the 
like. True/false variables enable you to make decisions, and thus have better control 
over your flow. For example, you can use true/false variables for slide completion, that 
is, to track if learners visit a slide and interact with its contents. 

• Text variables (string variables) hold text-based values (strings). They help store 
information such as names, passwords, etc. For example, you can use text variables 
to remember the learner name, then display it throughout the course to personalize 
your training. 

• Number variables (integer variables) hold numeric values. They store numeric 
information such as scores, number of attempts/clicks, question counting, current slide 
number/index, and any other numeric values. For example, you can use number 
variables for some simple calculation functions such as addition and subtraction. Or, 
use these variables to create a visible counter that counts either up or down to track 
the number of clicks. 

Creating Variables 

To create a new variable, do the following: 

1. Click the Home tab > Variables to open the Variables dialog. 

 

2. In the User tab, click Add  in the bottom toolbar. This opens the Variable dialog 
where you specify the variable name, type, initial value, and description (if any). 
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o Name: Specify a unique name for the variable. The name should be descriptive 
and intuitive enough and associated with the data stored. For example, a variable 
storing learner name would be called learnerName. 

o Type: Represent what kind of data is stored with the variable. Select from three 
types: true/false, text, and number. 

o Value: The data stored within a variable is called a value, and it can be one of 
multiple types as mentioned above. Normally, when you add variables, you define 
the variable names and types. For values, if you don’t assign initial values, the 
default values for true/false, text, and number variables are true, empty string, and 
zero (0), respectively. 

o Description: Optionally, provide a description for the variable to state its use or 
purpose. 

3. Click Add & Close to save the variable. The new variable will appear in the variable 
list in the User tab. 

4. Click Add & Continue to save the variable and continue adding another variable. 

Adding References to Variables 

Variables store data. Variable references retrieve and display the data stored in variables. You 
can also use references to verify whether the variable is working correctly or not. 

For example, you use a variable to get the learner name, then use the name throughout the 
course to personalize your training. On the welcome slide, just ask learners to type their names 
in a field (text box) and store the input in a variable. Then, add references to that variable to 
display the name in multiple slides in your course. 

 

You can add a reference to any text caption, shape, or other text-based objects. Do the 
following: 

1. Click the text area of a text-based object to open the inline text editor. 

2. Click the Home tab > Reference  to open the Variables dialog which contains all 
the system and user variable in your project.   
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3. Select a variable. Both system and user variables are available to add references. 

4. Click OK to finish. Then, a variable reference appears in your text as a placeholder 
that contains the variable name getting enclosed within two percent signs (%).  

When you preview or publish the project to HTML5, ActivePresenter replaces the 
variable names with the actual values of the variables they reference. 

5. Optionally, adjust the formatting of the reference as normal. 

Note: If you remember exactly a variable name, you can type the name and put it between 
the % signs to reference that variable. 

Using Actions to Adjust Variable Values 

Variable values change depending on user input. For example, in the above example of the 
learnerName variable, each time a learner types his name, the variable value will update with 
the new entry. 

Alternatively, you can use the Adjust Variable action to adjust variable values. Let’s say you 
want to count the number of times users click on the screen before they click the correct area. 
Do the following: 

1. Add the Adjust Variable action to the On Click event.  

2. Click Click to edit to open a dialog letting you change the variable. 

3. Click the Variable combo box and choose a variable from the list. Or, click the Add 
Variable button to create a new variable then select it. 

 

4. Choose an operator from the Operator combo box. For example, the Assignment 
operator assigns a value to the target variable. Meanwhile, the Add operator adds a 
value to the target variable. 

o True/false variables: Assignment, Toggle. 

o Text variables: Assignment. 

o Number variables: Assignment, Add, Subtract, Multiply, Divide. This means you 
can do math with number variables. 

5. Specify the Value by which the operation is to be done. It can be a specific value (you 
yourself specify it) or a value stored by another variable. 

Managing Variables 

Duplicating Variables 

To duplicate a user variable, in the Variables dialog > User tab, do the following: 
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1. Select the variable you want to duplicate. 

2. Click Duplicate  in the bottom toolbar to make an exact copy of the variable.  

3. In the user variable list, double-click the new variable to change its parameter. 

4. Click Update to save changes.  

5. Click OK to finish. 

Removing Variables 

You can delete only user variables. When you delete a variable, any references to this variable 
and actions that involve it still remain. Thus, you need to modify or delete those references 
and actions manually. 

To delete a user variable, select it > Remove  in the bottom toolbar. 

Editing Variables 

You can edit the name, initial value, and description of a user variable at any time. The variable 
type cannot be changed. If you rename a variable, all references to the variable and actions 
that involve it will be updated automatically. 

To edit a user variable, double-click it or select it > Edit  in the bottom toolbar. When you’re 
done, click Update to save changes and click OK to finish. 

Finding Variables 

ActivePresenter makes it easy to find how many times and where a variable is used. You can 
double-click the hyperlinked number in the Usage Count column for the variable you want to 
find. Each time it is referenced by slide text or involved in an action will be counted. You can 

also select the desired variable and click Usage  in the bottom toolbar. 

List of System Variables 

All system variables are shown in the Home tab > Variables > System tab as in the figure 
below. Besides the variable name, type, and default value, the list also shows the number of 
times each variable is used. 

Below is the list of system variables in ActivePresenter. Note that system variables have four 
types in total, namely true/false, text, number, and command. Command variables are system-
specific variables used to control the player. 

Name Type Description 

apVersion  TEXT Returns the version of the 
application.  

apAuthor TEXT Returns the name of the project 
author. 

apHomepage TEXT Returns the home page of the 
project. 
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apCopyright TEXT Returns the copyright information 
of the project. 

apProjectName TEXT Returns the project name. 

apDescription TEXT Returns the project description. 

apPlayMode TEXT Returns the current operation 
mode of the presentation. 

apCurrentSlideLabel TEXT Returns the current slide name. 

apElapsedTime TEXT Returns the elapsed time in the 
format hh:mm:ss since the 
presentation started playing. 

apElapsedTimeMs NUMBER Returns the elapsed time in 
milliseconds since the presentation 
started playing. 

apRemainingTime TEXT Returns the remaining time in the 
format hh:mm:ss. 

apRemainingTimeMs NUMBER Returns the remaining time in 
milliseconds. 

apTotalSlides NUMBER Returns the total number of slides 
in the project. 

apTakenSlides NUMBER Returns the number of taken slides 
in the project. 

apReviewMode TRUE/FALSE Returns true if presentation in 
review mode. 

apQuizScore NUMBER Returns the total score. 

apQuizScorePercentage NUMBER Returns the total score as 
percentage. 

apQuizMaxScore NUMBER Returns the highest score. 

apScoreSubtract NUMBER Used to collect the penalty score of 
incorrect answers. Users have to 
adjust the value of this variable 
manually. 

apQuizPassed TEXT Returns the result of the quiz as 
passed or failed. 

apQuizPassedBool TRUE/FALSE Returns the result of the quiz as 
true (passed) or false (failed). 
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apQuizTotalInteractions NUMBER Returns the total number of 
interactions in the project. 

apQuizTakenInteractions NUMBER Returns the number of taken 
interactions in the project. 

apQuizUnTakenInteractions NUMBER Returns the number of 
unanswered interactions in the 
project. 

apQuizCorrectInteractions NUMBER Returns the number of correct 
interactions in the project. 

apQuizIncorrectInteractions NUMBER Returns the number of incorrect 
interactions in the project. 

apDetailedResult TEXT Returns the detailed report. 

apDetailedResult2 TEXT Returns the detailed report with 
correct responses. 

apCurrentTime TEXT Returns the current time in the 
format hh:mm:ss. 

apCurrentDay NUMBER Returns the day of the week. The 
range is from 1 (Sunday) to 7 
(Saturday). 

apCurrentHour TEXT Returns the current hour in the 24-
hour format. 

apCurrentMinutes TEXT Returns the current minutes in the 
format mm. 

apCurrentMonth TEXT Returns the current month in the 
format mm. 

apCurrentYear TEXT Returns the current year in the 
format yyyy. 

apCurrentLocaleDate TEXT Returns the current date in the 
format of the locale on the viewer's 
computer. 

apProjectLocaleDate TEXT Returns the current date in the 
format of the project language. 

apDateMMDDYYYY TEXT Returns the current date in the 
format mm/dd/yyyy. 

apDateMMDDYY TEXT Returns the current date in the 
format mm/dd/yy. 
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apDateDDMMYYYY TEXT Returns the current date in the 
format dd/mm/yyyy. 

apDateDDMMYY TEXT Returns the current date in the 
format dd/mm/yy. 

apDateYYYYMMDD TEXT Returns the current date in the 
format yyyy/mm/dd. 

apDateYYMMDD TEXT Returns the current date in the 
format yy/mm/dd. 

apCurrentSlideIndex NUMBER Gets or set the current slide index, 
starts from 1. Set the value to a 
number to go to the slide at that 
index number. 

apPause TRUE/FALSE Set or checks if the presentation is 
paused. Set the value to true to 
pause the presentation. 

apResume TRUE/FALSE Set or checks if the presentation is 
playing. Set the value to true to 
continue the presentation. 

apProgress NUMBER Gets or set the current progress of 
the presentation in milliseconds. 
Set the value to a number to go to 
a specific time of the presentation. 

apSpeed NUMBER Gets or set the playback speed. 
The range is from 50% to 200%. 

apMute TRUE/FALSE Mutes or unmutes the audio. Set 
the value to true to mute the audio. 

apVolume NUMBER Gets or set the audio volume. The 
range is from 0 (mute) to 100 
(maximum). 

apCCVisible TRUE/FALSE Shows or hides the closed caption. 
Set the value to true to show the 
closed caption. 

apToolbarVisible TRUE/FALSE Shows or hides the player toolbar. 
Set the value to true to show the 
toolbar. 

apTOCVisible TRUE/FALSE Shows or hides the table of 
contents. Set the value to true to 
show the table of contents. 

apCmdNextSlide COMMAND Set the value to true to go to the 
next slide. 
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apCmdPreviousSlide COMMAND Set the value to true to go to the 
previous slide. 

apCmdFirstSlide COMMAND Set the value to true to go to the 
first slide. 

apCmdLastSlide COMMAND Set the value to true to go to the 
last slide. 

apCmdHistoryBack COMMAND Set the value to true to go to the 
previously visited slide in the 
navigation history. 

apCmdHistoryForward COMMAND Set the value to true to go to the 
next slide in the navigation history. 

apCmdEnd COMMAND Set the value to true to end the 
presentation. 

apCmdRestart COMMAND Set the value to true to restart the 
presentation. 

apCmdShowAbout COMMAND Set the value to true to show the 
information dialog. 
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Custom JavaScript in HTML5 Output 

ActivePresenter allows retrieving elements of presentation in the HTML5 output by exposing 
the JavaScript API. You can write custom script in the following areas: 

• The Event tab of a project (ActivePresenter button > Project > Properties > Event). 

• The Execute JavaScript action in the Evens - Actions section of the Properties pane. 

You can access the presentation in two above areas by using the object prez. The prez 

object has the following methods: 

Method Description 

object(name) Gets the object in the current slide from name. If not 
found, search control shows over multiple slides in the 
bottom layer, then the top layer. 

slideCount() Returns the number of slides in the presentation. 

showSlideAt(index, 

time) 

Returns false if the index is out of range. 

• index: Slide index, starts from 1. 

• time: Jumps to the specified time stamp (in 

milliseconds) in the slide. Time can be omitted. If 
omitted, then time equals 0. 

currentSlideIndex() Returns the current slide index, starts from 1. 

nextSlide() Goes to the next slide. Ends the presentation and 
returns false if the current slide is the last one. 

previousSlide() Goes to the previous slide. Returns false if the current 

slide is the first one. 

firstSlide() Goes to the first slide. If the current slide is already the 
first one, replays it from the beginning. 

lastSlide() Goes to the last slide. If the current slide is already the 
last one, replays it from the beginning. 

historyBack() Goes backward in slide navigation history. 

historyForward() Goes forward in slide navigation history. 

time() Returns the current time stamp of the presentation in 
milliseconds. 

time(time) Goes to the specified time stamp (in milliseconds) of the 
presentation. 

slideTime() Returns the current time stamp of the current slide in 
milliseconds. 
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slideTime(time) Goes to the specified time stamp (in milliseconds) of the 
current slide. 

duration() Returns the total duration (in milliseconds) of the 
presentation. 

restart(slideIndex, 

time) 

Restarts the presentation from slide index (start from 1), 
at specified slide time stamp (in milliseconds). All 
previous results are cleared. 

end() Ends the presentation. 

startTimeline(name, 

callback) 

Starts the interactive timeline which has the specified 
name, and executes the callback (if specified) when the 
timeline is complete. Don't use this method for the main 
timeline. 

pauseTimeline(name, 

paused) 

Pauses or resumes the interactive timeline which has 
the specified name. Don't use this method for the main 
timeline. 

paused() Returns true of the main timeline is paused, false 

otherwise. 

pause(paused) Pauses or resumes the main timeline of the 
presentation.  

speed() Returns the current playback speed (normal speed value 
is 1). 

speed(speed) Sets the playback speed. Possible values are 0.5, 1, 1.5, 
2. 

volume() Returns the current volume. 

volume(volume) Adjusts the volume of the player (volume value is from 0 
to 1). 

muted() Returns true if the presentation is muted, false 

otherwise. 

mute(muted) Mutes or unmutes the presentation. 

closedCaptionVisible() Returns true if the closed caption is shown, false 

otherwise. 

showClosedCaption(show) Shows the closed caption. If show equals true, then 

show the closed caption, otherwise hide the closed 
caption. 

tocVisible() Returns true if the table of contents is shown, false 

otherwise. 
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showToc(isShow) Shows the table of contents if isShow equals true, 

otherwise hide table of contents. 

toolbarVisible() Returns true if the player toolbar is shown, false 

otherwise. 

showToolbar(show) Shows the player toolbar. If show equals true, then 

show the player toolbar, otherwise hide the player 
toolbar. 

showAbout() Shows the information dialog. 

submit() Submits all interactions in the current slide. 

clear() Clears all user input in the current slide. 

interactionCount() Returns the number of interactions. 

takenInteractionCount() Returns the number of taken interactions. 

takenSlideCount() Returns the number of taken slides in the project. 

score() Returns the total score. 

percentageScore() Returns the score in percentages (0 - 100). 

maxScore() Returns the highest possible score of the presentation. 

result() Returns the result of the quiz as passed or failed (true 

equals passed, and false equals failed).  

reportData() Returns the report object (see Report in JSON Format) 
section for its properties). 

elapsedTime() Returns the elapsed time in milliseconds since the 
presentation started playing. 

remainingTime() If in Tutorial, Practice, or Test mode and Total Max Time 
is defined, return the remaining time in milliseconds till 
the max time expires. Otherwise, returns duration() - 
time(). 

variable(name) Get variable value. 

• name: The string name of the defined variable 

(“apVersion”, “apAuthor”, etc.). e.g. to get the 
presentation’s version, you can use script 
variable(“apVersion”). 

variable(name, value) Set variable value. 

• name: The string name of the defined variable. 

• value: Value of variable, can be string or number. 
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version() Returns the version of the application. 

author() Returns the name of the project author. 

homePage() Returns the home page of the project. 

copyright() Returns the copyright information of the project. 

name() Returns the project name. 

description() Returns the project description. 

playMode() Returns the current operation mode of the presentation 
('Demo', 'Tutorial', 'Practice' or 'Test'). 

 

The Object object has the following methods. Note that for text box, both html and text method 
set/get text box value as plain text. 

Method Description 

name() Returns the name of the object.  

visible() Returns the object’s current visibility state. Note that 
child object is actually visible if it is visible() and all 

its ancestors are visible(). 

show() Show the object. 

show(effectType, 

duration, options) 

Show the object with effect. 

• effectType: Use any of the following values. (You 

need to add AP.EffectType. prefix for accessing 

these values.) 

o FADE_IN 

o FLY_IN 

o PEEK_IN 

o FLOAT_IN 

o WIPE_IN 

o ZOOM_IN 

o GROW_TURN_IN 

o SHAPE_IN 

o SWIVEL_IN 

o BOUNCE_IN 

o EXPAND_IN 

o SPINNER_IN 

o STRETCH_IN 
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o COMPRESS_IN 

• duration: In milliseconds. 

• options: AP.EffectDirection or { 

direction: AP.EffectDirection, 

callback: Optional callback called when effect 

completes, callback is bound to the object ('this' is 
the object). 

} 

AP.EffectDirection: Use any of the following 

values. (You need to add AP.EffectDirection. 

prefix for accessing these values.)  

o BOTTOM 

o LEFT 

o RIGHT 

o TOP 

o BOTTOM_LEFT 

o BOTTOM_RIGHT 

o TOP_LEFT 

o TOP_RIGHT 

o IN 

o OUT 

o CLOCKWISE 

o COUNTER_CLOCKWISE 

hide() Hide the object. 

hide(effectType, 

duration, options) 

Hide the object with effect. 

• effectType: Use any of the following values. (You 

need to add AP.EffectType. prefix for accessing 

these values.) 

o FADE_OUT 

o FLY_OUT 

o PEEK_OUT 

o FLOAT_OUT 

o WIPE_OUT 

o ZOOM_OUT 

o GROW_TURN_OUT 

o SHAPE_OUT 

o SWIVEL_OUT 

o BOUNCE_OUT 
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o CONTRACT_OUT  

o SPINNER_OUT 

o STRETCH_OUT 

o COLLAPSE_OUT  

• duration: In milliseconds 

• options: AP.EffectDirection or { 

direction: AP.EffectDirection, 

callback: Optional callback called when effect 

completes, callback is bound to the object ('this' is 
the object) 

} 

See the values of AP.EffectDirection in the 

description of the show function. 

animate(effectType, 

duration, options) 

Animate the object. 

• effectType: Use any of the following values. (You 

need to add AP.EffectType. prefix for accessing 
these values.) 

o PULSE 

o TEETER 

o SPIN 

• duration: In milliseconds. 

• options: AP.EffectDirection or { 

direction: AP.EffectDirection, 

callback: Optional callback called when effect 

completes, callback is bound to the object ('this' is 
the object). 

} 

See the values of AP.EffectDirection in the 

description of the show function. 

html() Returns html text (all variables are replaced by their 
actual values before returning). 

html(htmlText) Sets html text, returns this object. 

• htmlText: HTML string. 

text() Returns plain text (all variables are replaced by their 
actual values before returning). 

text(plainText) Sets plain text, returns this object. 

• plainText: Plain text string. 
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cursor(strCursor) Sets cursor for object, strCursor is CSS cursor 

(“busy”, “crosshair”, “help”, etc.). 

left() Returns the left of the object in pixels. 

left(value) Sets the left for the object. Value can be pixel number 
(e.g. 100), or string (e.g. '20%'). 

top() Returns the top of the object in pixels. 

top(value) Sets the top for the object, value as left. Value can be 
pixel number (e.g. 100), or string (e.g. '20%'). 

right() Returns the right of the object in pixels. 

right(value) Sets the right for the object, value as left. Value can be 
pixel number (e.g. 100), or string (e.g. '20%'). 

bottom() Returns the bottom of the object in pixels.  

bottom(value) Sets the bottom for the object, value as left. Value can 
be pixel number (e.g. 100), or string (e.g. '20%'). 

width() Returns the width of the object in pixels. 

width(w) Sets the width for the object, value as left. Value can be 
pixel number (e.g. 100), or string (e.g. '20%'). 

height() Returns the height of the object in pixels. 

height(h) Sets the height for the object, value as left. Value can be 
pixel number (e.g. 100), or string (e.g. '20%'). 

size() Returns the size of the object in pixels {width, 

height}. 

size(w, h) Sets the size for the object. w, h can be pixel number 
(e.g. 100), or string (e.g. '20%'). 

state() Return the name of the current state. 

state(stateName) Change object state to the state named stateName 

fillSolid(color) Change fill color of object.  

• color: CSS color (e.g. 'red', '#FF0000', 'rgb(255, 0, 

0)', 'rgba(255, 0, 0, 0.5)'. 

rotate() Returns the current rotation in degrees. 

rotate(degree) Rotates the object, value is number in degrees. 

rotateBy(deltaDegree) Rotates the object by an additional delta in degrees. 
E.g., if currently the object rotates by 30 degrees, 
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rotateBy(40) will make the object rotate by 70 

degrees. 

• deltaDegree: Number in degree. 

translate() Returns the current translate transform {translateX, 

translateY}. 

translate(translateX, 

translateY) 

Uses translate transform to move the object from its 
original position by an amount of translateX, 

translateY along X, Y axis, respectively.  

• translateX, translate are numbers in pixels. 

Note that object position returned by left(), 

top(), right(), bottom() doesn't change. 

translateBy(deltaX, 

deltaY) 

Uses translate transform to move the object from its 
current position by an amount of deltaX, deltaY along 

X, Y axis, respectively.  

• deltaX, deltaY are numbers in pixels. Note that 

object position returned by left(), top(), 

right(), bottom() doesn't change. 

scale() Returns the current scale {scaleX, scaleY}. 

scale(scaleX, scaleY) Scales object. If scaleY is left out then scaleY equals 

scaleX. 

• scaleX, scaleY: Scale value along x, y axis. 

scaleBy(multiplierX, 

multiplierY) 

Scales object by multiple values. If multiplierY is left 

out, then multiplierY equals multiplierX. E.g., if 

current scale is 2, scaleBy(3) means that scale is 2 x 

3 = 6. 

transform() Returns the current transform {translateX, 

translateY, scaleX, scaleY, rotate}. 

transform(translateX, 

translateY, rotate, 

scaleX, scaleY) 

Transforms object by matrix values. 

• translateX, translate are numbers in pixels. 

Note that object position return by left(), top(), right(), 
bottom() doesn't change. 

• degree: Number in degree. 

• scaleX, scaleY: Scale value along x, y axis. 

disabled() Returns true if the object is disabled, false otherwise. 

disable(disabled) Disables or enables object. Disabled object can't receive 
events. Disabled buttons, radio buttons, and check 
boxes show disabled state. 
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• disabled: If true, disables object. Otherwise, 

enables object. 

submit() Submits the interaction object. 

clear() Clears the user input. 

score() Returns the object score. 

attempts() Returns the current attempts. 

maxAttempts() Returns the maximum allowed attempts. 

The Player object (AtomiAP) is a global object which has the following methods: 

Method Description 

open(prezUrl, 

containerId, options) 

Returns the new presentation object or null if browser 

isn't supported. 

• prezUrl: The URL of the presentation. 

• containerId: The ID of the presentation’s 

container. 

• options: Can be omitted. Available options are 

playMode: 'Demo', 'Tutorial', 'Practice', or 'Test', etc. 

close(prez) Closes the presentation object. 

• prez: The presentation to close. 

find(containerId) Finds the presentation object from container id. 

• containerId: The ID of the presentation’s container. 

Example:  

If you want to set text for an object which has name “object1”, you can add an “Execute 
JavaScript” action and write below code: 

var obj = prez.object("object1"); 

if (obj) { 

obj.text(“the text you want to set”); 

} 

Note: When you need to access the Player object inside a project, you should use the AP 

object (which has same scope as prez) instead of AtomiAP.  

Converting between version 6 and version 7 APIs: 

Object Version 6 Version 7 

Prez Prez: presentation object. prez: presentation object. 

ShowSlide(index) showSlideAt(index) 
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ShowNextSlide() nextSlide() 

ShowPreviousSlide() previousSlide() 

ShowPreviousVisitedSlide() historyBack() 

ShowNextVisitedSlide() historyForward() 

GetSlide() currentSlide() 

GetObject(objectName) object(objectName) 

Slide GetObject(objectName) Access from prez object instead 

Object SetText(htmlText) html(htmlText) 

GetText(plaintext) • plaintext equal true: 

text() 

• plaintext equal false: 

html() 

Show(show) • show equal true:  

show() 

• show equal false:  

hide() 

IsShown() visible() 

GetPosition() Using two functions to replace:  

• top() 

• left() 

SetPosition(x, y) Using two functions to replace:  

• top(x) 

• left(y) 
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ActivePresenter allows you to export the presentation in many different formats, as described 
below:  

Format Description 

Images Export slides as images that can be used for purposes related to the 
presentation/training course. Each slide will be exported as an image. 

Video  Export the presentation to a video. Use the video format when the 
interaction with audience isn’t required. 

HTML SlideShow Export slides as images and embed them in HTML pages to be 
viewable in a browser. 

PDF Document Export slides as images and embed them in the PDF format. 

Microsoft Word 
Document 

Export slides to shapes, text, and images, and insert them in a 
*.doc/docx file. After that, this file can be edited further in Microsoft 
Word (or LibreOffice Writer). 

Microsoft Excel Export slides to shapes, text, and images, and insert them in an 
*.xls/xlsx file. After that, this file can be edited further in Microsoft 
PowerPoint (or LibreOffice Calc). 

Microsoft 
PowerPoint 

Convert slides into PowerPoint slides. After that, this file can be edited 
further in Microsoft PowerPoint (or LibreOffice Impress). 

HTML5  Export the presentation to a set of files (HTML, CSS, JavaScript, etc.) 
using the HTML5 standard so it can run on most modern browsers 
(Internet Explorer 9 or later, Google Chrome, Mozilla Firefox, Safari), 
and on various devices and platforms (Windows, macOS, Linux, iOS, 
Android).  

Exporting to Images 

When you choose to export a project to images, each slide of the project will be exported as 
an image, which is great for creating brochures, handouts, and posters for the training.  

To export the project to images, click the Export tab > Images . After that, ActivePresenter 
will display the following dialog:  
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Option Description 

Rendering Options 

Include Closed 
Caption 

Export images along with closed captions (if any).  

Include Cursor Path Export images along with cursor path (if any).  

Include Objects 
Started by Event 

Export images along with objects that are triggered by events. 

Only Export Active 
Window Area 

The exported images only include the active window area and 
slide objects that are selected to export. 

Image 

Size Image size is relative to the slide size.  

Format  Select either PNG or JPEG. JPEG compression is lossy while PNG 
is lossless. PNG retains crystal clear quality, but it doesn’t 
compress well with pictures (very big file size) and its decoding 
(when viewing) is slower than JPEG’s.  

Thus, JPEG is best suited for pictures while PNG is best suited for 
computer-generated images (screenshots, drawings, etc.).   

Optimization Level  Applicable to the PNG format only. This option specifies a relative 
compression level (none, low, normal, high, ultra). The higher the 
compression level, the smaller the output file size, and the longer it 
takes to export. 
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Quality Applicable to the JPEG format only. The higher the quality, the 
larger the output file size. 

Output 

Location Specify the location where the exported images will be saved. 

Exporting to Videos 

The video format is suitable when audience don’t have to interact with the presentation in a 
self-paced manner. Exported videos can contain all animations, closed captions, and audio 
files, etc., that you have inserted in.   

To export the project to a video, click the Export tab > Video . The following dialog will 
appear, allowing you to specify export options.  

General Tab 
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Option Description 

Rendering Options 

Zoom-n-Pan  The exported video will include the zoom-n-pan effect that you 
have inserted in the project. 

Include Cursor Path  The exported video will include the cursor path that you have 
inserted in the project.  

Export Audio Selected by default. Clear this check box if you want to remove audio 
from the output. 

Export Closed 
Captions as Soft 
Subtitles (.SRT) 

Select to export closed captions as a separate subtitle file (*.srt). 
This allows you to change the font, size and color of the subtitles at 
the play time. You can also change the *.srt file to display the 
subtitles in a different language. 

Export Closed 
Caption as Hard 
Subtitles 

Select to hard-code closed captions in the video. Any video player 
which can play the video can also display CC. However, the 
attributes of the subtitles cannot be changed at the play time. 

Embedded in HTML The project will be exported and embedded in HTML.  

Video 

Video Size (%) Video size is relative to the slide size. If you change the video 
size, it will be scaled using bicubic interpolation. 

Width The width of exported video. When you specify the video size or 
height, the width will be automatically calculated based on the 
original size of project. Note that the aspect ratio cannot be changed. 

Height The height of exported video. When you specify the video size or 
width, the height will be automatically calculated based on the 
original size of project. Note that the aspect ratio cannot be changed. 

Frame Rate Set between 1 and 30 fps (frames per second). 

Quality Select in the range [1,100]. The higher number, the better quality 
and the larger file size. 

Audio 

Channels Select either stereo or mono. 

Sample Rate Select from 11025, 22050, 44100, and 48000 Hz. 

Bit Rate Applicable to the MP4, AVI, and WMV formats. Select from 64, 96, 
128, 192, 256, 320 Kbps. 
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Quality Applicable to WebM format only. Select in the range [1,100]. The 
higher number, the better quality and the larger file size.  

Output 

Format Select from MP4, AVI, WMV, WebM, and MKV. The following video 
and audio codecs are used for each container format: 

• MP4: H264 High Profile, ACC. 

• AVI: MS MPEG4 v2, WMA v2. 

• WMV: WMV v2, WMA v2. 

• WebM: VP8, Vorbis. 

• MKV: Flash Screen Video, PCM 16-bit (this format uses 
lossless audio and video codecs so it can be used for further 
editing in other programs without quality loss). 

Output File Specify the file path and name of the exported video. 

Advanced Tab 

This tab allows you to set the thumbnail for the exported video when you choose to embed it 
in HTML. 

Option Description 

None The exported video doesn’t have any thumbnail.  

Select a slide image 
from project 

Select one slide from the project to set as a thumbnail for the 
exported video.  

Select an image 
from file 

Select one image from your computer to set as a thumbnail for the 
exported video.  

Publishing Videos to YouTube 

This feature allows you to publish your video to YouTube after exporting the project to a video. 

To do that, click the Export tab > YouTube . In the dialog that appears, click the YouTube 
tab.  

Click the Sign In button to sign in your Google account before moving to the next steps. Note 
that your YouTube account must have a channel to publish the video successfully. The 
exported video will be published on that channel.  
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Option Description 

Sign In 

Click the Sign In button to sign in and publish video to YouTube.  

Infor 

Title The video title showed on YouTube. 

Description The description of the video. It should contain enough information 
for users to know what contents they can expect from the video.   

Options 

Tags Enter one or more keywords to describe published videos.  

Category Select the category (education, music, sport, etc.,) for published 
videos. 

Privacy Select one from Public, Private, and Unlisted. 



ActivePresenter User Manual  Version 7.5 

Exporting Projects > Exporting to HTML SlideShows 225 

After giving the video all the needed information, click OK to start exporting and publishing it. 

If the video already exists, ActivePresenter will display a dialog to let you decide what to do 
next. In that case, click NO to skip the exporting and start to publishing that video to your 
YouTube channel.  

Exporting to HTML SlideShows 

To export the project to HTML SlideShow, click the Export tab > HTML SlideShow  . The 
following dialog will appear: 

 

Option Description 

Rendering Options 

Include Closed 
Caption 

Export images along with closed captions (if any).  

Include Cursor Path Export images along with cursor path (if any).  

Include Objects 
Started by Event 

Export images along with objects that are triggered by events. 

Image 

Size Image size is relative to the slide size.  

Format  Select either PNG or JPEG. JPEG compression is lossy while PNG 
is lossless. PNG retains crystal clear quality, but it doesn’t 
compress well with pictures (very big file size) and its decoding 
(when viewing) is slower than JPEG’s.  



ActivePresenter User Manual  Version 7.5 

Exporting Projects > Exporting to PDF Documents 226 

Thus, JPEG is best suited for pictures while PNG is best suited for 
computer-generated images (screenshots, drawings, etc.).   

Optimization Level  Applicable to the PNG format only. This option specifies a relative 
compression level (none, low, normal, high, ultra). The higher the 
compression level, the smaller the output file size, and the longer it 
takes to export. 

Quality Applicable to the JPEG format only. The higher the quality, the 
larger the output file size. 

Output 

Location Specify the location where the exported images will be saved. 

Exporting to PDF Documents 

To export the project to Adobe PDF Document, click the Export tab > PDF Document . In 
the dialog that appears, there are three tabs which are described in details in the next parts. 

General Tab 
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Option Description 

Rendering Options 

Include Objects 
Started by Event  

The exported file will include objects which are started by events. 

Create Bookmarks Bookmarks are created from slide names and each bookmark is 
linked to a corresponding slide image. In other words, 
ActivePresenter creates bookmark links to each slide. 

Only Export Active 
Window Area 

The exported area only includes the active window area and slide 
objects which are selected to export. 

Layout 

Slides Per Page Specify the number of slides in one page: one (single slide per 
page), two (two slides per page (top, bottom)), or contiguous (the 
slides are written contiguously in a page until there isn’t enough 
space, then it will be moved to the next page). 

Page Orientation Choose from landscape and portrait. The page size is fixed (A4). 
ActivePresenter uses fixed margins of 1” (2.54 cm) on all sides. 

Description Export slide description and specify which side of the slide to place 
it (top, left, right, or bottom). Select None to disable this option. 

Description Width Applicable only when the slide description is placed on the left or 
right side of the slide. This option specifies the width of the slide 
description in each exported slide (in percentages).  

Image 

Format  Select either PNG or JPEG. JPEG compression is lossy while PNG 
is lossless. PNG retains crystal clear quality, but it doesn’t 
compress well with pictures (very big file size) and its decoding 
(when viewing) is slower than JPEG’s.  

Thus, JPEG is best suited for pictures while PNG is best suited for 
computer-generated images (screenshots, drawings, etc.).   

Optimization Level  Applicable to the PNG format only. This option specifies a relative 
compression level (none, low, normal, high, ultra). The higher the 
compression level, the smaller the output file size, and the longer it 
takes to export. 

Quality Applicable to the JPEG format only. The higher the quality, the 
larger the output file size. 

Output 

Output File Specify the file path and name of the exported document. 
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Advanced Tab  

Option Description 

Description: PDF document-related options. 

Title Title of the PDF document. When you open the PDF in a viewer, 
the title appears in the windows bar (or in the tab in the case of a 
tabbed PDF reader). 

Subject Subject of the document. This is one of PDF document properties 
which can be seen in Document Properties in any PDF viewer. 

Keywords Keywords defined in the PDF document. 

Protection: Security password for opening the PDF document. 

Opening Password  You can set a password for opening this PDF document. 

Confirm Password Enter the password again manually (no copy-paste from the 
previous field). 

Text Style Tab 

This tab controls the text in the generated PDF file. You can change the font size, line spacing, 
and text color for three different parts of the slide: 

Option Description 

Group Title The group title is only exported in the Compact mode. It’s placed 
before any slide group. 

Slide Name The name of the slide which is entered in the Properties pane > 
Slide Properties > General > Name. 

Slide Description The description of the slide which is entered in the Properties 
pane > Slide Properties > General > Description. 

Exporting to Microsoft Word Documents 

To export the project to Word Document, click the Export tab > Microsoft Word Document 

. 

Note: When you export the project to document formats (Microsoft Excel, Microsoft Word, and 
Microsoft PowerPoint), the slide name and slide description are included in the output with the 
default text style (font, size, color, etc.). However, if you format the text before exporting, 
ActivePresenter will export them with the customizations you made. 
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Option Description 

Rendering Options 

Include Objects 
Started by Event  

Include objects which are started by events.  

Create Table of 
Contents 

Add a table of contents to the document with hyperlinks to slides. 

Only Export Active 
Window Area 

The exported area only includes the active window area and slide 
objects which are selected to export.  

Layout 

Slides Per Page Specify the number of slides in one page: one (single slide per 
page), two (two slides per page (top, bottom)), or contiguous (the 
slides are written contiguously in a page until there isn’t enough 
space, then it will be moved to the next page). 

Page Orientation Choose from landscape and portrait. The page size is fixed (A4). 
ActivePresenter uses fixed margins of 1” (2.54 cm) on all sides. 

Description Export slide description and specify which side of the slide to place 
it (top, left, right, or bottom). Select None to disable this option. 



ActivePresenter User Manual  Version 7.5 

Exporting Projects > Exporting to Microsoft Word Documents 230 

Description Width Applicable only when the slide description is placed on the left or 
right side of the slide. This option specifies the width of the slide 
description in each exported slide (in percentages).  

Use Template 
Layout 

Use the layout specified in the template. See Creating Custom 
Word Template to learn more about how to create a custom 
layout.  

Image 

Format  Select either PNG or JPEG. JPEG compression is lossy while PNG 
is lossless. PNG retains crystal clear quality, but it doesn’t 
compress well with pictures (very big file size) and its decoding 
(when viewing) is slower than JPEG’s.  

Thus, JPEG is best suited for pictures while PNG is best suited for 
computer-generated images (screenshots, drawings, etc.).   

Optimization Level  Applicable to the PNG format only. This option specifies a relative 
compression level (none, low, normal, high, ultra). The higher the 
compression level, the smaller the output file size, and the longer it 
takes to export. 

Quality Applicable to the JPEG format only. The higher the quality, the 
larger the output file size. 

Output 

Template Specify the location of the template file. 

Output File Specify the file path and name of the exported document. 

Creating Custom Word Template 

When exporting to MS Word Document, you can create your own Word template and let 
ActivePresenter use it to create the output document. 

To create a custom layout template, you must have Word 2002 (Word XP) or a higher version 
installed on your computer. The steps are as follows: 

Step 1. Place contents.  

The following tags will be used to specify the location to place exported contents: 

• $SlideName1 

• $SlideDescription1 

• $SlideImage1 

For example, if you want to place slide name somewhere in the template, you type 
$SlideName1 in that location. 

Only the usage of $SlideImage1 is different. This is used to specify the location of the slide 
content (slide background, shapes, captions, text, etc.). You need to insert a Word drawing 
canvas and set its Alternative Text to $SlideImage1. 

Step 2. Style contents. 
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To set styles (font name, font size, color, etc.) for Slide Name, Slide Description, you cannot 
set text properties directly to the tags. You need to open the Styles pane and add new styles 
and name to them as: SlideName and SlideDescription. ActivePresenter will automatically use 
these styles when writing Slide Name and Slide Description text. 

After exporting, you can also change these styles easily by opening exported document and 
changing appropriate styles. 

Exporting to Microsoft Excel Worksheets 

To export the project to Excel Worksheet, click the Export tab > Microsoft Excel . 

 

Option Description 

Rendering Options 

Include Objects 
Started by Event  

Include objects which are started by events.  

Only Export Active 
Window Area 

The exported area only includes the active window area and slide 
objects which are selected to export.  

Layout 

Slides Per Page Specify the number of slides in one page: one (single slide per 
page), two (two slides per page (top, bottom)), or contiguous (the 
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slides are written contiguously in a page until there isn’t enough 
space, then it will be moved to the next page). 

Page Orientation Choose from landscape and portrait. The page size is fixed (A4). 
ActivePresenter uses fixed margins of 1” (2.54 cm) on all sides. 

Image 

Format  Select either PNG or JPEG. JPEG compression is lossy while PNG 
is lossless. PNG retains crystal clear quality, but it doesn’t 
compress well with pictures (very big file size) and its decoding 
(when viewing) is slower than JPEG’s.  

Thus, JPEG is best suited for pictures while PNG is best suited for 
computer-generated images (screenshots, drawings, etc.).   

Optimization Level  Applicable to the PNG format only. This option specifies a relative 
compression level (none, low, normal, high, ultra). The higher the 
compression level, the smaller the output file size, and the longer it 
takes to export. 

Quality Applicable to the JPEG format only. The higher the quality, the 
larger the output file size. 

Output 

Template Specify the location of the template file. 

Output File Specify the file path and name of the exported document. 

Exporting to Microsoft PowerPoint Presentations 

To export the project to PowerPoint Presentation, click the Export tab > Microsoft 

PowerPoint . 
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Option Description 

Rendering Options 

Include Objects 
Started by Event  

Include objects which are started by events.  

Only Export Active 
Window Area 

The exported area only includes the active window area and slide 
objects which are selected to export.  

Layout 

Show Slide Name Display the slide name. 

Show Slide 
Description 

Render the slide description. 

Full Screen Open the presentation in full screen initially. 

Advance Slides Select either automatic or manual to jump to the next slide after the 
current slide completes. 

Image 

Format  Select either PNG or JPEG. JPEG compression is lossy while PNG 
is lossless. PNG retains crystal clear quality, but it doesn’t 
compress well with pictures (very big file size) and its decoding 
(when viewing) is slower than JPEG’s.  
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Thus, JPEG is best suited for pictures while PNG is best suited for 
computer-generated images (screenshots, drawings, etc.).   

Optimization Level  Applicable to the PNG format only. This option specifies a relative 
compression level (none, low, normal, high, ultra). The higher the 
compression level, the smaller the output file size, and the longer it 
takes to export. 

Quality Applicable to the JPEG format only. The higher the quality, the 
larger the output file size. 

Output 

Template Specify the location of the template file. 

Output File Specify the file path and name of the exported document. 

Exporting to HTML5  

To export the project to HTML5, click the Export tab > HTML5 . 
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General Tab 

 

Option Description 

Operation Modes 

Modes Select which operation modes (Demonstration, Tutorial, 
Practice, and Test) to be exported and available to users. 

Generate Index 
Page 

Generate the HTML index page which contains the entry to open 
all the selected modes. 

Total Max Time 
(minutes)  

Applicable to the Test mode only. Set a time limit (in minutes) on 
an entire project. This is the total amount of time required for users 
to complete the project.  

Pass Condition Determine the overall pass/fail result of users when they take a 
test. Choose between the following options: percent of correct 
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answers, points gained, number of correct answers, and number 
of slides viewed. 

Due to SCORM specifications, take the following notes when the 
SCORM option is selected: 

• In SCORM 1.2, the raw score submitted to LMS is a 
normalized value in range [0, 100]. 

• In SCORM 2004, the raw score submitted to LMS is a 
normalized value in range [0, 100] if the first condition (percent 
of correct answers) is chosen. Otherwise, it is an absolute 
value. 

Content 

These following options are applicable to slide background images, audio, and text. 
Regarding multi-state objects, the object state will be retained when users move between 
slides. For example, if users finish one slide with a button in the Pressed state and move 
to the next slide, when they go back to this slide, the button is still in the Pressed state. 

Include WebM & 
Ogg 

Allow viewing HTML5 content on browsers which don’t support 
MP4 and MP3 but support WebM and Ogg. 

Enable Visual Focus 
Indicator 

Display an outline around the object having focus. 

Disable [Click or Tap 
to Unmute] 
Notification 

Some browsers don’t allow content containing audio that plays 
automatically without the user interaction. In that case, the HTML5 
player will mute audio to enable autoplay. 

The player will display a message to notify users to click to 
unmute audio. Select this check box to hide the message. 

Embed Fonts  

Embed fonts which are used in content into output using CSS3 
Web Fonts Specification. This makes the content look consistently 
across platforms and devices.Click the Details button to select the 
fonts to embed.  

JPEG Quality (%) Applicable to JPEG format only. This option specifies the quality 
of the images that are exported to JPEG format. The higher the 
quality, the larger the output file size.  

PNG Optimization Applicable to PNG format only. This option specifies the relative 
compression levels (none, low, normal, high, ultra). The higher the 
compression level, the smaller the output file size, and the longer 
it takes to export. 

Audio Bit Rate Specify the audio bit rate in the output. The higher value, the 
higher audio quality and the larger output file size. 

Video Quality (%) Specify quality for videos in the output. The higher value, the 
higher video quality and the larger output file size. 

Output 

Location Specify the location where the output will be saved. 
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Click the Setting button to open the following dialog and specify further output options: 

 

• Project ID: An identifier for each project. This will be used to identify different projects 
if multiple projects are embedded within the same page. 

• Player: Location for storing HTML5 player script and CSS files. 

• Project Resources: Location for storing project images, audio, and video 

• Index Resources: Location for storing index page images. 

• File Name Prefix: File names of project related files such as resources and project 
CSS and JavaScript files will begin with this prefix. This option may be used in the 
scenario that the system needs putting files of multiple projects into one folder. 

• Restore Defaults: Discard all changes and go back to the default settings. 

Operation Modes 

ActivePresenter allows you to run interactive presentations in four operation modes: 
Demonstration, Tutorial, Practice, and Test. These modes are useful when you create HTML5 
content such as interactive software simulations and quizzes.  

• Demonstration: In this mode, the task will be shown as a demonstration for users. It 
won’t be interactive but only viewable.  

• Tutorial: This mode lets users do the task. However, users are moved to the next 
action only after they have performed the previous action correctly.  

• Practice: This mode gives users a chance to try the task themselves. They can 
practice what they’ve learned without formally joining the test. There’s also no time and 
attempt limit.  

• Test: This mode brings users to the real test. They have to complete the task in a 
limited time and number of attempts.   

When creating HTML5 content, you have to choose operation modes for objects. If not, 
you can’t see them when in the output. 

The table below shows the difference between four operation modes: 
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Function Demonstra 
-tion Mode 

Tutorial 
Mode 

Practice 
Mode 

Test Mode 

The simulation automatically runs 
based on the time you have set 
for objects and slides. 

    

The presentation jumps to the 
next slide when the current slide 
comes to the end. 

    

If the toolbar is available, users 
can control the presentation such 
as navigate to a certain slide, 
pause/resume the simulation. 

    

The simulation supports 
interactive capability through 
mouse and keyboard. 

 

   

ActivePresenter assesses user 
response and executes 
associated actions which you 
have defined before. 

 

   

It has options to create the report 
of user result and send it to a 
specified HTTP address. 

  

  

The simulation displays 
interactive hidden objects when 
users fail to execute associated 
actions in predefined time. 

N/A 
  

 

Authors can limit the maximum 
time which users are allowed to 
complete the test. 
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LMS Reporting 

 

The eLearning Options section allows you to package the content to one of the following 
standards for uploading to LMS: SCORM 1.2, SCORM 2004, and Experience API (xAPI). 

ActivePresenter stores the value of a variable in suspend data on the LMS. The LMS will 
resume from the point where users left, allowing you to restore variables when users 
relaunched the course on the LMS.  

Option Description 

SCORM 1.2 and SCORM 2004 

Identifier Specify a name used by the LMS to identify different manifests 
(this value is generated automatically by ActivePresenter but you 
can change it if needed). 

Version  Specify a version that can be used to differentiate manifests with 
the same identifier.  
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Organization Title Specify a title for the organization which this item belongs to. 
Although ActivePresenter automatically generates this value from 
project name, you can change it if needed. 

Item Title The title of your project that is displayed to users viewing the 
project using an LMS. Although ActivePresenter automatically 
generates this value from project name, you can still change it if 
needed.  

Report the score in 
percentage 

Normalize the score in the range 1-100 instead of an absolute 
value. This option is only available in SCORM 2004. Score in 
SCORM 1.2 and xAPI are always normalized. 

Export each 
operation mode to a 
separated package 

Export each operation mode to a separated package instead of 
exporting all operation modes to one package with multiple 
organizations. 

Experience API (xAPI) 

Identifier Specify a name used by the LMS to identify different manifests. 
This value is generated automatically by ActivePresenter but you 
can change it if needed. 

Title The title of your project that is displayed to users viewing the 
project using an LMS. ActivePresenter automatically generates this 
value from project name but you can change it if needed.   

Description The description of your project that is displayed to users viewing 
the project using an LMS. ActivePresenter automatically generates 
this value from project description but you can change it if needed.  

Export each 
operation mode to a 
separated package 

This option is always selected by default when exporting to 
Experience API. 

Additional Reporting 

Besides LMS reporting, you can use additional methods to track user activities. These 
methods are useful when you use some alternatives to deliver and track your course, such as 
Google Spreadsheet. The report is in either XML or JSON (JavaScript Object Notation) format. 
In fact, you can use both LMS reporting and these additional methods at the same time if you 
need. 

To enable additional reporting, in the Export To HTML5 dialog, switch to the Reporting tab 
> Additional Report > Method.  

Option Description 

Method Choose between the following options:  

• No Report: Do not send the report. 

• HTTP: Send report through the HTTP request. 

Format Choose between XML and JSON (JavaScript Object Notation). 
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HTTP Address  This is the HTTP address of a server side script that will process 
the report data (the data is in either XML or JSON format). 

Content of Report 

The report can be formatted in various ways but the content generally consists of the following: 

Property Description 

Name Presentation name (also the project name). 

Description Presentation description (also the project description). 

Date The local time (based on the user computer date and time setting) 
when the report is created. 

UserID Identity of the user who takes the practice or test. When the user 
logs in to take the test, the server side script should store a cookie 
which its name is "userid". If no "userid" cookie found, the user will 
be prompt to input his/her identity before sending the report. 

TotalTime Duration in seconds in which users take the practice or test. 

SlideCount Number of slides in the presentation. 

TakenSlide Number of slides which the user has taken. 

TotalInteraction Number of interactions in the presentation. 

TakenInteraction Number of interactions which the user has taken. 

Correct Number of interactions which users perform correctly without any 
help. 

Score Score (marks) users gain through the practice or test, only correct 
action gains points. 

MaxScore Maximum score which users can gain in the practice or test (by 
taking correctly all slides). 

Percent Score over MaxScore in percentages (Score/MaxScore*100). 

Result The practice or test assessment based on the pass condition. 

• For human readable: Passed or failed 

• For computer: True or false 

Users pass the practice or test if their results are greater than or 
equal the minimum required result. The result can be points which 
users gain, points gained over maximum points in percentages, or 
number of correct answers.  
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Details Detail result for each slide and interaction which is called the 
interaction data record. 

The Details section of the report data contains an array of the interaction data record. Each 
interaction data record contains the following information: 

Property Description 

SlideIndex The index of the slide which contains the interaction (start from 1). 

ReportID The ReportID of the interaction. 

Attempts The number of actions that users have tried. 

Score Score gained when users interact with interactions. 

MaxScore The maximum score that users can get when interacting with interactions. 

Result A string represented in the output language of the presentation. It can be 
one of the following values: 

• Correct 

• Incorrect 

• Incomplete 

• (Empty) 

Type Type of the interaction represented in the output language of the 
presentation. There are the following interaction types: 

• Mouse Click 

• Key Stroke 

• Text Box 

• Drop Area 

• True/False 

• Multiple Choice 

• Multiple Response 

• Essay 

• Fill in Blank 

• Fill in Multiple Blanks 

• Sequence 

• Drag-n-Drop 

• Rating Scale (Likert) 

LearnerRes
ponse 

Users’ responses.  

Some examples for each interaction type: 

• Mouse Click:  
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o Left click 

o Click outside 

o Right click 

o Left double-click 

• Key Stroke:  

o A 

o Ctrl+A 

o Ctrl+Shift+Alt+A 

• Text Box:  

o This is a sample text 

• Drop Area:  

o Drop_area_report_id[.]Draggable_report_id 

• True – False: 

o Answer1_report_id 

• Multiple Choice: 

o Answer1_report_id 

• Multiple Response: 

o Answer1_report_id[,]Answer2_report_id 

• Essay:  

o This is a sample text 

• Fill in Blank: 

o This is a sample text 

• Fill in Multiple Blanks: 

o Answer1_report_id[.]text_value1[,]Answer2_report_id[.]text_value2[
,]Answer3_report_id[.]text_value3 

• Sequence: 

o Answer1_report_id[,]Answer2_report_id[,]Answer3_report_id[,]Ans
wer4_report_id 

• Drag-n-Drop: 

o Droppable1_report_id[.]Draggable1_report_id[,]Droppable2_report_
id[.]Draggable2_report_id[,] 

• Rating Scale (Likert): 

o Answer1_report_id[.]0[,]Answer2_report_id[.]5 

CorrectResp
onses 

An array of correct responses. The format of a correct response is similar 
to the format of a learner response. 

Report in XML Format 

The report is formatted in XML (Extensible Markup Language) format. Here is an example: 
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<?xml version="1.0" encoding="UTF-8"?> 

<Content> 

 <Report> 

  <Name>Quiz Sample</Name> 

  <Description></Description> 

  <Date>Tue, 10 May 2016 04:15:58 GMT</Date> 

  <UserID>apteam</UserID> 

  <TotalTime>96</TotalTime> 

  <SlideCount>2</SlideCount> 

  <TakenSlide>2</TakenSlide> 

  <TotalInteraction>2</TotalInteraction> 

  <TakenInteraction>2</TakenInteraction> 

  <Correct>2</Correct> 

  <Score>2</Score> 

  <MaxScore>2</MaxScore> 

  <Percent>100</Percent> 

  <Result>Passed</Result> 

  <Details> 

   <Interaction> 

    <SlideIndex>1</SlideIndex> 

    <ReportID>MouseClick1</ReportID> 

    <Attempts>2</Attempts> 

    <Score>1</Score> 

    <MaxScore>1</MaxScore> 

    <Result>Correct</Result> 

    <Type>Mouse Click</Type> 

    <Answers>Left click</Answers> 

    <LearnerResponse>Left click</LearnerResponse> 

    <CorrectResponses> 

     <CorrectResponse>Left click</CorrectResponse> 

    </CorrectResponses> 

   </Interaction> 

   <Interaction> 

    <SlideIndex>2</SlideIndex> 

    <ReportID>KeyStroke1</ReportID> 

    <Attempts>1</Attempts> 

    <Points>1</Points> 

    <MaxPoints>1</MaxPoints> 

    <Result>Correct</Result> 
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    <Type>Key Stroke</Type> 

    <Answers>Space</Answers> 

    <LearnerResponse>Space</LearnerResponse> 

    <CorrectResponses> 

     <CorrectResponse>Space</CorrectResponse> 

    </CorrectResponses> 

   </Interaction> 

  </Details> 

 </Report> 

</Content> 

Report in JSON Format 

The report is formatted in JSON (JavaScript Object Notation) format. Here is an example: 

{ 

 "Name": "Quiz Sample", 

 "Description": "", 

 "Date": "Tue, 10 May 2016 04:32:36 GMT", 

 "UserID": "apteam", 

 "TotalTime": 79, 

 "SlideCount": 2, 

 "TakenSlide": 2, 

 "TotalInteraction": 2, 

 "TakenInteraction": 2, 

 "Correct": 2, 

 "Score": 2, 

 "MaxScore": 2, 

 "Percent": 100, 

 "Result": true, 

 "Details": [ 

  { 

   "SlideIndex": 1, 

   "ReportID": "Question_5", 

   "Attempts": 1, 

   "Score": 1, 

   "MaxScore": 1, 

   "Result": "Correct", 

   "Type": "Fill Multiple Blank", 

   "Answers": "1.quick, 2.jumps, 3.dog", 
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   "LearnerResponse": "1[.]quick[,]2[.]jumps[,]3[.]dog", 

   "CorrectResponses": [ 

    "1[.]quick[,]2[.]jumps[,]3[.]dog" 

   ] 

  }, 

  { 

   "SlideIndex": 2, 

   "ReportID": "Question_6", 

   "Attempts": 1, 

   "Points": 1, 

   "MaxPoints": 1, 

   "Result": "Correct", 

   "Type": "Sequence", 

   "Answers": "1, 2, 3, 4, 5, 6, 7", 

   "LearnerResponse": "1[,]2[,]3[,]4[,]5[,]6[,]7", 

   "CorrectResponses": [ 

    "1[,]2[,]3[,]4[,]5[,]6[,]7" 

   ] 

  } 

 ] 

} 

Transmission of Report 

When the report is sent via HTTP protocol, the POST method will be used. The key is “report” 
and the value is the report content with the format specified when exporting to HTML5 
presentation.  

The server-side script at the HTTP address must handle and process the report. For example, 
suppose that the HTTP address is 

"http://atomisystems.com/reportreceiver.php". 

The following is a trivial sample code in reportreceiver.php file to receive and process report: 

<?php 

if (isset($_POST["report"])) 

{ 

//read report data 

$report = $_POST["report"]; 

//process report, e.g. append to a text file here 

$report_file = fopen("report.txt", "a"); 

if($report_file) 



ActivePresenter User Manual  Version 7.5 

Exporting Projects > Exporting to HTML5 247 

In case that you want to send the report data to a Google Sheets document or an email, you 
can see this tutorial to know how to do it. 

Player Settings 

The player is the interface that appears around the slide content. It has several components 
such as a top bar, a resource menu, a side bar, and a toolbar which holds many navigation 
buttons.  

 

You can make the player look the way you want by toggling its components, modifying each 
one, changing colors and fonts, etc. To customize the player, click the Export tab > Player 
Settings to open the following window. All changes you make will be reflected in the preview 
pane on the right side of the window. 

{ 

fwrite($report_file, $report); 

//separate this report from others 

fwrite($report_file,"\n\n---------\n\n"); 

fclose($report_file); 

} 

} 

?> 

https://atomisystems.com/elearning/send-quiz-report-google-sheets-email/
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General Settings 

General  is the first tab in the Player Settings window. This tab allows you to choose and 
customize the skin, add information of the author, and change many general and color 
parameters for the player.  

a. Customizing the Skin 

ActivePresenter provides you with several skins to define the layout of the player. Each skin 
comes with a variety of presets for you to choose and make changes if you want. In addition, 
you can create your own custom preset and reuse it across projects. Do the following: 

 

• Choose skins: Click the Skin combo box and choose the desired skin from list. 

• Choose presets: Click the Preset combo box and choose the desired preset from list. 

• Modify presets: Select a preset, then go to the Parameters pane > Color 

Parameters tab  to modify any color parameter you want. 

• Create new presets: After modifying a built-in preset, click the Save button  next to 
the Preset combo box to save your custom preset for later use. 

• Remove custom presets: Select a custom preset from the Preset drop-down list > 

Remove . You cannot remove built-in presets. 
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b. Adding Author Information 

 

You can display information of the author in the side bar of the player (General tab > 

Parameters pane > General Parameters  > Side Bar). All the information, including author 
name, description, and image, will be displayed at the top of the side bar, above the table of 
contents (if any).  

Do the following: 

 

• Add author names: Enter the name of the author in the Name text box. 

• Add author descriptions: Enter the description of the author in the Description text 
box. 

• Add author images: Choose an image from your project  or your computer  to 

be the author image. If you no longer need an author image, remove it by clicking . 

c. Changing General Parameters 

You can customize the parameters for each operation mode separately or for all the modes 
at once. Choose the operation mode you want by clicking the Operation Mode combo box. 

Later, if you want to go back to the original settings, click the Restore Defaults button . 
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1. Content section allows you to customize common properties of the player. 

 

Option Description 

Border Width Specify the border (in pixels) for the content and the side bar. 

Display Mode Decide how the content will be displayed in the output.  

• Actual Size: Display the content in the actual size. Users can 
use scroll bars to view the portions of the content that extend 
beyond the player. 

• AutoFit: Automatically scale the content without changing the 
proportion to fit it into the player.  

Player Size Decide how the player will fit the size of the content and the 
window.  

• Fit to Content: The player will wrap to fit the content size. 

• Fit to Window: The player will fit the container or browser 
window. If the content is smaller than the window, more space 
will be added to the gap between the player and the content.  

Navigation Specify the navigation behavior for the presentation using the 
toolbar and the TOC.  

• None: Disable the content navigation so that users cannot 
navigate through the slides.  

• Backward Only: Allow users to navigate through the viewed 
slides.  

• Free: Allow users to navigate freely through the slides.  

Font Specify the font for the player elements, such as presentation title, 
author information, and table of contents.  

Font Size Specify the player font size.  
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2. Side Bar displays the information of the author and the table of contents. 

 

Option Description 

Position Specify the position of the side bar on either the left or right side of 
the content. Select None if you don’t want to display the side bar.  

Width The width of the side bar in pixels. 

Author Information Display the name and description of the author in the side bar.  

Author Image Display the image of the author in the side bar.   

Author Video Display the video of the author in the side bar.  

 

3. Top Bar at the top of the player displays the presentation title. 

 

Option Description 

Show Top Bar Show the top bar of the player. The top bar can display the 
presentation title and the Resources menu button. 

 

4. Table of Contents (TOC) shows the content structure of the presentation and allows users 
to navigate through the presentation. 
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Option Description 

Style Select the display style for the table of contents.  

• None: Hide the table of contents. 

• Overlay: Allow users to use the TOC button in the toolbar to open 
the TOC in an overlay. 

 

• Side Bar: Display the table of contents in the side bar. Use can 
use the TOC button in the toolbar to show/hide the TOC. 

Show Duration Show slide duration in the TOC.  

Show Thumbnails Show slide thumbnails in the TOC.  

Show State Icons Show state icons in TOC entries to indicate the state of slides. The 
current slide is marked with an arrow while the viewed slide is 
marked with a check mark. 

Initially Expand 
Entries 

Expand all levels of the TOC from the beginning. Users can use the 
arrow icon next to an entry to expand/collapse its subentries. 

Auto Scroll to 
Current Entry 

Automatically scroll the TOC to the entry associated with the current 
slide. This ensures the entry of the current slide is always visible to 
users without having to manually scroll the TOC.   

 

5. Toolbar gives users many tools to control the player. 

 

Option Description 

Show Toolbar Show the toolbar at the bottom of the player. 
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Restart Button Show the Restart Presentation button which allows users to reset 
the presentation to the original state and start from the beginning. 

Exit Button Show the Exit button which allows users to exit the presentation. 

First Slide Button Show the First Slide button which allows users to jump to the first 
slide in the presentation. 

Previous Slide 
Button 

Show the Previous Slide button which allows users to go to the 
previous slide. 

Play Button Show the Play/Pause button which allows users to play/pause the 
presentation. 

Speed Button Show the Playback Speed button which allows users to change the 
playback speed of the presentation. 

Next Slide Button Show the Next Slide button which allows users to go to the next 
slide in the presentation. 

Last Slide Button Show the Last Slide button which allows users to jump to the last 
slide in the presentation. 

Progress Bar Show the progress bar which allows users to navigate through the 
presentation when navigation is enabled. 

Volume Bar Show the volume bar which allows users to change the sound 
volume. 

Volume Button Show the Mute/Unmute Audio button which allows users to toggle 
the sound.  

CC Button Show the Show/Hide Closed Caption button which allows users to 
toggle the CC. 

Display Mode 
Button 

Show the Display Mode button which allows user to change the 
display mode (actual size, autofit, full screen). 

Information Button Show the Information button which allows users to view the 
information of the presentation, such as title, author name, 
copyright, and home page. 

TOC Button Show the Show/Hide Table of Contents button which allows users 
to toggle the TOC when the TOC is enabled. 

Side Bar Button Show the Show/Hide Side Bar button which allows users to toggle 
the side bar when the side bar is enabled. 

Resources Button Show the Resources menu button in the top bar which allows users 
to access external content attached to the presentation. 

Slide Markers Show slide markers indicating the duration of slides in the progress 
bar. 
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Playback Position Show the current playback position in the presentation in the 
toolbar. 

Total Duration Show the total duration of the presentation in the toolbar. 

d. Changing Color Parameters 

To change the colors of the player, you can customize the color parameters for each 
operation mode separately or for all the modes at once. Choose the operation mode you 
want by clicking the Operation Mode combo box. Later, if you want to go back to the original 

settings, click the Restore Defaults button . 

You can also customize the color parameters and save the settings as a custom preset. 

 

Option Description 

Content Specify the colors for the background of the border and the page. 

Side Bar Specify the colors for the background and the text in the side bar. 

Table of Contents Specify the colors for the background and the text in the TOC. You 
can specify different colors for the background of  

Toolbar Specify the colors for the background and the text in the toolbar. 

Button Specify the colors for the buttons in the toolbar and the top bar. 

Slider Specify the colors for the progress bar and the volume bar in the 
toolbar. 

Menu Specify the colors for the background and the text in the menus that 
appears when users interact with buttons and controls in the 
toolbar. 

Resources Pane Specify the colors for the background and the text in the Resources 
pane. 
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Table of Contents 

An informative table of contents (TOC) is essential for your presentation as it can give a visual 
overview of the whole presentation and help users easily navigate while viewing. At run time, 
the TOC entry associated with the current slide will be highlighted. You can also choose to 
mark it with an arrow to indicate that the corresponding slide is playing. Meanwhile, a check 
mark can be shown in an entry to indicate that the corresponding slide has been viewed 
completely. During editing, you can enable navigation so that users can click a TOC entry to 
jump to the corresponding slide.  

 

By default, ActivePresenter generates the TOC and shows it in the side bar of the player. 
When viewing the output, users can show or hide the side bar to toggle the TOC. The 
Show/Hide Side Bar button is enabled by default and appears at the bottom-right corner of 
the player toolbar.  

 

Besides showing the TOC in the side bar, you can enable the Show/Hide Table of Contents 
button in the player toolbar and use it to open the TOC in an overlay.  

To organize the TOC, you can change the hierarchy of entries, create new entries, delete or 
hide entries you don’t want. Note that the reorganization in the TOC doesn’t affect the order 
of the slides. Do one or more of the following to reorganize the TOC: 
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• Add entries: Click the  button to add a new entry right above the selected entry. 

• Remove entries: Click the  button to remove a custom entry.  

• Hide entries: Clear the status box to hide an entry. Click the  button to show or hide 
all entries. Note that hiding a TOC entry doesn’t remove a slide from the project. 

• Move entries one sublevel up/down: Click the  button to make an entry one 

sublevel down or the  button to make an entry one sublevel up. 

• Move entries up/down: Click the  button to move an entry before previous or the 

 button to move an entry after the next entry. You can also move an entry by 
dragging it to a new location. 

• Adjust TOC heading style: Click the  button and select a style. 

• Reset TOC to default: Click the  button to go back to the default TOC. In case you 
reorganize slides after creating the TOC, your changes will not be automatically 
updated. Just click this button to reflect any changes.  

Preloader 

By default, ActivePresenter documents preload necessary resources before showing the first 
slide. To show the loading progress, a loading indicator that contains a spinner and a 
percentage sign appears in the center of the screen. The loading indicator also appears 
afterward if buffering takes longer than usual. 

To customize preloader, click the Export tab > Player Settings > Preloader. The loading 
indicator has six editable properties. To adjust their values, you can drag the handle on the 
slider, scroll the mouse wheel, or enter a new value. All changes you make are immediately 
reflected in the preview pane. After customizing, if you want to discard all changes, click 
Restore Defaults to go back to the default settings. 
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• Diameter: Set the diameter of the loading indicator. 

• Density: Set the number of shapes drawn on the loading indicator. 

• Range: Set the amount of the modified shapes in percentages. Specifically, it sets 
what range of the shapes should be scaled and/or faded. The shapes that are out of 
this range will be scaled and/or faded with a minimum amount only. If the range is 0.1, 
every shape out of the range will be scaled and/or faded to 10% of the original values. 
The visually acceptable range value should be between 0.4 and 1.5. The default value 
is 1.0. 

• Speed: Set the speed of the loading indicator animation. This value tells the loading 
indicator how many shapes to skip by each tick. 

• Color: Set the color of the loading indicator in RGB. 

• Shape: Set the type of the loading indicator shapes, namely oval, spiral, square, 
rectangle, and rounded rectangle. 

Resources 

• To give learners access to reference materials and other helpful information, you can 
add external contents to the presentation using this tab. This feature enables users to 
access the printable transcript or downloadable copy of the course content. 
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• Click the  button to add the resource from URL, from the project, or from the 

computer. Click the  button to replace the content that you added, and click the  

button to delete the selected content from the resource. Click the  and  button to 
change the order of the content.  

Player Language 

ActivePresenter provides the ready translated text for the output (name of elements in the 
toolbar and messages) for all supported language through the Player Language editor. If you 
want to modify the translation or add the support for your language, open the Export tab > 
Player Settings > Player Language. 

The editor provides the following properties: 

• Project Language: Display the language of the open project. You can change the 
project language in the Project Properties dialog. 

• Name: Display the text in the current user interface language of ActivePresenter so 
you can know their original meanings. 

• Value: Display the text in the language which is set in the Project Language section 
(if it is supported). You can modify the text in this column by double-clicking each row 
and typing in it. 

• Reset: Restore the original translation of the text. 

HTML5 Preview  

To preview the HTML5 output before actually exporting, click the HTML5 Preview button  
in the Home and Export tab. Click the arrow on the button to select one from four operation 
modes (Demonstration, Tutorial, Practice, Test).  
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Editing Project Properties 

Properties of a project fall in three categories: 

• Properties that you cannot edit from this Project Properties window: Slide size, total 
number of slides, total run time for the presentation, project file size, and the date on 
which the project was created and last modified.  

• Properties that you can edit from this Project Properties window: Author's name and 
any remarks that you want to attach to the project's file (client name, conference detail, 
the type of outputs for this project, etc.).  

• The JavaScript code: It is executed when loading the project. You can use this property 
in the case that you want to extend the capability of HTML5 output. 

To view the project properties, click the ActivePresenter button > Projects > Properties. The 
following window will appear:  
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General Tab 

This tab gives you generic information and settings of the currently editing project. They are 
global settings that affect all slides in your project. However, if a slide already has a 
background image, it won’t be affected. 

• Project Name: Change the name for the project. 

• Description: Give a description for the project. 

• Project Language: Specify the language of editing project. ActivePresenter will use 
the corresponding translation of selected language to display in the output (name of 
elements of toolbar and messages in HTML5) if the language is supported in 
ActivePresenter. For other languages, you can still modify the text in output by using 
Player Language Editor. 

• Project Size: The size of the project slides.    

• Number of Slides: The total number of slides in your project.  

• Total Duration: The total duration of all slides in your project.  

Author Tab 

This tab allows you to enter all details including the author’s information and security. You can 
enter a password for opening the project file in the Security section. Once you set the 
password, you can only open the file if you enter the password. This is useful if you have to 
leave the project file on a public computer. 

Event Tab 

On the Event tab of this window, you can enter the JavaScript code which is executed when 
loading the project 

Making Project Accessible 

ActivePresenter allows you to make your project accessible to people with disabilities. This 
means you can edit your project so that users with disabilities can perceive, understand, 
navigate, and interact with the project outputs. The HTML5 output can be viewed in various 
ways that don’t depend on a single sense or ability. For example, users can navigate with a 
keyboard, not with a mouse only. Also, audio content should be accompanied with closed 
captions for hearing impaired users, text description should be provided for visual contents so 
that screen readers can read out loud for visually impaired users. 

Tips for Creating Accessible Projects 

To create accessible projects, you should always use more than one mean (e.g. text, visuals, 
and sounds) to convey information. 

• For users with visual impairment, add text descriptions or audio equivalents for visual 
objects. For example, provide accessibility text description for video so that you can 
send the information to users through the screen reader. For objects that contain text 
such as shapes, text captions, you should enable the Auto Label property, the 
screen reader will read the text when this object is displayed. If you choose to attach 
audio to the object, don't forget to remove all accessibility text, otherwise voice from 
the screen reader will interfere with the attached sound. 
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• For users with hearing impairment, add text equivalents for audio objects. For example, 
when delivering a narrative audio, it is important to provide captions at the same time. 
You can use closed captions or any other type of objects that can display text, and 
remember to synchronize the text with the audio by using the Timeline pane. 

• For users with either visual or hearing impairment, ensure that users can interact with 
the output using keyboard. For example, enable Focusable property for mouse click 
objects so that users can use the TAB key to navigate between objects, and the 
ENTER or SPACE BAR key to activate it. You can also provide a key stroke object 
that acts as a hotkey for each mouse click object.  

• Enable Accessibility features when exporting to output formats that support 
accessibility. 

Customizing Accessibility Text for Slides 

In ActivePresenter, you can add accessibility text describing each slide for screen readers to 
read aloud when the slide is displayed. Screen readers and accessibility text are useful for 
people with visual impairment. 

 

By default, ActivePresenter uses slide name and description as slide accessibility text. To 
provide different text for screen readers, do the following:  

1. Select the slide that you want to change accessibility text. 

2. In the Properties pane, expand the Accessibility drop-down list. 

3. Clear the Auto Label check box, the Accessibility Text box are now enabled. Type 
text that describes the slide. 

4. When the slide appears, screen readers will read aloud the accessibility text in the text 
box. If you don’t want screen readers to read anything, leave this text box blank. 

Customizing Accessibility Text for Objects 

ActivePresenter supports accessibility text for each object in a slide. By default, accessibility 
text is generated automatically from the text that the object displays, or the object name if it 
doesn’t contain any text. Therefore, the default accessibility text is usually useless for objects 
that don’t contain text, such as video and image.  
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In that case, you should customize the accessibility text to provide sufficient information about 
the object by following steps below:  

1. Select the object that you want to change accessibility text. 

2. Click the Properties pane > Size & Properties tab > Accessibility. 

3. Clear the Auto Label check box, the Accessibility Text box are now enabled. Type 
the description of the object in the text box. 

4. When the object appears, screen readers will read aloud this accessibility text. If you 
don’t want screen readers to read anything, leave this text box blank. 

Localizing Projects 

Localization is the process of adapting a project for use in a specific country, region with a 
particular language, culture, and desired local look and feel. If you are creating a 
demonstration or simulation of a certain application that supports multiple languages, you may 
need to localize your project for each language. With ActivePresenter, you can do it easily 
thanks to the slide background replacement and the text translation features. 

Localizing Process 

Before doing localization, make sure that you have finished editing the original project (usually 
in English). 

To localize your project, do the following: 

1. Export text in your project to XLIFF format. 

2. Translate text in the exported XLIFF file using any tool that supports XLIFF 1.2 (e.g. 
Swordfish Translation Editor). 

3. Replace the original slide backgrounds with the new ones that are captured in the new 
language. 

4. Import the translated XLIFF file into the project of which slide backgrounds have been 
replaced in step 3. 

5. Test the localized version of your project, make sure that all screenshot images are 
replaced, and all text are properly translated and displayed. 

The next sections will describe each step in details. 

Exporting to XLIFF 

XLIFF (XML Localization Interchange File Format) is an XML-based format created to 
standardize the way localizable data are passed between tools during a localization process. 

To export text in your project to XLIFF format, do the following: 

1. Click the ActivePresenter button > Projects > Localize > Export To XLIFF. 

2. In the dialog that appears, select types of text which you want to export for the 
translation.  
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3. Select the Use TMX 1.4b standard compatible tags (<bpt>, <ept>, <ph>) text box if 
your translation tool doesn’t support <g> and <x/> tag. 

4. Enter the output location and file name in the Output File text box. 

5. Click OK to start exporting to XLIFF. 

Replacing Slide Backgrounds 

You should not localize directly in your original project, but in a copied version of the project. 
This section will describe the steps of copying projects and replacing slides.  

Step 1. Create a copy of the original project for the new language. 

1. Copy the project file in File Explorer, or use ActivePresenter button > Save As…. If 
you copy it in File Explorer, make sure it isn’t opening in ActivePresenter. The project 
copied from an open project may be corrupted. 

2. Give the copied project a meaningful name. It is recommended that the project name 
has language code suffice, for example, Skype_es.approj. You can also create a folder 
for the new language and place the copied project there. 

Step 2. Capture a new project for the new language. 

1. Change language preferences and settings for the captured application to display the 
new language, if needed. 

2. Use the same project size (width x height) as the size of the original project. 

3. Name the new captured project a meaningful name. For example, you can name it 
Skype_es_captured.approj. 

Step 3. Open the Slide Background Replacer window to replace slide backgrounds in the 
project copied in step 1 by new ones captured in step 2, or by slides of the new captured 
project. 

1. Open the project copied in step 1 (Skype_es.approj). 

2. Click the ActivePresenter button > Project > Localize, and do one of the following:  
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o Select Replace Backgrounds of All Slides to replace all slides backgrounds with 
slides of the new captured project. Selecting this option will launch the blue 
rectangle and the Replace Slide Backgrounds dialog so that you can capture the 
new project. 

o Select Replace Backgrounds of Selected Slides to replace some selected slide 
backgrounds with slides of the new captured project. Selecting this option will 
launch the blue rectangle and the Replace Slide Backgrounds dialog so that you 
can capture the new project. 

o Select Replace Backgrounds of All Slides From Project and browse the new 
project captured in step 2 (Skype_es_captured.approj) to replace all slide 
backgrounds of the current project. 

o Select Replace Backgrounds of Selected Slides From Project and browse the 
new project captured in step 2 (Skype_es_captured.approj) to replace some 
selected slide backgrounds of the current project. 

Step 4. In the Slide Background Replacer window, arrange new slides on the right in the 
same order as current slides on the left. 
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• To move a slide, drag and drop it to the new position. You can only drag slides in the 
same side (left or right) to change their position.  

• To copy/cut/paste/delete a slide, select it and press the DELETE key. You can also 
right-click it > Delete.  

• If you aren’t sure that a new slide of the new project (on the right) is redundant or not, 
move it to the bottom instead of deleting it. To do that, select the slide and click the 

down arrow button . 

• If a certain slide is required in the new language but not available in the original 

language, select it and click the Copy To Left button . This moves the selected slide 
from the right to the left. 

• If you don’t want to change a certain slide in the left (e.g. the introduction slide), select 

it and click the New Placeholder button . This insert a placeholder slide into the 
right.  

Step 5. Click the OK button in the Slide Background Replacer window to replace slide 
backgrounds.   

Importing from XLIFF 

After translating text and replacing slide backgrounds, you need to import the XLIFF file back 
to the project of which slide backgrounds are replaced. ActivePresenter will replace the current 
text in your project with the corresponding text in the translated XLIFF file. 

• Open the project that has been replaced slide backgrounds. 

• Click the ActivePresenter button > Projects > Localize > Import From XLIFF > 
browse the translated XLIFF file. 

• Verify imported text on each slide, adjust the object position and size if necessary. 

Active Window 

When creating a video demo or simulation to demonstrate how to work with an application or 
software (e.g. Microsoft), you will want to capture only a specified window sometimes (e.g. a 
confirmation dialog). ActivePresenter can automatically detect the area that you want to 
capture and save the information to captured slides through the active window feature. 

To view the active window, do one of the following:  

• Click the Slide tab > View Active Window . 

• Right-click the slide on the Canvas > View Active Window.  

The following figure shows an active window area (in the red dashed border) in a captured 
slide: 
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In some certain circumstances, the active window area detected while capturing doesn’t fit the 

dialog/window. You can modify this area by opening the Slide tab > Edit Active Window  
, or right-clicking the slide on the Canvas and select Edit Active Window. 

This enables the Edit Active Window Area tool. Then, you can resize the active window by 
dragging the red dashed border.  
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Canvas  

The Canvas in the center of the workspace displays all slide contents. It can also be called 
the working window.  

When your project has many slides, the Canvas shows contents of the selected slide. All 
project creating and editing are visually done here. This means that you can view all changes 
of objects you’ve made from other panes (Properties pane, Timeline pane, etc.). 

• With a blank project, the Canvas displays the blank slide. 

• With a recorded project, the Canvas displays the recorded videos/slides along with all 
annotations added. 

• With a created project, the Canvas shows the slide with all of its contents (quizzes, 
shapes, images, videos, etc.). 

Changing Canvas Color 

By default, the Canvas has a light gray color. You can change its color by clicking the 
ActivePresenter button > Preferences > Canvas Background Color, click the color picker 
and select a color.  

When you change the Canvas color, the slide’s color isn’t affected. If you want to change the 

color for slides, click the Design tab > Background Styles .  

See Slide Properties to know more in details about slide’s properties.  

Zooming Canvas  

During the project editing, chances are you need to zoom in and zoom out the Canvas to make 
the editing more easily. Regardless of how much you are zooming in/out the Canvas, when 
you preview the slide, the content automatically fits the Canvas. This allows you to view the 
content of the entire slide. When the preview is completed, ActivePresenter goes back to the 
previous zoom scale.  

With this feature, you don’t have to click the Zoom Fit  button each time you preview the 
content, which saves you much time in project editing. 

To zoom in/out the Canvas, do one of the following: 

• Drag the Zoom slider at the bottom-right corner of the application window. 

Drag it to the right or left to zoom in or zoom out the Canvas respectively. 

• Click the View tab > Zoom  > select a preset zoom level from the Zoom dialog that 
appears, or enter a value in the Percent spin box. 

• Place the mouse inside the Canvas area > hold down CTRL while scrolling the mouse 
wheel up or down to zoom in or zoom out the Canvas respectively.  

To automatically fit the Canvas zoom level, do one of the following: 

• Click the Zoom Fit button  next to the Zoom slider. 
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• Click the View tab > Zoom Fit . 

This automatically adjusts the zoom level to fit the space of the Canvas.  

Canvas Snapping  

Canvas snapping lets you align different objects and elements more easily and precisely. To 

turn the snap mode on, click the View tab and click Canvas Snapping .  

When the snap mode is on, as soon as a moving “snappable” element comes in the vicinity of 
another “snappable” element, it will make a tiny jump to match the edge of each other. Vertical 
or horizontal orange lines or both will appear to visualize the alignment. 

Timeline Pane  

Timeline Overview 

A timeline defines how multiple objects in slide show or hide against time. By default, each 
slide has a main timeline which is run automatically when entering slide. You can add more 
timelines into a slide. These added timelines called interactive timelines since they can only 
be run by an action. If you are working with a video project, you just need to work with main 
timeline while working with interactive presentation, you may need to use interactive timelines. 

The Timeline pane is used to manage timelines and edit each timeline. You can do the 
following tasks in the Timeline pane:  

• Edit audio/video objects (split, join, change volume/speed, insert time, etc.). 

• Edit the object timing and animations. 

• Play slides and record your commentary in real time.  

• Preview slides. 

• Add, remove, or rename timelines. 

 

Managing Timelines 

In ActivePresenter 7, you can create and manage multiple timelines simultaneously with the 
Multiple Timelines feature. You can add more or remove timelines when needed.  

• Select a timeline: Click the Timeline list box and select one of the existing timelines 
from the drop-down list.  

• Add a timeline: Click the Timeline list box and select Add Timeline. The new timeline 
will be created with an auto generated name (Timeline N). The newly created timeline 
will be automatically chosen for editing.  You can add more than one timeline.  
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• Remove a timeline: Click the Timeline list box, and select the timeline that you want 
to remove, then click Remove Timeline. You cannot remove the main timeline.  

• Rename a timeline: Click the Timeline list box, and select the timeline that you want 
to rename, then click Rename Timeline. Enter a new name in the dialog and click 
OK.  You cannot rename the main timeline.  

Using Multiple Timelines 

To use multiple timelines, do the following:  

1. Add timelines.  

2. Rename added timelines to a more meaningful name.  

3. Add animations to objects. To add animations to objects in added timelines, select 
the object from the Canvas or Selection pane. Then, click the Animations tab and 
select entrance and exit effect from the effect gallery. 

4. Use events - actions to start/pause/continue the added timelines.  

Object Time Bars 

The time bar of an object represents its existence along the time axis.  

 

As you can see from the time bar of Shape 4 in the screenshot above, Shape 4 will appear on 
the Canvas at the 5th second after the slide starts to play. The shape will disappear at the 15th 
second, which means its duration is 10 seconds. The length of the object time bar represents 
its duration.  

The shape has animation effects which can be realized by the green and red bar placed inside 
the object time bar. The green-bar’s length indicates the duration of the entrance effect while 
the red-bar’s length indicates the duration of the exit effect.  

Though there are many kinds of objects in ActivePresenter, not all of them have time bar: 

• Sub-objects of composite objects don’t have time bars. They use the timing values 
from the top-level parent.  

• Background images don’t have time bars because they remain unchanged. You 
cannot vary their properties over time. 

• The object time bar is only available in main timeline since it takes a role for audio/video 
editing functions.  

Initially Hidden Objects 

We can set the initial state of an object as hidden, so it can only be shown by an action or an 
interactive timeline. The initially hidden object is represented in the timeline as follows: 
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You cannot change the time bar of initially hidden object. To change the initially hidden state, 
just right-click object and select Initially Hidden. You can also change this option in the 
Properties pane > Timing section. 

By default, some types of messages such as Correct Message, Incorrect Message are initially 
hidden objects. 

Changing Object Timing and Duration 

The timing and duration of an object is easy to adjust by using its time bar. The left-side edge 
of the time bar is the start point, and the right-side edge of the time bar is the end point of the 
object.  

• Changing the start time of objects: Hover the mouse over the start point of the object 
time bar until the mouse turns to a double-headed arrow, drag it horizontally to change 
its start time.  

 

• Changing the end time of objects: Hover the mouse over the end point of the object 
time bar until the mouse turns to a double-headed arrow, drag it horizontally to change 
its end time.  

 

• Moving objects in the timeline: Hover the mouse over the object time bar until the 
mouse turns into a four-way arrow, drag the bar horizontally, and drop it wherever you 
want.  

 

You can move multiple objects as well as change their start/end points simultaneously 
by selecting multiple of them, then moving them together. To select multiple objects, 
hold down CTRL or SHIFT while clicking object time bars or clicking object names in 
the timeline.  

To select contiguous objects, click the first object, then hold down CTRL while clicking 
the last object, all the objects between these two objects will be selected. 

Putting Multiple Objects in a Line  

Each line in the timeline can contain multiple objects which are displayed sequentially. Thanks 
to that, you can easily organize and track their timing and duration.  

Objects in a line have the successive z-order. This means the object on the left has a smaller 
z-order in comparison with the one on the right. You cannot swap the z-order between two 
objects in a line without changing their start time.  
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To move an object along its current line, select the object, then drag it sideways and drop it to 
the desired position.  

If the object is between two other objects, you can only move it within the available space 
between them. If the object is at the end of the line, the slide duration will be extended when 
you drag the object to the right and reach the end point of the slide duration.  

To move an object to a new line, do one of the following: 

• Select the object and drag it upward or downward to the new line. You can only drop 
the object in the line which has enough available space between two objects for it. If 
the object is placed at the end of the line, and the duration of the object is greater than 
the available duration, the Slide duration will be automatically extended to contain it.  

You can move multiple objects together sideways, but you cannot move them up/down 
simultaneously to the new line.  

• When there are at least two objects in a line: Right-click the object > Move Up/Down 
into a New Line. In this case, ActivePresenter will create a new line containing the 
object.  

Inserting Objects Using Playhead 

Note that the following description doesn’t apply for cursor path, closed caption, and zoom-n-
pan.  

When you insert an object with the present of the Playhead in the timeline, the object will be 
placed at the Playhead position. The start time of the object is the current time of the Playhead.  

If there are any existing objects in a line and the duration of the newly inserted object is smaller 
than the line duration, the new object will be placed before them in the same line.  

If there are any existing objects, and the duration of the newly inserted object is larger than 
the line duration, the new object will be placed in the other line and above them in the timeline, 
as long as the new line doesn’t contain any object that is overlapped in time with it.  

When you insert an object without the Playhead presented in the timeline, the start time of the 
object is set to 0, and its duration is stretched to the end point of the slide. The new object will 
also be placed above existing objects in the slide.  

Timeline Snapping 

With the snap mode in ActivePresenter, you can align different objects more easily and 
precisely in the timeline. When the snap mode is on, as soon as a moving “snappable” element 
comes in the vicinity of another “snappable” element, it will make a tiny jump to match the 
timestamp of the other element.  

The snap mode applies to the following elements: 

• In ruler area: Playhead, start marker and end marker of the range. 

• In the time bars of objects: Starting and ending edge, all markers inside the object 
time bar. 
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• Others: Start and end point of the slide.  

To turn the snap mode on, click the View tab > Timeline Sapping . 

Below are some notes when using the snap mode: 

• The “other element” may be anywhere in the timeline: Right from the ruler to the lowest 
object's time bar. The vertical separation between the elements doesn’t matter at all. 

• You may not be dragging the “snappable” element itself. For example, when we drag 
a time bar of an object, all “snappable” elements in the bar are moving simultaneously. 
Any of these elements can snap to another snappable element. 

• You can temporarily disable the snap mode by pressing CTRL when dragging the 
element. 

When a snapping takes place, ActivePresenter shows an orange vertical line at that point of 
time in order to draw your attention. This helps you to synchronize the dragged elements 
precisely with other elements in the timeline. Now it is up to you whether to drop the dragged 
element there or keep dragging. 

Timeline Toolbar and Productivity Tips 

Icon Command Hotkey Function 

 Add Timeline 

 

Add a timeline. Additional timelines are 
triggered using actions. 

 Remove Timeline 

 

Remove the current timeline. You 
cannot remove the main timeline. 

 Rename Timeline 

 

Rename the current timeline. You 
cannot rename the main timeline. 

 
Single Slide/All 
Slides 

 

View the current slide or all slides in 
your project. The All Slides mode shows 
all slides in the timeline, which is useful 
to see the objects that span across 
multiple slides. 

 
Preview SPACE BAR Switch the control to play, pause, or 

resume the preview, starting from the 
Playhead position. You can also right-
click the Canvas > Play Preview. At the 
end of the preview, the Playhead 
returns to the start marker of the range. 

In addition, click the arrow next to the 
button and choose the following options: 

• Preview all: Preview all slides in 
your project, from the first to the last. 

• Preview from current slide: 
Preview the current slide and its 
succeeding slides. 
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Stop 

 

Stop the preview if the timeline is 
playing. Otherwise, clicking this button 
clears the selected range. 

 
Record Narration CTRL+SHIFT+R Record audio while playing the slide 

simultaneously. To stop recording, click 

the Stop button . 

 
Zoom Fit Timeline  Fit the entire slide duration into the 

available pane width. 

 
Zoom Out Timeline CTRL+MOUSE 

DOWN 
Reduce the time scale of the timeline. 

 
Zoom In Timeline CTRL+MOUSE 

UP 
Expand the time scale to see more 
details. 

 
Cut Range CTRL+SHIFT+X Cut the selected range and place it on 

the clipboard. 

 
Copy Range  CTRL+SHIFT+C Copy the selected range and put it on 

the clipboard.  

 
Delete Range CTRL+DELETE Delete the selected range. 

 
Crop to Range SHIFT+DELETE Delete everything outside the selected 

range. 

 
Insert Time 

 

Insert a period of silence into the 
selected audio or freeze the frame of 
the selected video at the Playhead 
position. 

 
Split Audio/Video 
Objects 

 

Split the selected audio/video at the 
Playhead position. 

 
Join Audio/Video 
Objects 

 

Join the selected audio/video objects. 

 
Change Playback 
Speed 

 

Speed up or slow down the selected 
range of the audio/video. 

 
Insert Blur Area  

 

Insert a blur area into the selected 
video.  

 
Adjust Volume 

 

Adjust the relative volume of the 
selected range of the audio/video. 

 
Audio Fade In 

 

Add a fade in effect to the selected 
audio.  

 
Audio Fade Out 

 

Add a fade out effect to the selected 
audio. 
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Audio Noise 
Reduction 

 

Reduce background noise from the 
selected audio. 

 
Audio 
Normalization 

 Normalize audio throughout a project for 
consistent volume across all slides. 

 
Insert Caption 

 

Insert a closed caption (CC) into a slide. 

 
Split Slide 

 

Split the slide at the Playhead position.  

 
Go to Previous 
Keyframe 

 

In editing blur effects, go to the previous 
keyframe. 

 
Add/Remove 
Keyframe 

 

In editing blur effects, add or remove a 
keyframe. 

 
Go to Next 
Keyframe 

 

In editing blur effects, go to the next 
keyframe. 

Below are hotkeys you can use to speed up your work in the timeline. Only some of them are 
customizable using the Preferences dialog > Hotkeys tab.  

Hotkey Function 

HOME Move the Playhead to the beginning of the timeline. 

END Move the Playhead to the end of the timeline. 

LEFT ARROW If there are no selected objects, move the Playhead to the 
left. Otherwise, move the selected objects to the left. 

CTRL+LEFT ARROW Same as above, but 10 times faster (the CTRL key is x10 
accelerator). 

RIGHT ARROW If there are no selected objects, move the Playhead to the 
right. Otherwise, move the selected objects to the right. 

CTRL+RIGHT ARROW Same as above, but 10 times faster (the CTRL key is x10 
accelerator). 

[ Move the Playhead to the start marker of the selected 
range. 

] Move the Playhead to the end marker of the selected 
range. 

SHIFT+[ Set the start marker of the selected range at the Playhead 
position.  

SHIFT+] Set the end marker of the selected range at the Playhead 
position. 
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SHIFT+LEFT ARROW If there are no selected objects, move the start point of the 
range to the left. Otherwise, reduce the duration of the 
selected range. 

CTRL+SHIFT+LEFT 
ARROW 

Same as above, but 10 times faster (the CTRL key is x10 
accelerator). 

SHIFT+RIGHT ARROW If there are no selected objects, move the end point of the 
range to the right. Otherwise, increase the duration of the 
selected range. 

CTRL+SHIFT+RIGHT 
ARROW 

Same as above, but 10 times faster (the CTRL key is x10 
accelerator). 

SHIFT+MOUSE UP/DOWN Scroll horizontally the timeline. 

CTRL+SHIFT+X Cut the selected range and place it on the clipboard. 
(customizable) 

CTRL+SHIFT+C Copy the selected range and put it on the clipboard. 
(customizable) 

CTRL+DELETE Delete the selected range. (customizable) 

SHIFT+DELETE Delete everything outside the selected range. 
(customizable) 

CTRL+SHIFT+R Record audio while playing the slide simultaneously. 
(customizable) 

Properties Pane 

The Properties pane is where you can view and change all common properties of selected 
objects or slides.  

 

There are many tabs in the Properties pane: Style & Effects, Size & Properties, 
Interactivity, Audio, Media, and Slide Properties tab.  
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There are many sections in each tab. Each section displays several properties which are 
related to each other. You can freely expand or collapse any section by clicking the section 
title. You can select multiple objects or slides to change their properties simultaneously. 

Style & Effects Tab 

The Style & Effects tab contains object’s properties in terms of fill, line, and shadow so that 
you can customize them. Not all of object types have this tab. For example, an audio object 
doesn’t have this tab.  

Fill Section 

In this section, you can customize the background of the object and create your own object 
style.  

 

a. No Fill 

The object's background becomes transparent (no solid color or gradient of colors). 

b. Solid Fill 

Fill the shape with a single color. To fill a shape with a single color, click the color picker > 
select a color > change the color Opacity by dragging the slider or entering a number in the 
Opacity spin box.  

c. Gradient Fill 

Fill the shape with a gradient of colors. 
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The Gradient Strip (3) is at the heart of the controls. It shows a live sample of the gradient, 
and lets you make changes to it in a visual manner. 

Choose between Linear and Radial gradients using the Gradient Type drop-down list (1). 

• Linear: Shades vary in a straight direction. 

• Radial: Shades are in concentric circles. 

Define the Transform (2) of the gradient using the spin boxes or dragging the sliders, as 
shown below:  

• Angle: Gradient Rotation. This option is available only if you select Linear gradient 
type. 

• Offset X (%): X-offset from the top corner (range from -100 to 100, default value is 0). 
When you drag the bar of the Offset X slider to the right or increase the value in the 
spin box, the gradient stops will move to the right of the gradient correspondingly, and 
vice versa. 

The closer a gradient stop offset value is to -100, the closer the color is to the start of 
the gradient. On the other hand, the closer a gradient stop offset value is to 100, the 
closer color is to the end of the gradient. 
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• Offset Y (%): Y-offset from the top corner (range from -100 to 100, default value is 0). 
Note that this slider is only activated when you select the Radial Gradient type. When 
you drag the bar of the Offset Y slider to the right or increase the value in the spin box, 
the gradient stops of the radial gradient will move downward, and vice versa. 

The closer a gradient stop offset value is to -100, the closer the color is to the start of 
the gradient. On the other hand, the closer a gradient stop offset value is to 100, the 
closer color is to the end of the gradient. 

• Scale X (%): Gradient horizontal scale (range from 10 to 250, default value is 100). 
When you drag the bar of the Scale X slider to the right or increase the value in the 
spin box, the horizontal radius of the radial gradient (Radial Gradient type), or the width 
of the linear gradient colors (Linear Gradient type) will be increased correspondingly, 
and vice versa. 

• Scale Y (%): Gradient vertical scale (range from 10 to 250, default value is 100). Note 
that this slider is only activated when you select the Radial Gradient type. When you 
drag the bar of the Scale Y slider to the right or increase the value in the spin box, the 
vertical radius of the radial gradient will be increased correspondingly, and vice versa.  

The triangular “stops” at the bottom of the Strip show how many colors are used to compose 
the gradient. You can click any stop to make it active and drag it along the Strip. An active 
stop has a red border. Then, use control boxes (5), (6), (7) to edit the properties of the active 
stop.  

To add more stops, click anywhere in the Strip (3), the new stop will be added at the point that 

you click. Alternatively, click the Add button  (4) to get the same result. After that, select a 
new color for the stop by clicking the color picker (6), then change its opacity if needed (7).  

To delete any stop, select it and click the Remove button  (4). 

d. Image Fill: This option allows you to fill the shape with an image. 

 

The controls are as follows: 

First, select how the shape is to be filled (1). 

• Tile: The image will be replicated in x- and y-axis to fill up the space. If the image is 
larger than the shape, it will be clipped. 

• Stretch: The image will be stretched in height and/or width to fill up the available 
space. If the image is larger than the shape, it will be rescaled to fit the available space. 
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Next, select an image either from project or your file system (2). 

Line Section 

In this section, you can customize the look and feel of a line by changing its width, line style, 
cap type, and join type.  

• No Line: There is no outline for objects at all.  

• Solid Line: This part allows you to customize the line border of the object.  

 

You can set the following properties for a solid line: 

• Line Width: Change the width of the line (in pixels) by entering a value in the Width 
spin box or clicking the up/down arrow of the spin box.  

• Cap Type: This property matters only in an open curve, where you can see the end of 
a line. You can let the end of an open shape have either a round or square cap type.  

o Round: The end of the line is capped with a round shape. 

o Square: The end of the line is capped with a square shape.  

• Join Type: You can change the type of the join where two lines intersect with each 
other.  

o Round: The corners where two lines connect are rounded.  

o Bevel: The corners where two lines connect are cut off at a 45-degree angle.  

o Miter: The corners where two lines connect are squared off.  

• Dash Pattern: Solid/dot/dash/dot-dash. 

• Arrow Type and Size: These properties are only available for Line and Arrow shape. 

• Color: Change the color of the line. 
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• Opacity: Adjust the opacity of the line by moving the slider or entering a number in the 
Opacity spin box (255 = fully opaque). 

Shadow Section 

This section lets you customize the shadow of the object.  

 

• No Shadow: The shape has no shadow. 

• Custom Shadow: Customize the shadow of the object.  

o Presets: Choose one of the presets.  

o Blur Radius: Set the blur radius for the shadow. The larger the radius, the more 
diffused the shadow.  

o Angle: Angle is measured clockwise, with x-axis as reference. 

o Distance: Set the shadow length distance from the shape. 

o Color: Select a color for the shadow. 

o Opacity: Adjust the opacity of the shadow by moving the slider or entering a value 
in the spin box (255 = fully opaque). 

Size & Properties Tab 

Timing Section 

This section defines when and how the object start/stop displaying in the presentation.  

• Start Time: The start time of the object (vis-a-vis start time of the slide). 

• Duration: The duration in which the object will be displayed in the presentation.  

• Initially Hidden: Hide the selected objects until they are called by an event. See 
Initially Hidden Objects for more information.  

• Show to the End of Slide: The object will be shown until the end of the slide. If you 
select this check box, then change the object duration either by entering a value in the 
Duration spin box or dragging the object time bar, the check box will be automatically 
cleared.  
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Transform Section 

This section defines the size and position of the frame that is used to define the shape. 

• Left: Left edge of the frame. 

• Top: Top edge of the frame. 

• Width: Width of the frame. 

• Height: Height of the frame. 

• Rotation: Rotate the object by specified degree in slide coordinates. The rotation 
center is the center point of the frame that is used to define the shape. 

• Lock Aspect Ratio: Keep the ratio between the width and the height of frame 
unchanged when resizing the frame. 

Text Margin Section 

This section defines the minimum margin between the frame and the text inside it. 

• Left: Minimum margin on the left side. 

• Right: Minimum margin on the right side. 

• Top: Minimum margin on the top side. 

• Bottom: Minimum margin on the bottom side. 

• AutoFit Text: When this option is selected, the frame automatically changes its size 
to fit the text. 

Group Layout Section 

Group layout allows you to define the layout of the object group.  

The Group Layout section displays when you work with the answers of the question or a 
group of objects. In case of the question, the answer part is considered as a group of text box 
objects.  

Note: You cannot change the layout for an essay or a fill in blank question. 

• Mode: Select between None and Grid.  

o None: Allow you to freely change the size and position of any object of a group by 
dragging it. 

o Grid: The object position is fixed and you cannot change the position/size for each 
object separately. You can only change the position/size for the whole group of 
objects together. 

• Horizontal Spacing: The horizontal space between object columns. 

• Vertical Spacing: The vertical space between object rows. 

• Advanced Settings…: Click to open the Group Layout Advanced Settings dialog, 
which lets you adjust proportion and alignment of object columns and rows. 

Show in Mode Section 

This section allows you to select the modes in which the object will be visible by selecting the 
check boxes (Demonstration, Tutorial, Practice, and Test).  
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Accessibility Section 

This section defines properties that make the object accessible to users with disabilities when 
viewing the project output. 

• Text Selection: Allow users to select the text in the object in the HTML5 output. 

• Auto Label: Generate accessibility text automatically from the text that the object 
displays, or from the object name if it doesn’t contain any text. If you clear this check 
box, type accessibility text in the below text box. When the slide appears, screen 
readers will read aloud the accessibility text in the text box. If you don’t want screen 
readers to read anything, leave this text box blank. 

Cursor Section 

This section only appears if your project has a cursor path (e.g. in Software Simulations).   

Properties Function 

Cursor Image Change the cursor shape. 

Position Change the position for each dot in the dotted line of the cursor path. 

Timing Change the timing of the cursor movement.  

Start Duration The duration which is counted from the beginning point of the cursor 
segment (the time when the cursor appears) to the point when the 
cursor starts moving. During this time, the cursor has no movement.  

Stop Duration The duration which is counted from the point when the cursor stops 
moving to the end point of the cursor segment. During this time, the 
cursor has no movement.  

Moving Duration The duration in which the cursor has movement. 

Speed The speed of the cursor movement.  

Fixed Speed The movement speed is fixed. Select this check box to disable the 
option to set the moving duration. 

Click Point Change the click point’s sound, effect, and timing.   

Type Select the click type to add and customize it (Left click, Middle click, 
Right-click, and Left double-click). 

Click Sound  The sound which is played when a mouse button is pressed. 

Click Time The duration from the time that the cursor appears to the time it starts 
moving. If that cursor is the last one, it is the cursor’s showing time. 

Click Effect The animation effect which is rendered when a mouse button is 
pressed. You can select from: None, Circle, Concentric Circles, and 
Square. 

Size Size of click effect. 
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Color The color which is used to draw the click effect. 

Opacity The opacity which is used to draw the click effect. 

Apply To All Left 
Clicks 

Apply the click sound and effect to all left clicks in the simulation.  

Cursor Path Section 

This section only appears if your project has a cursor path (e.g. Software Simulations).  

Properties Function 

Highlight Type of the highlight effect.  

You can select from: None, Circle, and Square. 

Size Size of the highlight effect.  

It is the radius of the circle in the Circle Highlight or half of the square 
width in the Square Highlight. 

Color The color which is used to draw the highlight. 

Opacity The opacity which is used to draw the highlight. 

Show to end Show the last Cursor to the end of the slide.  

Interactivity Tab  

General Section 

• Name: Show the name of the currently selected object. You can type text here to 
change its name.  

• Cursor: Change the cursor shape. You can let the cursor display in default shape or 
change it to other shape. Select None if you don’t want your project to show the cursor.  

• Tab Order: Allow specifying the tab order for objects. It is the order in which users 
move from one object to another by using the TAB key.  

o Focusable Only: Objects are able to receive focus. However, it will not gain the 

tab focus. 

o Auto: Objects will be automatically ordered. When the TAB key is pressed, objects 
will be selected randomly. 

o Specific Value: Define a specific order for an object. When the TAB key is 
pressed, objects will be selected in the order you’ve set. 

o None: Select this if you don’t want to give objects any tab order. 

• State View: Click to open the Object States pane.  

• Show Toggle Button: For the objects that contain toggle buttons like radio button or 
check box, you can choose to show or hide them by clicking this button. Clearing this 
option will make the toggle buttons invisible to users.  
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• List of Correct Values: Allow setting the correct answer list for a question. It only 
displays for two question types: essay and fill in blank.  

Click Add Value and type text in the box to set the correct answer for a question. Keep 
doing that until you have a desired list of correct answers for the question. When you 

want to delete any answer in the answer list, click the Remove button  next to that 
answer.  

• Pause presentation to wait for user input: If this check box is selected, all the objects 
stop playing as seen in the timeline (users can still interact with them), and the 
presentation resumes when one of the defined actions is executed (Continue 
Presentation, End Presentation, Go to Slide, Go to Slide at Index, etc.). 

If you select this check box, you have to define actions for the question in the Events 
- Actions section.  

Score & Reporting Section 

This section allows you to select the mode of the question and interaction object between 
graded and survey mode and have further settings for each of them. 

When you select the graded mode, the Score & Reporting section will show properties as 
explained below:  

• Mode: Select between graded and survey mode. 

• Report ID: Select this check box to enable the reporting of interaction objects. This 
unique reference number is used for reporting the test result. Only text that contains 
alphanumeric characters (A-Z, a-z, 0-9) and underscore (_) is allowed (maximum 
length=250 characters). 

• Shuffle Answers: Allow shuffling answer choices of a question. This property only 
appears when you are working with some certain types of question: true/false, multiple 
choice, and multiple response.  

• Points: Allow learners to get a specified point that you set in the Points spin box.  

Partial: Allow learners to get the points assigned to the particular correct answer that 
they choose. This option is used when you want to give some answers more or less 
points than some others. When users choose more correct answers, these partial 
scores are added up.  

• Attempts: Set the maximum number of attempts that users could make. If exceeding 
the predefined number, users could not interact with objects anymore. 

Infinite: There is no limit for the number of attempts that users could make. 

• Timeout (ms): Enable you to specify the time limit. If this check box is selected, when 
the timeout occurs, objects will be disabled.  

• Password Field: Entered characters will be displayed as asterisks as if user entering 
password if this option is selected. This option is only available for text box and fill-
in-blank questions.  

• Case Sensitive: Uppercase and lowercase letters are treated differently if this option 
is selected. This option is only available for text box and fill-in-blank questions.  

• Submit: Select the method to submit entered text. This option is only available for text 
box and fill-in-blank questions.  

• Variable: Select the variable which is associated with the text box. The value of 
variable will be updated following the content in the text box. 
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When you select the survey mode, the Score & Reporting section will only show the Report 
ID, Validate User Input, and Password Field property. 

Drag-n-Drop Section 

This section contains the drag-n-drop properties. See Drop Area for more details. 

For drop targets, the following properties are available: 

Accepts: Specify the number of drag sources that can be accepted by a drop target. The 
default value is infinite, but it’s possible to use the finite value from 1 to 10. In this case, you 
can define what happens when users reach maximum accepts. 

• Reject: The drop target doesn’t accept the new dropped object. The dropped object is 
sent back to its original position, and the On Reject event is triggered.  

• Replace the Last: The last dropped object is sent back to its original position, and the 
new dropped object is accepted. Of course, the On Accept event is triggered in this 
case.  

Events - Actions Section 

Events - Actions allows you to define actions for a given event of the question, interaction 
object, or slide of the project. To open this section, select the question/interaction object/slide 

> Interactions tab > Event . 

Alternatively, you can select the slide containing the question or interaction object > 
Properties pane > Interactivity > Events - Actions.  

The image below shows the sample of the question’s Events - Actions.  
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Audio Tab  

The Audio tab is used to change and edit the sound associated with objects, such as shape, 
text caption, etc. in your project. The sound plays when the object starts showing. In general, 
this tab has the same structure and function as those of the Audio section in the Media tab, 
except the Playback Options section.  

To view this contextual tab, select the object > Properties pane > Audio tab  .  

General  

This part shows the name and source of the audio file and its duration. It also contains 
playback buttons to control the audio playing.  

• Click  button to select an audio from project or click  button to import an audio file 
from your computer. 

• Click the Remove button  to delete the audio.   

Recording 

This part allows you to record your own audio track. To record the sound, do the following:  
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1. Select a device from the Input Device drop-down list. 

2. Click the Record button  to start recording.  

3. Click the Volume control button  to adjust the recording volume.  

4. Click the Stop button  when finished.   

Note: You can calibrate the input volume of microphone before starting the recording to 
make sure that the sound level is strong enough. To do this, click Calibrate Input… and scale 
the input volume in the dialog that appears.  

Text To Speech  

This part provides you an alternative source of the sound, which is a text-to-speech sound of 
the text that is entered in the box. By default, ActivePresenter copies the text that is entered 
in the shape into this box. However, you can edit the text by directly entering here.  

To adjust the TTS settings, do the following:  

1. Click the Settings button. The following dialog will appear: 

 

2. Select a TTS voice from the Voice drop-down list. All installed voices are displayed 
here. 

Adjust the speed and volume, then check out the overall effect by clicking the Speak 
button. Repeat the cycle till you are satisfied, then click OK to exit. 

3. Click the Generate button to generate the TTS audio.  

When you generate a TTS audio, the object duration can be shorter than the generated audio 
duration. In that case, ActivePresenter will open a dialog to ask whether you want to extend 
the object duration to match the duration of the generated audio.  

You can also take further adjustments in the Preferences dialog to extend the object duration 
so that it can match the audio duration. Do the following to get it done: Click the 
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ActivePresenter button > Preferences > select Yes in the Extend object duration to match 
the duration of generated audio section.  

Media Tab 

The Media tab is only displayed if you select a media file (audio/video) in your project. If you 
select an audio file, the Media tab will show the Audio section. On the other hand, when you 
select a video file, the Video section will be shown.  

Audio Section 

 

a. General  

This part shows the name and source of the audio file and its duration. It also contains 
playback buttons to control the audio playing.  

• Click the  button to select an audio from project or click the  button to import an 
audio file from your computer. 

• Click the Remove button  to delete the audio.   

b. Recording 

This part allows you to record your own audio track. To record the sound, do the following:  

1. Select a device from the Input Device drop-down list. 

2. Click the Record button  to start recording.  

3. Click the Volume control button  to adjust the recording volume.  

4. Click the Stop button  when finished.   
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Note: You can calibrate the sound level before starting the recording to make sure that the 
sound level is strong enough. To calibrate the sound level, click Calibrate Input… and scale 
the input volume in the dialog that appears.  

c. Text To Speech  

This part provides you an alternative source of the sound, which is a text-to-speech sound of 
the text that is entered in the box. 

By default, ActivePresenter copies the text that is entered in the shape into this box. However, 
you can edit the text by directly entering here.  

To adjust the TTS settings, do the following:  

• Click the Settings button. The following dialog will appear: 

 

• Select a TTS voice from the Voice drop-down list. All the installed voices are displayed 
here. 

Adjust the speed and volume, then check out the overall effect by clicking the Speak 
button. Repeat the cycle till you are satisfied, then click OK to exit. 

• Click the Generate button to generate the TTS audio.  

When you generate a TTS audio, the object duration can be shorter than the generated audio 
duration. In that case, ActivePresenter will open a dialog to ask you whether to extend the 
object duration to match the new audio or not.  

d. Playback Options  

This section provides options to control how the audio is played. These options are available 
only for audio objects, not for the audio files which are attached to other types of objects. 
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• Loop: Make the video replay continuously. When the Playhead reaches the end of the 
range, it will return to the start point and continue playing. This feature is helpful 
especially for adding background music to a project.  

• Autoplay: Make the video play automatically when the slide loads and the Playhead 
reaches the start point of the video time bar.   

• Show Media Controls: Display a separate play bar for the video in HTML5 output, 
which allows users to control the playback. 

• Background Music: Make the audio file play as the Background Music for the 
presentation.  

Video Section 

a. Video 

• General: Show the name and source of the video file and its duration: 

o Click the  button to import a video from the project or click the  button to import 
a video from your computer. 

o Click the  button to delete a video.   

• Playback Options: Allow you to define the playing mode of the video: 

o Loop: Make the video replay continuously. When the Playhead reaches the end of 
the range, it will return to the start point and continue playing.  

o Autoplay: Make the video play automatically when the slide loads and the 
Playhead reaches the start point of the video time bar.   

o Show Media Controls: Display a separate play bar for the video in HTML5 output, 
which allows users to control the playback. 

b. Cursor Effects 

This part is used to change the cursor effects for the recorded video.  

c. Green Screen Effect 

This part allows you to apply the green screen effect for the video. 

d. Blur Effect 

This section is activated only if your video has a blur effect, which is used to blur an area in 
a video.  

Slide Properties Tab 

This tab allows you to change properties of the slide. It has four sections which are General, 
Background Fill, Background Image, and Accessibility.   

General Section 

This section allows you to view and edit the general information of the slide. 
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Property 
Default 
Value 

Function 

Name  Blank  

Title of the slide. This property will be used as a table of 
contents (TOC) entry in the HTML5 output or as a brief 
description of slides in document outputs. 

When planning navigational jumps among slides, slide name is 
very useful. 

Description  Blank  

Your comments about the content. While exporting the project 
to document formats (PDF, MS Word, Excel, PowerPoint), you 
can choose whether to export slide description. For example, if 
you plan to present the slides personally, you can enter your 
speech associated with the slide in this text box (equivalent to 
the “Notes” field in PowerPoint). 

Duration  3000 ms  

You can set the duration of each slide in milliseconds. This 
duration is represented by a slide time bar in the timeline. 

This duration is the default value to start with. If any object in the 
slide ends beyond this time limit, ActivePresenter automatically 
extends that slide's duration to display all the objects. You can 
also change the duration of the slide by dragging the slide time 
bar along the timeline. 

Auto 
Advance 

 

With this option, the presentation automatically jumps to the 
next slide when the current slide completes. If you disable this 
option, use actions to advance slides. 

Note: This option is independent of the option Pause 
presentation to wait for user input. 

Background Fill Section 

This section allows you to set the background fill (color or image) of the slide. 

Property Function 

Solid Fill 

 
Fill the background of the slide with a single color. 

1. Click the color picker and select a color. 

2. Drag the slider along the Opacity bar to change the opacity value. 
You can enter a value in the Opacity spin box, or click the up/down 
arrow button to increase/decrease value respectively.  

Gradient Fill Fill the background of the slide with a gradient of colors.  
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Image Fill Fill the background of the slide with an image.  

Hide Background 
Graphics 

Hide objects in the slide layout that is used by the slide.  

Apply to All Apply the changes you’ve made to all slides in your project. 

Reset 
Background 

Restore the default value of the slide’s background.  

Background Image Section 

Background images can be used for many purposes, such as showing a corporate logo 
throughout the presentation, setting different backgrounds for different segments/subjects of 
the presentation, and showing a theme.  

 

• To import an image to a project as the background image, you can click the  button 

to select a background image from an ActivePresenter project or click the  button to 
import a background image from your computer. The new inserted image will be 
automatically stretched to fit the slide size.  

When you choose to import an image from project, ActivePresenter will display the 
Select an image… dialog where you can choose which image to import.  

Click the Remove button  to delete the background image.  

• Change the background image position and size (in px or %) using spin boxes. 

o Left: X position of the background image from the top-left corner. 

o Top: Y position of the background image from the top-left corner.   

o Width: Change the width of the background image.  

o Height: Change the height of the background image. 

• Restore Original Size: Restore the original size of the inserted image.  

• Fit To Background: The inserted image will fit the background size. 

Accessibility Section 

Property Function 
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Auto Label If this property is selected, accessibility text will be generated automatically 
from the slide name and slide description. 

Name Accessibility name of the slide. Screen reader will read this text aloud when 
the slide appears. 

Description This provides more information about the slide. Screen reader will read this 
text aloud when the slide appears after reading the accessibility name. 

Resources Pane 

The Resources pane provides you with all the resources that are available in the current 
project. It has three tabs: 

• Images: Image resources in the current project. 

• Audio & Video: Audio and video resources in the current project. 

• Other Resources: Other resources in the current project. 

There are some different ways in which resources get into a project, being shown in the 
Resources pane: 

• Resources added by users: 

o Audio files by inserting, recording narration, or using Text To Speech. 

o Video files by inserting or recording. 

o Image files by inserting or capturing. 

o Other resources that are added by using hyperlink or the Resources menu in the 
player. 

• Logical resources created by certain operations: Audio/video splitting, audio/video 
range editing, slide splitting. 

Images Tab 

As being shown in the screenshot below, the Images tab has the Toolbar and Preview 
section. The Toolbar section contains buttons for managing image resources.  

Button Function 

 Select to view resources either as thumbnails or items. 

 Add an image from the computer (or LAN, etc.).  

 Select the resources that are unused in the current project. 

 Remove the resource from the project storage area. 

 Export an image to a file. 

 Launch the Image editor and load the image in it. 

 This button triggers the Image Resource Properties dialog.  
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You can also click the resource icon (image/video/audio) to view the resource 
information and show the dialog.  

 Toggle the Slide Background type of images.  

 Toggle the Object Background type of images. 

 Toggle the Cursor type of images. 

The Preview section shows the resources. The currently selected images have dark blue 
borders. You can drag any resource from here into the slide to use it.  

Audio & Video Tab 

The Audio & Video tab also has the Toolbar and Preview section. The Toolbar section 
contains icons to manage the audio and video resources. The buttons work as follows: 

Button Function 

 

Select to view resources either as thumbnails or as items.  

 

Add an audio/video clip from the computer (or LAN, etc.).  

 

Select the resources that are unused in the current project. 

 

Remove the resource from the project storage area. 

 

Export (save) the media as a file. 

 

This button triggers the Audio/Video Resource Properties dialog. 

You can also click the resource icon (image/video/audio) to view the resource 
information and show the dialog.  

 

Toggle the Audio type of media. 

 

Toggle the Video type of media. 

The Preview section is placed in the center of the pane. This section shows the resources 
(audio files and video clips). The currently selected resource has a dark blue border. You can 
drag any resource from here into the slide to use it.  

Other Resources Tab 

The Other Resources tab also has the Toolbar and Preview section. The Toolbar section 
contains icons to manage the resources. The buttons work as follows: 

Button Function 

 

Select to view resources either as thumbnails or as items.  

 

Add a resource from the computer (or LAN, etc.).  

 

Select the resources that are unused in the current project. 
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Remove the resource from the project storage area. 

 

Export (save) the media as a file. 

The Preview section is placed in the center of the pane. This section shows the resources. 
The currently selected resource has a dark blue border.  

Resource Properties Dialog  

Video Resource Properties Dialog  

The dialog has two tabs which are General and Details tab. 

The General tab contains generic information about the video such as video name, duration, 

format, and data size. You can rename the video if needed. You can use the Play button  

or Stop Playing button  to preview or stop previewing the video respectively. Click the 

Change Volume button  to change the video output volume.  

The Details tab displays more detailed information about the video, for example, audio sample 
rate, audio channels, and video frame rate.  

Audio Resource Properties Dialog  

This window also has two tabs which are General and Details tab.  

The General tab contains generic information about the audio. It also lets you preview the 
audio.  

Similar to the Details tab of the Video Resource Properties dialog, this tab of the Audio 
Resource Properties dialog also displays more detailed information about the audio (e.g. 
sample rate and channels). 

Image Resource Properties Dialog  

This dialog of images has only one tab which is General tab.  

Name: Show the name of the resource, you can change it without affecting any functionality.  

Type: This is the type of the resource. You can tag the image as Slide background, Object 
background and/or Cursor.  

Cursor HotSpot: This section is for defining the cursor hotspot for the Cursor resource type.  

Selection Pane 

The Selection pane shows all the objects in a given slide by their stack order (z-order). The 
Selection pane is hidden by default. To show the Selection pane, in the View tab, click the 

Selection button  .   
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You can do the following tasks in the Selection pane: 

1. Select slide objects: If a slide has many overlapping objects, it can be tricky to select 
them using the Canvas. With the Selection pane, you can simply click a line in the 
pane to select the corresponding object in the slide.  

If you want to select multiple objects, hold down CTRL while clicking them. If you want 
to select a range of objects, click the first object of the range, then hold down SHIFT 
while clicking the last object. All the objects between the two objects will also be 
selected.  

You can also right-click selected objects and select one from the following operations: 
Cut, Copy, Delete, Bring Forward, Bring to Front, Send Backward, and Send to Back. 

2. Rename objects in the Selection pane: Double-click the name part of an object in the 
Selection pane and type a new name. Giving objects unique names can be helpful 
when you are adjusting their timing values in the timeline or writing custom script which 
refers to the object by name.  

3. Turn visibility state on or off: The Visibility button  controls whether to display the 
object on the Canvas. 

4. Click it to toggle its state (an eye-slash  means the object becomes invisible). The 
best use of this control is to turn an object off to edit the overlapped object easier. 
Note that this control is applicable only during editing; not during playback. It also 
doesn’t affect the output when exporting. The objects which are hidden by this 
command still display normally in the exported materials.  

The Master Visibility button  in the first line toggles the visibility of all the objects at 

once. 

5. Turn lock state on or off: The Lock button  controls whether you can edit the object. 

Click this button to toggle its state. A closed lock  means that the object is “locked”: 
You cannot select its shape by using any pane and you cannot edit it. 

The Master Lock button  in the first line toggles the lock status of all the objects at 
once. 

6. The Expand/Collapse button  is available for object which contains the sub-objects. 
It controls whether to display those sub-objects. You can press RIGHT ARROW or 
LEFT ARROW to get the same result.  

7. You can press UP ARROW or DOWN ARROW to navigate between objects in the 
Selection pane. 

8. You can drag and drop objects to change their z-order in the Selection pane. 
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Calibrate Audio Input Dialog  

The Calibrate Audio Input dialog allows you to select appropriate level of input volume for 
recording audio. 

 

You can calibrate audio in two different modes:  

Manual Calibration 

• Keep the microphone in its normal position, and speak in your normal volume. 

• Click the  button, and speak something into your microphone.  

• At the same time, move the slider to right and increase the gain till the LED bar on the 
right shows yellow bars intermittently. If the bar starts showing red LEDs, move the 
slider a bit to the left (otherwise the voice will be clipped).  

• When you are satisfied with the audio level, click the  button to stop the calibration. 

• Now click the  button to play your recorded voice. If the sound has any defects (e.g. 
breathing noise), take care of the problem and repeat steps 1-4. Or you can use the 
Audio Noise Reduction feature in ActivePresenter. 

Automatic Calibration 

• Click the Auto Calibrate button, and use the microphone normally. 

The Auto Calibrate button turns into Stop Calibration button which you can click 
when you want to stop the calibration.  

• Continue speaking so that ActivePresenter can automatically optimize the gain. 

After a few seconds, the button reverts to Auto Calibrate button. This indicates that the 
calibration is over. 

Regardless of the calibration method, the volume adjustment is accepted only when the OK 
button is clicked. If you click the Cancel button, the new value will be discarded and the old 
value still be applied. 
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Recording Settings Dialog 

When you record screen as video or software simulations, ActivePresenter provides the 
Recording Settings for Video and Recording Settings for Software Simulation dialog 
correspondingly so that you can have settings for the audio/video/webcam quality and storage 
size.  

In the previous versions of ActivePresenter, these settings are included in the Capture Profile 
Editor dialog.  

Both dialogs have three same tabs: Audio & Video, Cursor, and Hotkeys tab. However, the 
Recording Settings for Software Simulation dialog has one more tab which is the 
Annotation tab.  

Audio & Video Tab 

This tab contains two main sections for audio, video, and webcam settings separately.  

 

Video Settings Section 

• Video Codec: ActivePresenter offers two choices which are Flash Screen Video 
(lossless) and H.264/MPEG-4 AVC (lossy). When the flash codec is selected, 
ActivePresenter uses the lossless algorithm in encoding to preserve the quality. But 
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when you select the H.264 codec, ActivePresenter down-samples the video data, 
resulting in the reduction of file size but at the cost of irreversible loss of video detail. 

• Frame Rate: A higher frame rate can increase the size of the recorded video. It may 
also overload simpler computers, because the computer not only has to run all the 
applications, but also captures those screens in real time. In the worst case, you will 
see dropped frames in the captured video. 

On the other hand, a lower frame record will appear jerky. This particularly happens 
with the rates which are lower than 15 frames/s. Besides, you may miss capturing 
some low-duration events (something that just flashes on screen and vanishes). 

The most commonly used range is 20-30 frames/s. 

• Key Frame Every: This is the number of continuous non-key frames between key 
frames. When recording video, ActivePresenter will automatically place a key frame 
every n frames. 

When you change the frame rate, ActivePresenter automatically adjusts this setting so 
that the video will have exactly one key frame every four seconds. But you can 
manually change this rate. 

Key frames are full frames that video player can jump directly to, a higher value results 
in a (little bit) smaller video size, but will make seeking less accurate. Also, in case of 
corruption, lesser number of frames are lost because the key frames spaces are closer. 

As a compromise, the [4 - 400] range is used. 

• Quality: When you select one of the lossy codecs, ActivePresenter allows you to select 
a quality level between 1 (min) and 100 (max). The higher the number you select, the 
better the video quality and the larger the file size. 

Audio Settings Section 

• Audio Codec: ActivePresenter offers a choice of three audio codecs which are 16-bit 
PCM, (lossless), Vorbis (lossy), and MP3 (lossy). When the 16-bit PCM codec is 
selected, ActivePresenter uses the lossless algorithm in encoding to preserve the 
quality. But when you select the Vorbis or MP3 codec, ActivePresenter uses the lossy 
algorithm in encoding, resulting in the reduction of the file size and the irreversible loss 
of audio quality. 

• Sample Rate: The incoming analog sound is firstly converted to digital form and then 
stored in the disk. This digital sound isn’t the exact replica of the original, some fidelity 
is always lost. The fidelity of the digital sound depends on the Sample Rate and Bit 
Rate. This means the higher the sampling and bit rate, the better the fidelity. However, 
higher fidelity also increases the file size, which means more data needs to be stored. 

• Channels: Choose from Mono and Stereo channel. Unless you are opting for a studio-
recorded sound track, Mono channel is sufficient. (During playback, the sound card 
feeds the same sound in left and right channels). Stereo recording needs to double the 
storage size as compared to Mono. 

• Bit Rate: This is the amount of compressed data needed to store one second of sound. 
The higher the bit rate you set, the better the quality and the larger the size the audio 
file has. This option is only available if the MP3 audio codec is selected because 
ActivePresenter encodes the MP3 audio in constant bit rate mode. 

• Quality: ActivePresenter allows you to select a quality level between 1 (min) and 100 
(max). The higher the number you select, the better the audio quality and the larger 
the file size. This option is only available if the Vorbis audio codec is selected because 
ActivePresenter encodes the Vorbis audio in constant quality mode. 
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Webcam Settings Section 

Choose one from two video codecs: Flash Screen Video and H.264/MPEG-4 AVC codecs. 
They are similar to the video codecs mentioned in the Video Settings section above. See 
Webcam Settings for more details. Note that this section is only activated in recording video 
demos.  

Cursor Tab 

The options in the Cursor tab apply for both the cursor in recorded videos and the cursor of 
the cursor path object.  

 

The Cursor tab contains the following sections: 

Cursor Settings Section 

• Record Mouse Cursor: It is common that you want to record the cursors in a software 
demonstration video, so this option is selected by default. If you don’t want cursors to 
appear in recorded result, clear this check box.  

• Make Cursor Editable for Full Motion Recording: ActivePresenter allows you to edit 
the cursor highlight, mouse click sounds and effects in recorded video if this option is 
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selected before recording. Clear this option if you want the cursors to be rendered 
directly into the recorded video. 

• Exclude Layered Windows While Recording to Reduce Cursor Flickering: When 
recording videos or creating software simulations, some layered windows may appear 
on screen. In that case, ActivePresenter will exclude those windows that you don’t 
want to record. 

Cursor Path Section 

• Real Movement: The mouse movements on screen will be recorded truthfully.  

• Simplified: The mouse movements on screen will be recorded and saved as straight 
or curved lines.  

Note that this section is only available in recording software simulations.  

Automatic Panning Section 

• Make Capture Window Follow Mouse Cursor: When this option is selected, the blue 
rectangle follows the mouse pointer around the screen. As long as the pointer is within 
the blue rectangle, the frame doesn’t move. But when the mouse pointer crosses any 
side of the frame, the frame starts following it. 

• Panning Speed: Set the speed (in pixels/s) at which the frame will start following the 
mouse pointer. Note that very high speeds are unsettling for users, because the small 
blue rectangle presents a blinkered view to begin with, and at high pan speeds, users 
won’t realize which area of the screen you are at. 

Annotation Tab 

This tab controls the annotations and interactions that are automatically added during the 
capturing. (These are distinct from the annotations and interactions added during the editing 
of the captured project.) 

Note that the Annotation tab is only activated when you record software simulations. When 
you record video, this tab is deactivated.  
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The Annotation tab has two main sections, one for the mouse and the other for the keyboard.  

Both have identical options as follows: 

Annotation: Introduce an annotation (mouse/key) that is about to occur or to guide learners 
how to operate. Annotation is usually used for demonstrating and training. 

Correct Message/Incorrect Message/Hover Message: Correct, Incorrect, and Hover 
message are feedback objects. ActivePresenter presentations can provide a feedback to user 
actions when they interact with the HTML5 (in Tutorial, Practice or Test mode; but not in 
Demonstration mode).  

• The Correct message is displayed if the user action is correct.  

• The Incorrect message is displayed if the user action is incorrect. 

• The Hover message is displayed when the user hovers the mouse over the interaction 
object (e.g. mouse click, key stroke).  

Place Annotation inside Active Window Area: Let you place all the annotations that are 
automatically added during the capture inside the active window area. 

Hotkeys Tab 

The Hotkeys tab lets you set the keyboard hotkeys for various functions.  
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The image below shows the Hotkeys tab when you record Software Simulations. If you record 
Video, this tab doesn’t have four last options: Manual Capture, Capture For Next Slide, Start 
Full Motion Recording, and Stop Full Motion Recording.  

 

Select Use Hotkeys to enable all the options below. Otherwise, clear it if you want to disable 
all of them. 

To change any hotkey, just click inside the box corresponding to it, and press the new 
combination of keys on your keyboard. The new combination doesn’t take effect till you click 
the Save button. 

The Capture For Next Slide function is similar to the Manual Capture function except the 
captured screenshot will be used as background for next steps. This function may be useful 
in some circumstances, for example when you want to capture a button in the normal state, 
not in the hover state. 

The Restore Defaults button at the bottom brings back all the default values. This is useful if 
you have experimented with the controls far too much and want to start over. 

To know more in details about hotkeys and how to customize it, see Hotkeys Tab.  
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Webcam Settings Dialog  

Webcam Properties 

Video Proc Amp 

 

Drag the slider to the right or left to increase or decrease the values in this dialog.  

• Brightness: Brightness level that adjusts the amount of lighting on the image. 

• Contrast: Contrast level that adjusts the difference between brightest and dimmest 
areas in the image. 

• Hue: Hue setting that adjusts the color tint of the image through the red-yellow-blue 
spectrums. 

• Saturation: Saturation level that adjusts the amount of color in the image. 

• Sharpness: Sharpness level that adjusts the clarity of the image. 

• Gamma: Gamma measurement. 

• White Balance: Color temperature in degrees Kelvin. 

• Backlight Comp: Configure backlight compensation modes to adjust the camera to 
capture images dependent on environmental conditions. 

• Gain: A multiplier for the RGB color values. 

• ColorEnable: Specify the color enable setting. 
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Camera Control 

 

Drag the slider to the right or left to increase or decrease the values in this dialog.  

• Zoom: Control zooming, measured in millimeters. 

• Focus: Set focus, as the distance to the optimally focused target, in millimeters. 

• Exposure: Specify exposure, in log base 2 seconds. 

• Aperture (Iris): Specify iris setting, in units of f-stop x 10. 

• Pan: Control panning, measured in degrees. 

• Tilt: Control tilting, measured in degrees. 

• Roll: Control rolling, measured in degrees. 

• Low Light Compensation: Configure light compensation modes to adjust the camera 
to capture images. 
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Format Settings  

 

You can change the following settings: 

• Frame Rate:  Change the recording frame rate for webcam. A higher value will make 
the motion in the video smoother but larger file size. 

• Color Space: You can use the default value for this option. 

• Output Size: The dimension of recorded video.   
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ActivePresenter Main Menu 

ActivePresenter main menu appears when you click the ActivePresenter button at the top-
left corner of the application window. This menu is similar to the File menu, commonly seen at 
the top-left corner of Microsoft Office programs.  

The main menu provides access to all common file operations, configuration settings, and list 
of recently opened projects. 

Icon  Command Hotkey  Function 

 
Blank Project  

 

Create a new project using the blank 
theme. 

 
Record Video  Record a screencast as a new project. 

 
Record Software 
Simulation 

 

Record a software simulation as a new 
project. 

 
Responsive Project   Create a new responsive. 

 
Import PowerPoint 

 

Create a new project from a PowerPoint 
presentation. 

 
Open Project...  CTRL+O Open an existing project on your 

computer. 

 
Save  CTRL+S Save the current project. 

 Save As... 

 

Save the current project under a new 
name and different types. 

 Close 

 

Close the current project. 

 
Project > Properties 

 

View and edit some information about 
the current project.  

 
Project > Convert to 
(Non-)Responsive 
Project… 

 Convert from a non-responsive project 
to a responsive one or vice versa. 

 Project > Advanced 
Actions 

 Open the Advanced Actions dialog to 
manage advanced actions. 

 Project > Shrink…  Make a project compact. 
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 Project > Localize  Localize a project to another language. 

 
Project > Reset 
Default Objects 

 Restore the default settings of an object 
type. 

 Recent Projects 

 

Open a list of recently opened projects. 

 
Preferences 

 

View and edit the global settings. 

 
Start Page 

 

Open the Start Page. 

 Exit  

 

Close the application. 

Quick Access Toolbar 

The Quick Access Toolbar includes a set of commands which are independent of the tabbed 
toolbar. This toolbar gives a quick access to commonly used features like saving and opening. 
Note that you cannot move or add commands to the Quick Access Toolbar. 

Icon Command Hotkey  Function 

 
Create Blank Project  

 

Create a new blank project. 

 
Open Existing 
Project  

CTRL+O Open an existing project. 

 
Save Changes  CTRL+S Save the current project. 

 
Undo Last Action CTRL+Z Reverse the last actions. Click the arrow 

to choose the action you want to undo.  

 
Redo Last Action  CTRL+Y Restore the last “undone” actions. Click 

the arrow to choose the action you want 
to redo.  

Home Tab 

The Home tab is the first tab in the tabbed toolbar. It is selected by default whenever you 
launch the application. This tab contains all common tools for inserting slides, formatting text, 
organizing objects, etc. 

Icon Command Hotkey Function 

 
Cut CTRL+X Remove the selected items and place 

them on the clipboard. 
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Copy CTRL+C Copy the selected items and place them 

on the clipboard. 

 
Paste > Use 
Destination Theme 

(default)  

CTRL+V Paste the contents of the clipboard at 
the current location. Adapt the copied 
contents to match the destination 
theme. 

 

Paste > Keep Source 

Formatting  

 Paste the contents of the clipboard at 
the current location. Keep the original 
theme format of the copied contents. 

 
New Slide 

 

Insert a new slide into a project. Click 
the arrow to select a slide. 

 
Layout  

 

Change the layout of the current slide. 
Click the arrow to show the layout 
gallery.  

 
Reset  

 

Restore the placeholders of the current 
slide to their default settings. 

 
Record Screen > 

Record Video  

 

Record a screencast as a new slide. 

 
Record Screen > 
Record Software 

Simulation  

 Record a software simulation as new 
slides. 

 Font Name 

 

Change the font of the selected text or 
objects. 

 Font Size 

 

Change the font size of the selected text 
or objects. 

 
Increase Font Size  CTRL+] Increase the font size of the selected 

text or objects. 

 
Decrease Font Size CTRL+[ Decrease the font size of the selected 

text or objects. 

 
Remove Format 

 

Return the selected text or the text in 
the selected objects to its default 
formatting. 

 
Bold CTRL+B Make the selected text or the text in the 

selected objects bold. 

 
Italic CTRL+I Make the selected text or the text in the 

selected objects italic. 

 
Underline CTRL+U Underline the selected text or the text in 

the selected objects. 
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Strikethrough CTRL+SHIFT+

S 
Strike through the selected text or the 
text in the selected objects. 

 
Text Color 

 

Change the text color of the selected 
text or objects.  

 
Highlight Color  Highlight the selected text or the text in 

the selected object.  

 
Subscript  Format the selected text as subscript. 

 
Superscript  Format the selected text as superscript. 

 
Insert Symbol  Insert a symbol into the selected text. 

 
Insert Hyperlink 

 

Insert a hyperlink into the selected text. 
You can also link to a project resource 
(appears in the Resources pane) or a 
file from your computer. When you add 
a link to external file, that file will be 
attached to the course player 
automatically. 

 
Remove Hyperlink 

 

Remove the hyperlink added to the 
selected text. 

 
Numbering 

 

Add numbering to the selected text. 

 
Bullets 

 

Add bullets to the selected text. 

 
Decrease Indent 

 

Make the selected text closer to the 
margin. 

 
Increase Indent 

 

Make the selected text farther away 
from the margin. 

 
Line Spacing  

 

Adjust the amount of space between 
each line in paragraph. 

 
Align Text Left CTRL+L Align the selected text or the text in the 

selected objects left. 

 
Align Text Center CTRL+E Align the selected text or the text in the 

selected object center. 

 
Align Text Right CTRL+R Align the selected text or the text in the 

selected objects right. 

 
Justify CTRL+J Justify the selected text or the text in the 

selected objects. 
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Text Vertical Align > 
Align Text Top 

 

Align the selected text to the top of the 
object. 

 
Text Vertical Align > 
Align Text Middle 

 Align the selected text to the middle of 
the object. 

 
Text Vertical Align > 
Align Text Bottom 

 Align the selected text to the bottom of 
the object. 

 
Shapes 

 

Insert a shape into a slide. Click the 
arrow to select a shape type.  

 
Interactions 

 

Insert an interaction object into a slide. 
Click the arrow to select an interaction 
object type. 

 
Equation 

 

Insert an equation into a slide. 

 
Arrange > Order  Change the z-order of the selected 

objects.  

 
Arrange > Group  Group the selected objects together to 

create a new group object. 

 
Arrange > Align  Align the selected objects. 

 
Quick Style  Quickly set the style (fill, line, shadow, 

and text) of the selected objects.  

 
Fill  Change the fill style of the selected 

objects. 

 
Line  Change the line style of selected 

objects.  

 
Shadow  Change the shadow style of the 

selected objects. 

 
Variables  Create a variable. 

 
Reference  Add a reference to a variable. 

 
Find CTRL+F Find and replace text. 

 
Replace CTRL+H Find and replace text. 

 
HTML5 Preview  Preview a project in browser.  
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Slide Tab 

The Slide tab contains all the commands for working with slides. Along with inserting slides, 
changing layouts, and importing slides from other sources, you can modify slide background, 
edit active window, and use batch operations to perform certain tasks.   

Icon Command Function  

 
New Slide Insert a new slide into a project. Click the arrow to select 

a slide. 

 
Layout  Change the layout of the current slide. Click the arrow to 

show the layout gallery.  

 
Reset Restore the placeholders of the current slide to their 

default settings. 

 
Record Video Record screen as a video and insert the video as a new 

slide. 

 
Record Software 
Simulation 

Record a software simulation and insert the slides into the 
current project. 

 
Import Images Import slides from images on your computer. 

 
Import PowerPoint Import slides from a PowerPoint presentation. 

 
Import 
ActivePresenter  

Import slides from another ActivePresenter project. 

 
Random Slide Insert a random slide. 

 
Report Slide  Insert a report slide. 

 
Save Slide As Image  Export the current slide as an image. 

 
Edit Background 
Image 

Edit the slide background. 

 
View Active Window  Show/hide the active window area. 

 
Edit Active Window  Enable/disable editing the active window area. 

 
Batch Operations > 
Insert Objects… 

Insert an object type into multiple slides at once.  

 
Batch Operations > 
Delete Objects… 

Remove an object type from multiple slides at once. 
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Batch Operations > 
Convert Closed 
Captions To Audio 

Convert closed captions in specified slides or in all slides 
in your project. 

 
Batch Operations > 
Generate Slide Name 
From First Shape 

Find the first shape in slide and use its text for slide 
name. 

 
HTML5 Preview Preview a project in browser. 

Annotations Tab 

The Annotations tab lets you insert all annotation objects such as shapes, images, videos, 
audio, and zoom-n-pan.  

Icon Command Function 

 
Shapes Insert a shape. 

 
Text Caption Insert a text caption. 

 
Highlight Insert a highlight. 

 
Spotlight Insert a spotlight. 

 
Equation Insert an equation. 

 
Icons Insert an icon. 

 
Gesture Effects Insert a gesture effect. 

 
Footer Insert a footer. 

 
Image Insert an image. 

 
Screenshot Take a screenshot of windows, objects, the full screen, or 

an application or region. 

 
Audio Insert an audio from your computer or create an empty 

audio object for recording or text to speech. 

 
Video Insert a video from your computer or by recording 

webcam. 



ActivePresenter User Manual  Version 7.5 

Menus, Toolbars and Hotkeys > Interactions Tab 314 

 
YouTube Video Insert a YouTube video. 

 
Web Object Insert a web object. 

 
Cursor Path Insert a cursor path. 

 
Zoom-n-Pan Insert a zoom-n-pan. 

 
Closed Caption Insert a closed caption (CC). 

 
HTML5 Preview Preview a project in browser. 

Interactions Tab 

The Interactions tab allows you to insert all interaction objects and questions into slides.  

Icon Command Function 

 
Mouse Click Insert a mouse click. 

 
Key Stroke Insert a key stroke. 

 
Text Box Insert a text box. 

 
Drop Area  Insert a drop area. 

 
Button Insert a button. 

 
Check Box Insert a check box. 

 
Radio Button Insert a radio button. 

 
Animated Timer Insert an animated timer. 

 
True/False Insert a true/false question. 

 
Multiple Choice Insert a multiple choice question. 
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Multiple Response Insert a multiple response question. 

 
Essay Insert an essay question. 

 
Fill in Blank Insert a fill-in-blank question. 

 
Fill in Multiple 
Blanks 

Insert a fill-in-multiple-blank question. 

 
Sequence Insert a sequence question. 

 
Drag-n-Drop Insert a drag-n-drop question. 

 
Rating Scale (Likert) Insert a rating scale question. 

 
Event  Open the Properties pane > Events - Actions section to 

add and manage actions.  

 
Advanced Actions Manage advanced actions. 

 
Message Insert a feedback message.   

 
HTML5 Preview Preview a project in browser. 

Design Tab 

The Design tab allows you to apply a theme or color scheme, or format the slide background. 

Icon Command Function 

 Theme Gallery Apply a theme to a project.  

 
Colors Change the color of the current theme. 

 
Fonts  Change the font of the current theme. 

 
Background Styles Change the background style of the current theme. 

 
Slide Size Change the size of the slides in your project.  

 
HTML5 Preview Preview a project in browser. 



ActivePresenter User Manual  Version 7.5 

Menus, Toolbars and Hotkeys > Transitions Tab 316 

Transitions Tab 

The Transitions tab contains a gallery of all slide transition effects. Use this tab to set up how 
a slide appears. 

Icon Command Function 
 

Transition Gallery Apply a transition effect to a slide. 
 

Effect Options Choose a variant of the transition.  
 

Effect Duration Specify the length of the transition. 

 Slide Duration Specify the length of the slide. 

 Auto Advance  Jump to the next slide automatically when a slide 
completes. If you disable this feature, use actions to 
advance slides. 

 
HTML5 Preview Preview a project in browser. 

Animations Tab 

The Animations tab contains all animation effects that can be applied to objects. 

Icon Command Function 
 

Effect Gallery Apply an animation effect (entrance/exit/emphasis/motion 
path) to an object. 

 Effect Options Choose a variant of the animation. 
 

Start Time Specify the time when the animation starts playing. 
 

Duration Specify the length of the animation. 

 

Add Animation Apply an emphasis/motion path to an object. 

 
HTML5 Preview Preview a project in browser. 
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Export Tab 

The Export tab lets you export a project to many different output formats. 

Icon Command Function 

 
Images Export slides as individual images. 

 
Video Export a project as a video. 

 
YouTube Export a project as a video and publish the video to 

YouTube. 

 
HTML SlideShow  Export a project as a HTML SlideShow. 

 
PDF Document Export a project as a PDF file. 

 
Microsoft Word Export a project as a Microsoft Word file. 

 
Microsoft Excel Export a project as a Microsoft Excel file. 

 
Microsoft 
PowerPoint 

Export a project as a Microsoft PowerPoint file. 

 
HTML5  Export a project as HTML5. 

 
Player Settings Customize the HTML5 player. 

 
HTML5 Preview Preview a project in browser. 

View Tab 

The View tab allows you to show or hide panes and toggle some useful features when working 
on a project. 

Icon Command Function 

 
Slides in Column Show slide thumbnails in the Slides pane in column. 

 
Slides in Grid Show slide thumbnails in the Slides pane in grid. 

 
Slides in Titles Show slide titles in the Slides pane. 
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Slide Master Open the slide master view. 

 
Feedback Master Open the feedback master view. 

 
Timeline Show/hide the Timeline pane. 

 
Resources Show/hide the Resources pane.  

 
Properties Show/hide the Properties pane. 

 
Slides Show/hide the Slides pane. 

 
Selection Show/hide the Selection pane. 

 
Slide Pools Show/hide the Slide Pools pane. 

 
Object States Show/hide the Object States pane. 

 
Object Templates Show/hide the Object Templates pane. 

 
Drag-n-Drop Show/hide the markers that indicate drag sources, drop 

areas, and drop targets along with the connection between 
them. 

 
Tab Order Show the tab order value of objects on the Canvas.   

 
Canvas Snapping Enable/disable snap behavior on the Canvas. 

 
Timeline Snapping Enable/disable snap behavior in the timeline. 

 
Cursor Snapping Make cursor paths move continuously between slides. 

 
Fit on Preview Fit the slide in to the available Canvas area during 

preview.  

 
Zoom Set the zoom level of the Canvas. 

 
Zoom Fit Fit the slide into the available Canvas area. 

 
Language Set the GUI language. 
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Reset UI Layout Go back to the original window layout. 

Help Tab 

The Help tab provides access to the documentation, homepage, user community, the current 
version. It also helps activate or deactivate ActivePresenter and check for updates. Remember 
that most of these commands are available on the Start Page. 

Icon Command Function 

 
User Manual Launch the Help file. 

 
Product Homepage Launch the default browser to access the ActivePresenter 

homepage. 

 

Support Center Launch the default browser to access the user forum/FAQ. 

 
Purchase A License Launch the default browser to access the Pricing page. 

 
Activate Product Enter the license information to activate ActivePresenter.  

 
Deactivate Product Deactivate ActivePresenter on your computer. 

 
Check Updates Check for available updates. 

 
About Provide information about the current version. 

Format Tab 

The Format tab is a contextual tab that appears when an object is selected. Use this tab to 
format and organize objects.  

Icon Command Function 

 
Change Shape Change the shape of the selected objects. 

 Style Gallery Apply a built-in style to the selected objects. 

 
Fill Change the fill style of the selected objects. 

https://atomisystems.com/activepresenter/
https://talk.atomisystems.com/c/activepresenter
https://atomisystems.com/pricing/
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Line Change the line style of selected objects.  

 
Shadow  Change the shadow style of the selected objects. 

 
Order Change the z-order of the selected objects.  

 
Group Group the selected objects together to create a new group 

object. 

 
Align  Align the selected objects. 

Formula Tab 

The Formula tab is a contextual tab that appears when you edit an equation. Use this tab to 
edit and write equations.  

Icon Command Function 

 
Equation Insert a built-in equation. 

 Symbol Gallery Insert a math-related symbol. 

 Structure Gallery Insert a structure. 

Drawing Tab 

The Drawing tab is a contextual tab that appears when you edit (background) images (right-
click an image > Edit (Background) Image). This tab contains many basic photo editing. 

Icon Command Function 

 
Cut Remove the selection and place it on the clipboard. 

 
Copy Copy the selection and place it on the clipboard. 

 
Paste Paste the contents of the clipboard at the current location.  

 
Select Rectangle Select a rectangle area by drawing on the Canvas. 

 
Crop Crop the image so that it contains only the selection. 
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Scale Image Scale an image. 

 

• Image size: Specify the target width and height. 

• Lock ratio: Maintain the aspect ratio of the image. 

• Reset: Bring back the original size value. 

• Interpolation: Specify the algorithm used to scale an 
image (Box, Bilinear, Bicubic, 4th order b-spline, 
Catmull-Rom spline, and Lanczos3).  

Box algorithm is the simplest one and usually gives the 
lowest quality. Lanczos3 is an advanced algorithm with 
the best quality and commonly used in popular image 
editor. However, choosing the most suitable algorithm 
depends on the image content, so you can use try-and-
error tactic to choose the most suitable one.  

 
Insert Image Insert an image from your computer. 

 
Auto Shape Select a shape. 

 
Rotate Right 90o Rotate an image 90o to the right. 

 
Rotate Left 90o Rotate an image 90o to the left. 

 
Flip Horizontal Flip an image horizontally. 

 
Flip Vertical Flip an image vertically. 

 
Antialias Enable antialiasing to draw anti-aliased lines.  

 
Line Draw a line. 
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Polygon Draw a polygon. When you click at various spots, those 

points are added to the current polygon. A double-click 
ends the spline-creation mode. 

 
Spline Draw a spline. As you click at various spots, those points 

are added to the current spline. A double-click ends the 
spline-creation mode. 

 
Pencil Draw freehand with a pencil. 

 
Air Brush Create spray with a color. 

 
Eraser Make an area on the image transparent.  

 
Flood Fill Fill a same contiguous colored area with the current fill 

color. 

 
Text Create rich text by using the text editor. 

 
Blur Blur the selected area. 

 Blur Radius Specify the blur radius. The larger the radius, the more 
blurred the image. 

 
Pen Color Select a pen color for painting or drawing. 

 Pen Opacity Set the opacity level for a pen (0 means fully transparent, 
255 means fully opaque). 

 
Pick Pen Color After selecting this tool, click any area on the image and 

the pen tool will assume that color (hue and saturation) 
and opacity. 

 
Fill Color Set the color filled inside a shape. 

 Fill Opacity Set the opacity level for fil (0 means fully transparent, 255 
means fully opaque). 

 
Pick Fill Color After selecting this tool, click any area on the image and 

the fill color tool will assume that color (hue and 
saturation) and opacity. 

 
Line Width Set the width of the outline of a shape or of the pencil 

tool. 

 
Line Style Set the type of the outline of a shape or of the pencil tool. 
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Zoom Set the zoom level of the Canvas. 

 
Zoom Fit Adjust the zoom level automatically to fit the Canvas to 

the available space. 

Slide Master Tab  

The Slide Master tab appears when you open the slide master view (View tab > Slide 
Master). It contains commands for editing slide masters.  

Icon Command Function 

 
Insert Slide Master Add a new slide master to a project. 

 
Insert Layout  Insert a custom layout into a slide master. 

 
Delete Delete a custom layout. 

 
Rename Rename a layout. 

 
Preserve Preserve a slide master so that it won’t be deleted event 

if not used. 

 
Master Layout  Choose what to include in the master layout.   

 
Insert Placeholder Insert a placeholder into a custom layout. 

 Title Show/hide the title placeholder on a custom layout. 

 Footers Show/hide the footer placeholders on a custom layout. 

 
Themes Apply a theme to a slide master.  

 
Colors Change the color of the current theme. 

 
Fonts Change the font of the current theme. 

 
Background Styles Change the background style of the current theme. 

 
Slide Size Change the size of the layouts.  
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Close Master View  Exit the slide master view and go back to editing slides. 

Feedback Master Tab 

The Feedback Master tab appears when you open the feedback master view (View tab > 
Feedback Master). It contains commands for editing feedback masters.  

Icon Command Function 

 
Insert Layer  Add a new feedback layer to a feedback master. 

 
Delete Delete a feedback layer. 

 
Rename Rename a master layout or feedback layer. 

 Title Include the title placeholder in a master layout or 
feedback layer. 

 Text Include the text placeholder in a master layout or 
feedback layer. 

 Button Include the button placeholder in a master layout or 
feedback layer. 

 
Close Master View  Exit the feedback master view and go back to editing 

slides. 
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Customizing Language 

By default, the display language in ActivePresenter is set to English (United States). If you 
prefer another language, click the View tab > Language > select another language. Your 
change will be applied the next time you open the application.  

Another way to customize the display language is to use the Preferences dialog. Do the 
following: 

1. Click the ActivePresenter button > Preferences. 

2. In the dialog, click the General tab > Program section > select a language. 

3. Click Apply to submit changes. Your change will be applied the next time you open 
the application.  

Customizing User Interface 

ActivePresenter saves the project settings when you close a project. The next time you open 
the application, the settings of the last saved project will be applied to the new one. After 
customizing, if you want to go back to the original window layout, just click the View tab > 

Reset Pane Layout . Your change will be applied the next time you open the application. 

Showing and Hiding Toolbar and Panes 

You can collapse the tabbed toolbar by clicking the Hide/Show Toolbar button (double arrow) 
at the top-right corner of the application window. To show or hide panes, click the View tab 
and select the pane you want. In this tab, you can also: 

• Change the slide view mode in the Slides pane (column, grid, titles). 

• Open the slide master view and feedback master view to work on slide masters and 
feedback masters, respectively. 

• Change the zoom level of the Canvas. 

Changing Pane Position 

You can drag panes, except the Timeline pane, from their current positions by dragging their 
title bars. Alternatively, click the Floating button at the top-right corner of a pane to undock it. 
After undocking a pane, you have two options: 

• Make the pane free-floating by dragging it to an area that isn’t a drop zone. The floating 
pane allows you to position it anywhere on screen, even outside the application 
window. 

• Dock the pane in the highlighted drop zones that appear on screen. Just drag and 
bring the pane to the edge of the window and release the mouse button over a drop 
zone. The pane will be docked into place.  
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Changing Pane Size 

Changing pane size is useful when you want to make your work area larger by reducing the 
pane size, or when you want to view more of the information that appears in a pane by 
increasing its size. 

• To resize a docked pane, move the pointer over the left or right edge of the pane (for 
vertical panes) or over the top edge of the pane (for horizontal panes). When the 
pointer turns into a resize pointer, drag the boundary to resize the pane to the 
dimensions you want. 

• To resize a floating pane, hover over any edge or corner of the pane until the pointer 
turns into a resize pointer, then drag the boundary until the pane reaches the 
width/height you want.  

Customizing Preferences 

Use the Preferences dialog to set how you want ActivePresenter to operate. To open the 
dialog, click the ActivePresenter button > Preferences. The dialog has six tabs, each serves 
a different area. Select the relevant tab to change the relevant settings. 

Tab Category  

General  General options applicable to the entire application. 

Auto Annotation Text Handle how annotation text is auto-generated while capturing.  

Hotkeys Set hotkeys for various operations. 

Tabbed Toolbar Customize the tabbed toolbar. 

Script Editor Features and colors in the JavaScript Function form. 

Miscellaneous Options that don’t fit anywhere in the above tabs. 
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General Tab 

  

Control Function 

Program 

Display Language  Set the display language of the application. 

Max Recently Used 
Projects 

Set how many recently opened projects would be listed. Set 
to 0 to disable this control. Note that a large number isn’t 
actually useful. Instead, cultivate the habit of storing the 
project files in a hierarchical folder system so that you can 
retrieve a project fast. 

Clear List: Select to forget the actual list of recently opened 
projects. 
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Canvas Background 
Color 

Set the color of the Canvas background. Note that this 
control only affects the Canvas inside the editor, it doesn’t 
affect the output at all.  

Reset Window Layout Reset the layout of the application to default. You need to 
restart the application so that this change can take effect. 

Project 

Backup Project Every n 
Minutes 

Set how frequently to back up (save) the project. In rare 
cases when ActivePresenter crashes, it allows you to 
recover the last opened project from the latest back-ups. 
Set to 0 to disable this control.  

Note that these aren’t permanent back-ups. Back-ups are 
automatically removed when a project is closed. 

Project Language Set the default project language. 

Project Location Set the default folder path where all new projects will be 
saved. You are allowed to change this folder each time you 
save a new project. 

Template Location Set the default folder path where all custom templates will 
be saved.  

Default Project Size Set the default project size. To change the size, enter a new 
value or choose from the Preset Size list. 

Restore Defaults Go back to the original settings. 

Auto Annotation Text Tab 

This tab defines the auto-annotation text that is automatically added when you record 
software simulations. 
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ActivePresenter can automatically generate the text for annotations based on what you are 
interacting with while capturing. For example, when you type your user name into a log-in 
screen, ActivePresenter can create a callout which says “Type [XXX] into User Name text 
box”. 

You can easily customize how annotation text is generated while capturing. There are three 
parameters available to specify dynamic content. Each parameter has the form {$XXX}, in 
which XXX is the parameter name: 

{$name} Name of the item with which you are interacting while capturing. For example, 
when you enter your name in a log-in screen, the text box may have a name 
like “User Name”. 

{$type} Type of the item with which you are interacting while capturing. The item types 
are provided by the Operating System. For example, you are typing in a text 
box, then the item type is “text box”. If you are clicking a button, then the item 
type is “button”. 
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{$value} What you are entering while capturing. If you are pressing a key, the value is 
the key that you’ve pressed. If you are entering text into a text box, then the 
value is the text you’ve entered. 

Note that the Prefix Modifiers check box is selected by default to allow using modifier keys 
(SHIFT, CTRL, and ALT) in mouse clicks and key strokes. 

Hotkeys Tab 

The Hotkeys tab shows all hotkeys in ActivePresenter. You can assign hotkeys to commands 
or remove any hotkeys you don’t want.  

 

All the major commands are grouped functionally in a hierarchical tree. The tree consists of 
nodes; each node contains a group of related commands. To expand any node to list the 
commands or other items that it contains, click the  button to its left. Any currently used 
hotkeys are shown in the Current hotkey box on the right side of the dialog. 
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Assigning Hotkeys 

1. Select a command or item that you want to assign a hotkey. 

2. Click inside the New hotkey box, then press the combination of keys you want to 
assign. 

3. Look at the Currently assigned to box to see if the combination of keys is already 
assigned to a command or item. If the combination is already in use, press a different 
combination. 

4. Click the Add button to assign the new hotkey. 

5. Click Apply to submit changes. 

For example, select the Save command in the tree view, then press CTRL+A in the New 
hotkey box. The combination is automatically captured and displayed. You are informed that 
the combination is currently used by the Select All command. 

Now you have two options: Either try another hotkey (and repeat the cycle), or press the Add 
button to reassign the CTRL+A hotkey to the Save command. If you choose the second 
option, this hotkey will no longer be assigned to the Select All command.  

Removing Hotkeys 

1. Select a command or item that you want to remove a hotkey. 

2. Click the Remove button. 

3. Click Apply to submit changes. 

To go back to the default settings, click the Restore Defaults button. 

Tabbed Toolbar Tab 

You can customize the tabbed toolbar to improve the performance in editing. In this tab, the 
box to the left contains all the commands which are organized in groups. The box to the right 
is the structure of the current toolbar. 



ActivePresenter User Manual  Version 7.5 

Customizing ActivePresenter > Customizing Preferences 332 

 

Note: You cannot reorder the default commands, hide their names, or rename them. Besides, 
if your experiments go haywire, you can always go back to the default settings by clicking the 
Restore Defaults button. All your customization will be removed. 

Reordering Tabs, Groups and Commands 

You can change the order of all the tabs/groups/commands but not the default commands.  

1. In the right box, select the tab/group/command that you want to move.  

2. Click Move Up  or Move Down  until you get the order you want.  

3. Click Apply to save and see your changes. 

Removing Tabs, Groups and Commands 

1. In the right box, select the group (both default and custom) or tab/command (custom 
only) that you want to remove.  

2. Click the Remove button to exclude them from view. 

3. Click Apply to save and see your changes. 

To remove the default tabs or groups/commands like the Home or Slide tab, clear the relevant 
check box in the right box. Note that you cannot hide contextual tabs such as Format and 
Drawing. 
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Adding Tabs and Groups Back to the Toolbar 

After removing a tab/group from view, you can still add it back to the tabbed toolbar by: 

1. In the left box, select the tab that you want to bring back. In case you want to recover 
a group, you must select a tab in the right box to place it. 

2. Click the Add button to retrieve the selected tab/group.  

3. Change the tab/group order if needed. 

4. Click Apply to save and see your changes. 

Creating Custom Tabs and Groups 

You can add new tabs to the tabbed toolbar and add new groups to both default and custom 
tabs. Regarding commands, you can only add commands to custom groups. The custom tabs 
and groups have the word (Custom) after their names, but this word doesn’t appear in the 
tabbed toolbar. 

To create custom tabs/groups, do the following (skip unnecessary steps, if any): 

1. In the right box, select the tab to which you want to add a new group. In case you want 
to create a tab, the new tab with be inserted below all other tabs or the selected one. 

2. Click New Tab… or New Group… to create a new tab or group, respectively. 

3. In the dialog, enter a name for the new tab/group and click OK. 

4. For custom groups, select Hide Command Labels to hide the labels while showing 
the icons in smaller size. 

5. In the main dialog, click Apply to save and see your changes. 

After creating a custom group, you need to add commands to it. Use the Add button to add 
commands from the left box. 

Renaming Tabs, Groups and Commands 

You can rename both default and custom tabs and groups, but for commands, you can only 
rename the ones added to custom groups. For those included in default groups, you cannot 
rename them. 

Script Editor Tab 

Use this tab to customize coding preferences. The tab has three parts. The Color box to the 
left lets you change syntax highlighting preferences. The View box in the center lists some 
code view options. The Preview box to the right allows you to preview the coding content. 
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To customize syntax highlighting preferences, click the color rectangle next to each element 
and change the color. All changes you make are immediately reflected in the preview editor 
on the right side. 

Below are the code view options: 

• Line Number: Display line numbers along the side of the code. 

• View White Space: Display dots in place of white space. 

• Auto Insert (), {}, []: Selected by default. This option automatically inserts matching 
closing brackets to the code. 

You can always go back to the default settings by clicking the Restore Defaults button. All 
your customization will be removed. 

Miscellaneous Tab 

This tab is a “catch-all” tab. It contains application options that could not be placed in other 
tabs. 
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Control Function 

Automatic Updates 

Automatically Check for 
Updates 

Selected by default. ActivePresenter periodically checks 
for updates when it starts. 

Connection Settings Set connection settings to use a proxy (no proxy, use 
system settings (default), manual configuration. Check 
with your admin and set the value. 

Log Settings 

Enable Logging Selected by default. If you disable this option, no logs will 
be kept. 
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Log UI Level Select the log level to show. Only log messages with the 
severity level higher or equal to the selected level are 
displayed. The other logs are written to the log file silently. 

Verbose Mode In verbose mode, more details are captured. This is better 
for troubleshooting. 

Log Level There are five levels: fatal error (most severe level), error, 
warning, message, status, and information. If you select 
any level, the log will be kept of that level and higher levels 
(if any). 

For example, selecting Warning keeps a log of the top 
three types of problems, but selecting Fatal Error keeps a 
log of fatal errors only. 

View Log Show the log file. The log file is automatically cleared and 
started over when its size reaches 2 MB. 

Confirmation Settings 

Warning none-ANSI path 
when export  

Selected by default. When you export your project, there 
are some outputs that cannot be opened or run properly if 
the file name contains non-ANSI characters. This option 
specifies whether you should be asked in such cases or 
not. 

Show language confirmation 
when importing XLIFF 

Selected by default. When you import from XLIFF, 
chances are that the target language is unspecified or 
invalid. A language confirmation will appear letting you 
select a target language to continue. 

Extend object duration to 
match the duration of 
generated audio 

Select any of the choices to determine how 
ActivePresenter performs when converting text to 
speech: Should it display the dialog so that you can make 
further changes to the TTS settings before converting? 

Save external resource 

Link resources with file size 
greater than n MB 

When an external file is added to a project, 
ActivePresenter creates a copy of the file and stores it in 
that project (to ensure that even if you rename, move, or 
delete the original file, the inserted item will not be 
affected). 

If the original file is large, storing it directly in the project 
will consume more disk space than necessary, which 
severely reduces the performance and prones to errors 
that might corrupt the project.  

In that case, ActivePresenter doesn’t store the original file 
directly in the project. Instead, it maintains the copy of the 
original file and creates a link in the project which points to 
the copy. 
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This parameter defines the threshold above which 
ActivePresenter creates a link to the resource instead of 
storing the original file directly in your project. 

Use software rendering 
instead of GPU rendering 

Improve performance for some computers which have a 
strong CPU but a weak GPU. 

Use Direct3D for recording 
screen 

Clear this check box if you cannot capture the screen due 
to graphics driver-related issues. 

Use JPEG color range (full 
range) when exporting video 

Select to fix the “white color turns grey” issue when 
viewing output videos on some systems. 

 

 

Last updated: 2019/01/15 
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